Currently Being Moderated

Browser Support for SAP

SAP software runs in a variety of browsers from several different manufacturers. We aim to keep you informed as to which browsers SAP supports. You'll find up-to-date information pertaining to browser support of SAP in the Product Availability Matrix (PAM) (SMP login required).

 

The PAM bundles technical and release planning information such as release dates, end-of-life dates and release information. One of the key areas in the PAM is browser support. It tells you which browser (versions) SAP supports for each release (e.g. NW 2004, 7.0, 7.0 EHP1, etc.). It also specifies which SPS you need to install and distinguishes between different platforms such as XP, Vista, MAC OS and different technologies such as Web Dynpro, SAP NetWeaver Portal, SAP NetWeaver Business Client.

 

For example, if you need to know whether Web Dynpro runs in Internet Explorer 7 on XP in Release 7.0 EHP1, then you can find this out from the PAM and also see which SPS you have to install.

 

Usage Note:

SAP software and technology is optimized to run on the most recent Web browsers available from the major browser providers. Using the most recent versions of these supported browsers allows you to get the most out of the available features and extensive functionality of your SAP software and technology. The most recent versions of Web browsers help realize better performance and improve security in your latest SAP products. For example, SAP NetWeaver 7.3 is optimized for Windows Internet Explorer 7 and 8.

 

To that end, many of the rarely used or older versions of supported browsers have been removed from the browser column in the standard display in the Web Browser Platforms tab for each selected product version. However, SAP continues to support browser types and browser versions that are older and/or rarely used to meet customers’ specific licensing agreements and support options. The related documentation will continue to include information on the older browser types and versions.

If you are using an older browser type or version not listed in PAM, please contact your SAP system administrator or SAP account representative to ensure delivery of the appropriate browser.

 

Note: The most up-to-date information is in the PAM slides.

  • Click on the major release you are interested in, for example SAP NetWeaver 7.0 (EHP information (e.g 7.01) is provided with the main release (e.g. 7.0).
  • If a dialog box appears choose Open to view the PAM slides.
  • Note: If the dialog box has been blocked by the popup blocker please specify that you want to download the file.
  • Scroll down to the slides on browser support. SAP updates the PAM slides on the first Monday of the month.

For further information check the SAP Browser Support Strategy

For questions regarding the SAP NetWeaver browser support, please contact Manfred Lutz.

Delete Document

Are you sure you want to delete this document?