Currently Being Moderated

IBM AIX and Java

In May 2006 IBM System p brand and SAP announced the direction to enhance the IBM AIX 5L and newer JDK 1.4.2 for SAP NetWeaver 2004 and SAP NetWeaver 7.0x based applications. The new IBM JDK 1.4.2 (the term Hybrid JVM (J9) is often used) for SAP NetWeaver applications on AIX 5L and newer is 100% upward compatible for all SAP business applications and, compared to the classical AIX JDK (Sovereign), provides a more consistent runtime behavior, enhances memory management, and improves debugging capabilities. The J9 technology is the common used JVM on AIX now.
Starting with SAP NetWeaver 7.1x the SAP JVM is the only supported JVM on AIX. The IBM JVM is no longer supported.

 

Key Resources

 

End of support for partner JDKs for SAP

We would like to remind you that with the introduction of the SAP JVM 4 the end of SAP support for partner JDK’s was announced in 2011 (for details see SAP note 1495160). Effective since October 2012, only SAP JVM 4 is now supported for SAP Web Application Server 6.40 and SAP NetWeaver 7.00 systems running the Java stack.

 

New prerequisites for SAP JVM 5.1 and 6.1 on AIX

Starting from July 2012, SAP JVM 5.1 and 6.1 will be built on AIX 5.3 TL9 SP7 with XLC 10.
SAP JVM 5.1 and 6.1 are used as the standard JDK for the NetWeaver Application Server Java 7.10 and newer. Up to now, the SAP JVM 5.1 and 6.1 were built with the XLC 8 compiler. However, to use new Power and AIX specific features SAP decided to use IBM's XLC 10 compiler for all SAP JVM versions. The technical consequence is the minimum operating system level of AIX 5.3 TL9 SP7 to run SAP JVM 5.1 and 6.1. For details check SAP Note 1663178.

 

SAP JVM 4 as Replacement for Partner JDKs 1.4.2

SAP developed its own Java Virtual Machine (JVM) 1.4.2, named SAP JVM 4, to ensure the guaranteed support for SAP Web Application Server 6.40 and SAP NetWeaver 7.0 systems. The replacement is required because of end of support for the partner JDK 1.4.2 solutions.

 

IBM JVM 1.4.2 64-bit in SAP NetWeaver Application Server Java Environments

A new whitepaper has been published by IBM dealing with the usage of IBM's JVM 1.4.2 for SAP NetWeaver Application Server Environments. The paper was jointly written by SAP and IBM. Its content is based on experiences from development and customer support, typical issues and their solutions, tuning options and tool usage.

 

More on AIX

IBM AIX Best Practices

IBM AIX High Availability, Disaster Recovery and Storage

IBM AIX and Virtualization

 

Related SAP Notes

973227 Overview of AIX JVM for NetWeaver 2004 and 7.0

1048686 New prerequisites for SAP JVM 5.1 and 6.1 on AIX

1121904 Recommendations for paging space

 

Related IBM and Database Areas

SAP on DB2 for Linux, Unix, Windows

SAP on Sybase

SAP on IBM i

SAP on DB2 for z/OS

SAP on IBM Power Linux

IBM and SAP

 

Related Resources on SCN

Virtualization and Cloud Infrastructure

Adaptive Computing

High Availability

Security

Monitoring

Delete Document

Are you sure you want to delete this document?

Actions