11 Replies Latest reply: May 6, 2012 11:23 PM by Daniele Sangiovanni RSS

ABAP Devs want EHP2

S.W. E.
Currently Being Moderated

Hi Experts,

 

according to the page below, "new" functions for abap developers have been implemented with EHP2:

 

What's New in ABAP with SAP NetWeaver 7.0 EhP2

 

i just started searching for arguments and information how we (the developers) can get these new functionalitys. now i am at a "totaly confused" state:

 

- we can not install EHP2 only, we need to install the newest EHP (which is now 6, in older posts, its stated that EHP5 has to be installed)?

 

- EHPs can be installed for specific components, which do we have to use to get the ones mentioned above?

 

- do we need to activate any business function?

 

it would be nice if you can help clarifying these points to me.

 

best regards

steve

 

btw. according to the info given by SAP, the EHPs will not change any business function, even in a heavly enhanced environment (many custom programmes and some enhancements). so in short, it should be possible to install EHP5 / EHP6 without involving any changes to the usual users, right?

  • Re: ABAP Devs want EHP2
    Deepika Paturu
    Currently Being Moderated

    Hi Steve,

     

    For more information regarding the various enhancement packages availability please refer the link

     

    https://websmp205.sap-ag.de/pam

     

    EHP5 is the latest enhancement package available for ERP 6.0 as EHP6 is still in the ramp-up phase and is not in the general

    availability.

     

    And EHP2 is the latest enhancement package for SAP Netweaver 7.0

     

    For more information about the technical usages please refer the note 1165438 & 1324838 and select the usage according to your business requirement.

     

    Thank You.

     

    Regards,

    Deepika

    • Re: ABAP Devs want EHP2
      S.W. E.
      Currently Being Moderated

      Hi Deepika,

       

      thanks for you answer and the links!

       

      so no need for EHP6 then

       

      Cheers

      Steve

       

      Edited by: Steve-Wesley Emmert on Dec 28, 2011 2:02 PM

      • Re: ABAP Devs want EHP2
        Deepika Paturu
        Currently Being Moderated

        Hi Steve,

         

        As of now EHP6 is not required as it is still not released. If you are satisfied with the reply then i would request you to kindly mark this thread as closed giving your valuable feedbacks.

         

        Thank You.

         

        Regards,

        Deepika

        • Re: ABAP Devs want EHP2
          S.W. E.
          Currently Being Moderated

          Hi Deepika,

           

          no it is not closed as there are still open questions from the first post AND i am going through the documentation on the SAP website.

           

          What i now know is that we have to install EHP5 for ECC 6.0 to get the EHP 2 for Netweaver. I am not shure if we have to activate something afterwards to get the new ABAP / Coding functionality like the code completion for a function module.

           

          Regards

          Steve

          • Re: ABAP Devs want EHP2
            Deepika Paturu
            Currently Being Moderated

            Hi Steve,

             

            Regarding activating a business function in your system to enable new functionalities please refer the SAP KBA

             

            1641394 - Activating Business Function in Switch Framework (SFW5)

             

            To select the business function of interest, the needed techical usage need to be selected while generating the stack xml file for the upgrade.

             

            A Business Function is always enabled by installing a Technical Usage.A Technical Usage is a logical grouping of ABAP software components,Java software components, XI Content, or Portal Content.

            In order to implement a Technical Usage, you have to have an SAP ERP 6.0 system in place, or you are in the process of upgrading your system landscape to SAP ERP 6.0. See the Master Guide for SAP enhancement

            package 5 for SAP ERP 6.0 for more details.

            If you are in the course of an upgrade to SAP ERP 6.0, you may include parts (i.e. "Technical Usages") of the Enhancement Package directly in the upgrade.

            The procedure is supported by the SAP Solution Manager (note 1155041) and is described in the ERP Upgrade Guide at:

             

            https://service.sap.com/erp-upgrade  ->  SAP ERP Upgrade Guides.

            Identify the appropriate technical usage with the help of the attached

            mapping document 'EhP5_BF_TU_Mapping.pdf'.

             

            And also refer the note 1287216 - MOPZ: pre-select technical usages

             

            Thank You.

             

            Regards,

            Deepika

          • Re: ABAP Devs want EHP2
            Mateus Pedroso
            Currently Being Moderated

            Hi Steve-Wesley

             

            For EHP5 keep in mind that you must have Solution Manager SP23 at least. The latest version is SP28 and is highly recommended.

            Regarding the business function and switch framework.

            It doesn't matter if you have or not business functions activated in your ERP system, mopz will do the check and will perform the calculation based on the source components and the business functions activated in SFW5.

            During the first steps of mopz, you'll see that you need create some specific RFC (Read RFCs) between solman and the ERP system. This RFC is needed to solman connect in the managed ERP system and check the Switch framework, so mopz will take in account this information during the calculation.

            For example.

            You activated the business functions of IS-OIL, let's suppose that this is a BF that you can't deactivate, and you'll receive this information during the activation, it doesn't make sense for mopz calculate the BF for the other components as you can have just only one activated in your system, so mopz will ignore the other components.

            • Re: ABAP Devs want EHP2
              S.W. E.
              Currently Being Moderated

              Hi both,

               

              maybe i need to rephrase my question.

               

              there are many new ABAP functionalities and functions for the ABAP Workbench (TC: SE80 etc.) comming with EHPs 5 (& 2). As these are for developing and not for any "new" business functions i do not think that i have to activate any business funtion. But i did not find an simple and clear statement about this.

               

              What i want: have the new developers tools without affecting the enduser.   What i need: some basic answer to the question: do i get this by just installing, or is there anyting else to consider.

               

              another rephrasing:

              --> Can i talk to the key user and say: we developers need the EHP5. If we install it, we have some great new stuff and can test and develop even better. But you, loved user, wont see any difference and all your processes wont change (except the SolMan crew forgets SPDD / SPAU). But you, user, are able to get new functions by just activating them, someday in the future.

              (Info: The customer does not want new business functions. but the developers want an up to date development environment)

               

              Thanks

              Steve

               

              Edited by: Steve-Wesley Emmert on Dec 28, 2011 4:01 PM

              • Re: ABAP Devs want EHP2
                Sunny Pahuja
                Currently Being Moderated

                Hi,

                 

                Upgrade does not effect any existing business processes. But when you plan for upgrade then lot of new functionality will be delivered that time you need to do complete testing. Users will see some differences as some new functionality comes in new patches that time you need to do the testing.

                 

                As far as business activation is concerned that you can do anytime after upgrade.

                 

                Thanks

                Sunny

                • Re: ABAP Devs want EHP2
                  Christian Cabrita
                  Currently Being Moderated
                  • Hello there,

                  It looks quite ambiguous. As mentioned Deepika Paturu, you must figure out these two things :

                  - Enhancement Packages exist for the ECC part of your SAP ERP systems (EHP1, EHP2,...,EHP5,EHP6 in ramp-up)

                  - Enhancement Packages exist for the Netweaver part (EHP1 for NW, EHP2 for NW, EHP3 for NW...)

                   

                  Both Enhancement Packages are related as Netweaver EHP's are now prerequisite for ECC EHP's installation :

                  - Enhancement Package 4 for ECC requires Enhancement Package 1 of Netweaver

                  - Enhancement Package 5 for ECC requires Enhancement Package 2 of Netweaver

                  - Enhancement Package 6 for ECC requires Enhancement Package 3 of Netweaver

                   

                  But it is impossible to implement EHP2 of Netweaver without upgrading the ECC part to 605. You seem to have considered it.

                  In my point of view, you shouldn't consider to upgrade to EHP5 for ECC (then... EHP2 of NW) for development reasons. You'll have to import Support Packages during the Upgrade and new Software Components for SAP_APPL EA-APPL for exemple. Even if you don't activate any Business Function, you'll have to do a full test regression of your solution.

                   

                  You must consider other things :

                  - Enhancement packages for the ECC components are made of activable Business Functions. Changes are only made after an explicit activation.

                  - Enhancement packages for the NW components are not made of Business Functions. Changes are immediatly effective for the technical components. The improvements that you want for the development team are in Netweaver Enhancement Package 2

                   

                  Best regards,

                  Christian

              • Re: ABAP Devs want EHP2
                Daniele Sangiovanni
                Currently Being Moderated

                Hi Steve,

                 

                I'm going to do well in your same stage of the upgrade.

                 

                Can you give me some feedback ?

                Can you explain how you've answered your points ?

                 

                Regards

                Daniele

Actions