9 Replies Latest reply: Apr 18, 2012 3:37 PM by Klaudio Gospic RSS

Metamodel version validation when compiling Processes

Michael Chytracek
Currently Being Moderated

Hi Experts,<br>

<br>

After upgrading Developer Studio to 7.3 SP07 PAT0000 (latest available from SAP update site) and compiling our BPM Processes we get Build errors complaining about  "Metamodel version validation...". We buildt up a fresh workspace and downloaded all Projects and dependent Libs from the NWDI Server. The dependent Libs on the server are also the latest available version (7.3 SP5 PAT??? i think)<br>

A similar simple process compiles well in a Local Development Configuration so we think that the dependent libs in the NWDI track are not compatible with the generated process definitions by the Developer Studio. Can this be true?<br>

<br>

<br>

[MOINInit] Meta models found.<br>

[MOINInit] Referenced meta-model: D:\workspace.jdi\0\DCs\sap.com\ide\es\config\mc\model\bi\_comp\gen\default\public\MM_Inf\lib\moin\sap.comideesconfigmc~model_xmi.zip<br>

[MOINInit] Referenced meta-model: D:\workspace.jdi\0\DCs\sap.com\tc\bpem\bi\model\flow\_comp\gen\default\public\MM_Inf\lib\moin\glx~ide_xmi.jar<br>

[MOINInit] Referenced meta-model: D:\workspace.jdi\0\DCs\sap.com\tc\bpem\bi\model\triggernet\_comp\gen\default\public\MM_Inf\lib\moin\glx~tnet_xmi.jar<br>

[MOINInit] Referenced meta-model: D:\workspace.jdi\0\DCs\sap.com\tc\esmp\bi\model\wsdl20\_comp\gen\default\public\MM_Inf\lib\moin\sap.comtcesmpmodelwsdl20_xmi.zip<br>

[MOINInit] Referenced meta-model: D:\workspace.jdi\0\DCs\sap.com\tc\esmp\bi\model\xsd1\_comp\gen\default\public\MM_Inf\lib\moin\sap.comtcesmpmodelxsd1_xmi.zip<br>

[MOINInit] Referenced meta-model: D:\workspace.jdi\0\DCs\sap.com\tc\mie\bi\model\gfw\_comp\gen\default\public\MM_Inf\lib\moin\sap.comcomsapmigfwmmdef_assmbl.zip<br>

[MOINInit] Referenced meta-model: D:\workspace.jdi\0\DCs\sap.com\tc\moin\bi\model\textverticalization\_comp\gen\default\public\MM_Inf\lib\moin\sap.comtcmoinmodeltextverticalization_xmi.zip<br>

[MOINInit] Referenced meta-model: D:\workspace.jdi\0\DCs\sap.com\tc\moin\bi\model\util\_comp\gen\default\public\MM_Inf\lib\moin\sap.comtcmoinmodelutil_xmi.zip<br>

[MOINInit] DataArea name: DefaultDataArea<br>

[MOINInit] Moin initialized in 1654 milliseconds.<br>

[BpemTask] BC-BMT-BPM-SRV com.sap.tc.glx.BpemTask execute() - Metamodel version validation...<br>

Caused by:<br>

java.lang.NullPointerException<br>

at com.sap.tc.glx.BpemTask.metaModelVersionCheck(BpemTask.java:549)<br>

at com.sap.tc.glx.BpemTask.execute(BpemTask.java:96)<br>

at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)<br>

at sun.reflect.GeneratedMethodAccessor123.invoke(Unknown Source)<br>

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)<br>

at java.lang.reflect.Method.invoke(Method.java:597)<br>

at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)<br>

at org.apache.tools.ant.Task.perform(Task.java:348)<br>

at org.apache.tools.ant.Target.execute(Target.java:357)<br>

at org.apache.tools.ant.Target.performTasks(Target.java:385)<br>

at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)<br>

at org.apache.tools.ant.Project.executeTarget(Project.java:1306)<br>

at com.sap.tc.buildplugin.ant.util.AntRunner.run(AntRunner.java:115)<br>

at com.sap.tc.buildplugin.DefaultAntBuildAction.execute(DefaultAntBuildAction.java:53)<br>

at com.sap.tc.buildplugin.DefaultPlugin.processSequence(DefaultPlugin.java:235)<br>

at com.sap.tc.buildplugin.DefaultPlugin.handleBuildStepSequence(DefaultPlugin.java:174)<br>

at com.sap.tc.buildplugin.DefaultPlugin.performBuild(DefaultPlugin.java:165)<br>

at com.sap.tc.buildplugin.DefaultPluginV3Delegate$BuildRequestHandler.handle(DefaultPluginV3Delegate.java:66)<br>

at com.sap.tc.buildplugin.DefaultPluginV3Delegate.requestV3(DefaultPluginV3Delegate.java:48)<br>

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)<br>

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)<br>

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)<br>

at java.lang.reflect.Method.invoke(Method.java:597)<br>

at com.sap.tc.buildtool.v2.impl.PluginHandler2.maybeInvoke(PluginHandler2.java:403)<br>

at com.sap.tc.buildtool.v2.impl.PluginHandler2.request(PluginHandler2.java:149)<br>

at com.sap.tc.buildtool.v2.impl.PluginHandler2.build(PluginHandler2.java:87)<br>

at com.sap.tc.buildtool.PluginHandler2Wrapper.execute(PluginHandler2Wrapper.java:59)<br>

at com.sap.tc.devconf.internal.DCProxyMake.make(DCProxyMake.java:276)<br>

at com.sap.tc.devconf.internal.DCProxy.make(DCProxy.java:1459)<br>

at com.sap.tc.devconf.internal.DCProxy.make(DCProxy.java:1441)<br>

at com.sap.tc.devconf.internal.DCProxy.make(DCProxy.java:3927)<br>

at com.sap.ide.dii08.internal.commandz.BuildDcsCommand.build(BuildDcsCommand.java:333)<br>

at com.sap.ide.dii08.internal.commandz.BuildDcsCommand.execute(BuildDcsCommand.java:176)<br>

at com.sap.ide.dii08.internal.service.CommandExecutor$2.run(CommandExecutor.java:77)<br>

at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1800)<br>

at com.sap.ide.dii05.util.internal.lock.DiiConsistencyServiceImpl.executeConsistentWorkspaceRunnable(DiiConsistencyServiceImpl.java:90)<br>

at com.sap.ide.dii05.util.internal.lock.DiiConsistencyServiceImpl.executeConsistentWorkspaceRunnable(DiiConsistencyServiceImpl.java:52)<br>

at com.sap.ide.dii08.internal.service.CommandExecutor.executeInWorkspaceAndDevConfLocks(CommandExecutor.java:90)

at com.sap.ide.dii08.internal.service.InternalDiiCommandService.buildDcs(InternalDiiCommandService.java:179)<br>

at com.sap.ide.dii08.internal.service.InternalDiiCommandService.buildDcs(InternalDiiCommandService.java:986)<br>

at com.sap.ide.dii05.ui.internal.actions.dc.BuildAction$2.run(BuildAction.java:193)<br>

at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)<br>

 

Edited by: Michael Chytracek on Feb 18, 2012 9:37 AM

Actions