7 Replies Latest reply: Feb 28, 2012 7:27 PM by Venkata Battula RSS

User record showing up in USR02 table and not in USER_ADDR table.

Venkata Battula
Currently Being Moderated

Hi Experts,

In one of our SAP systems, the user record is showing up in USR02 table and the same record not showing up in USER_ADDR table even though user has first name and last name maintained in SU01. Can any one know how to pull those missing records in USER_ADDR from USR02? Because some of the work flow activities look for user data in USER_ADDR table not from USR02 and we are unable to add those users to assign some work flow items.

Appreciate your help in this regard.

Thanks very much in advance

Venkat Battula

  • Re: User record showing up in USR02 table and not in USER_ADDR table.
    Julius von dem Bussche
    Currently Being Moderated

    There are programs to do consistency checks and synchhronize address data.

     

    I think you are looking for RSADRCK2 (or one of the related programs).

     

    Cheers,

    Julius

  • Re: User record showing up in USR02 table and not in USER_ADDR table.
    Venkata Battula
    Currently Being Moderated

    Hi Julius,

    Thanks for looking into this. I already run this RSADRCK2 and some other address check programs. But its not missing records from USR02 to USER_ADDR but showing up number of users in each address object. I am looking for any program that pulls the missing data from USR02 and update USER_ADDR.

    Very much appreciate for your help.

    Thank you

    Venkat

  • Re: User record showing up in USR02 table and not in USER_ADDR table.
    Venkata Battula
    Currently Being Moderated

    Hi Prashanth,

     

    Looks like this is not issue as I see all address numbers of the missing users that exist in USR21 exists in address table also USCOMPANY table. I think I am sure address number ranges are mismatched but I am not sure how to fix this issue. May be some program might exist to fix these things. Anyway I am opening customer message with SAP and see how they respond.

     

    Appreciate your help

    Thank you

    Venkat

    • Re: User record showing up in USR02 table and not in USER_ADDR table.
      Bernhard Hochreiter
      Currently Being Moderated

      Hello Venkat,

       

      in most cases the report from note 499997 helps.

       

      I suppose, what Prashanth meant is the new functionality to search for company adresses as well in the F4 of SU01, which can cause problems now, if the user adress number differs from the assigned uscompany adress number.

      With the latest version of note 1601232  a z-report is provided to repair such inconsistencies.

      b.rgds, Bernhard

       

      Edited by: Bernhard Hochreiter on Feb 28, 2012 2:14 PM

      • Re: User record showing up in USR02 table and not in USER_ADDR table.
        Prashant Tripathi
        Currently Being Moderated

        Hi Bernhard and Venkat

         

        The problem I faced recently in one of SAP Systems was as Bernhard rightly pointed out related to F4 search for users in SU01. But I checked usr02 entries and user_addr entries and there was a huge discrepancy between them. For users with user_addr entry were listed in F4 search. Upon analyzing address tables of users without user_addr entries it became clear that such users had invalid company address assigned to them (maybe because system was removed from CUA and all those company address went defunct in the local system - I have not investigated the exact cause) - hence I had to reassign all these a valid company code  as per table USCOMPANY and that did the trick and all these users were now listed in user_addr and were available for search via f4 in SU01.  I ran report RSADRCK2 and it only added two users into user_Addr and those two users were DDIC and SAP* and note 499997 did not help either. Nice to know that a note (1601232) exists for such scenarios - thanks for the info - will check it. Would like to add that SQL trace helped a lot in identifying the root cause

         

        Hope this helps as a side topic to this thread

         

        EDIT - P.S: Venkat if you suggest that this is number range issue - then did a client copy got messed up ? I can associate such cases due to incorrect/incomplete client copy and you can find more details in appropriate transactions storing client copy log (SCC3, SM21) to identify the tables disturbed; address tables in particular.

         

        Please keep us posted on the resolution ..thanks !!

         

        BR

         

        Prashant

         

        Edited by: Prashant Tripathi on Feb 28, 2012 6:53 PM

  • Re: User record showing up in USR02 table and not in USER_ADDR table.
    Venkata Battula
    Currently Being Moderated

    Hi Prashanth & Bernhard,

     

    SAP recommended 499997 and I applied that but that didn't work. Looks like this note 1601232 may fix this issue. But I see this is already taken care basis releases 702, 720, 730 and 731. My company SAP database environment suppors all 702, 720 and 730. So still we need to pull that attched report and run or  it is not needed for these versions, does SAP given any other standard report to take care of this?

     

    Thank you

    Venkat

     

    Edited by: Venkata Battula on Feb 28, 2012 7:26 PM

  • Re: User record showing up in USR02 table and not in USER_ADDR table.
    Venkata Battula
    Currently Being Moderated

    Hi Bernhard & Prashanth,

    Note 1601232 resolved this issue. I tried to award full points to both of you and I awarded Bernhard first and then tried to Prashanth but its not allwed to award full points to Prashanth as already full points awarded to Bernhard and awarded 6 points to Prashanth.

    Thank you very much for all your help

    Venkat

Actions