2 Replies Latest reply: Jan 12, 2012 6:44 AM by Syed Ershad Ahmed RSS

Oracle Version Upgrade

John DSouza
Currently Being Moderated

Dear Gurus,

 

I am planning to do an Oracle Version Upgrade.

 

My system details are as per below:-

 

System:- SRM 4.00

AIX:- AIX 2 5

Oracle Database:- 11.2.0.1.0

Current Oracle Patch Set Installed:- Oracle 11.2.0.1.0 (Baseline) SAP_112011_201007 (released on 12 July 2010). Initial plan was to patch it to the latest SBP level as per SAP note 1431795 and the latest SBP available in SAP Marketplace was SAP_112016_201111_AIX.zip which would bring my SBP Level to Oracle 11.2.0.1.6.

 

 

Change of plans now. I am required to upgrade the release from 11.2.0.1 to 11.2.0.3

 

I would need all the Guru's expertise and advise to carry out this task step by step. Please kindly advise on this.Your support would be greatly appreciated.

 

Also I have 2 questions as per below:-

 

1) This is a SRM system that I am planning to upgrade. As SRM system is interlinked to ECC and so on, if I do the Version

    Upgrade from 11.2.0.1 to 11.2.0.3 would it cause any issue in terms of communicating with other systems such as

    ECC and so on which is still on 11.2.0.1.

 

2) Is it wise to go to version 11.2.0.3 in terms of performance and so forth. Any known issues that can be encountered after

    the upgrade.

 

Looking forward to your feedbacks.

 

Thank you.

 

Regards,

John

  • Re: Oracle Version Upgrade
    Deepak Kori
    Currently Being Moderated

    Hi John,

     

     

    1) This is a SRM system that I am planning to upgrade. As SRM system is interlinked to ECC and so on, if I do the Version

    Upgrade from 11.2.0.1 to 11.2.0.3 would it cause any issue in terms of communicating with other systems such as

    ECC and so on which is still on 11.2.0.1.

     

     

    Absolutely there won't be any issue in integration. You can go ahead with the oracle database version upgrade on SRM.

     

     

    2) Is it wise to go to version 11.2.0.3 in terms of performance and so forth. Any known issues that can be encountered after

    the upgrade.

     

    It is always advisable to apply latest Oracle patchsets to incorporate latest bug fixes and performance related issue fixes.

    Post application of latest patches you need to tune your database parameters with help of SAP note 1431798.

    Refer Oracle upgrade central note 1431800 - Oracle 11.2.0: Central Technical Note for updated information on Oracle 11g upgrade.

     

    Regards,

    Deepak Kori

  • Re: Oracle Version Upgrade
    Syed Ershad Ahmed
    Currently Being Moderated

    Hi John,

     

    I just went through PAM and i see that Oracle 11g is not released for SRM4.0

     

    To answer your questions

     

    1) This is a SRM system that I am planning to upgrade. As SRM system is interlinked to ECC and so on, if I do the Version

    Upgrade from 11.2.0.1 to 11.2.0.3 would it cause any issue in terms of communicating with other systems such as

    ECC and so on which is still on 11.2.0.1.

     

    There should not be any impact between ECC and SRM system.

     

    2) Is it wise to go to version 11.2.0.3 in terms of performance and so forth. Any known issues that can be encountered after

    the upgrade.

     

    Its always recommended to be on higher patch level so i dont think you will have perfomance problems.You need to make sure that DB stats are run post Oracle Upgrade and Prior to releasing the system for Business users.

     

    Regards,

    Ershad Ahmed.

    • Oracle Version Upgrade Error
      John DSouza
      Currently Being Moderated

      Dear All,

       

      As I was doing my upgrade have encountered this error :-

       

      ETW000                                                                              74  0.037585

      4 ETW000  [dev trc     ,00000]  function dbdd_exp_funs loaded from library /usr/sap/SID/SYS/exe/run/dboraslib.o

      4 ETW000                                                                              87  0.037672

      4 ETW000  [dev trc     ,00000]  New connection 0 created                             113  0.037785

      4 ETW000  [dev trc     ,00000]  000: name = R/3, con_id = -000000001, state = DISCONNECTED, tx = NO , hc = NO , perm = YES,

      4 ETW000                             reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

      4 ETW000                                                                             127  0.037912

      4 ETW000  [dev trc     ,00000]  db_con_connect (con_name=R/3)                        108  0.038020

      4 ETW000  [dev trc     ,00000]  find_con_by_name found the following connection for reuse:

      4 ETW000                                                                              68  0.038088

      4 ETW000  [dev trc     ,00000]  000: name = R/3, con_id = 000000000, state = DISCONNECTED, tx = NO , hc = NO , perm = YES,

      4 ETW000                             reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

      4 ETW000                                                                              64  0.038152

      4 ETW000  [dev trc     ,00000]  Got ORACLE_HOME=/oracle/SID/112_64 from environment

      4 ETW000                                                                             993  0.039145

      4 ETW000  [dev trc     ,00000]    Default connection: tnsname ='SID'                 173  0.039318

      4 ETW000  [dev trc     ,00000]  Nls CharacterSet                 NationalChar                 C      EnvHp      ErrHp      ErrBt

      4 ETW000                                                                              68  0.039386

      4 ETW000  [dev trc     ,00000]  -->oci_initialize (con=0, char='UTF16', nchar='AL16UTF16', nls=-1, uc_ln=2)

      4 ETW000                                                                              88  0.039474

      4 ETW000  [dev trc     ,00000]  got NLS_LANG='AMERICAN_AMERICA.UTF8' from environment

      4 ETW000                                                                              72  0.039546

      4 ETW000  [dev trc     ,00000]     default client setting: NLS_CHAR=charset='UTF8'

      4 ETW000                                                                           10912  0.050458

      4 ETW000  [dev trc     ,00000]  Client NLS settings: AMERICAN_AMERICA.UTF8            71  0.050529

      4 ETW000  [dev trc     ,00000]  Logon as OPS$-user to get SAPSID's password           61  0.050590

      4 ETW000  [dev trc     ,00000]  Connecting as /@SID on connection 0 (nls_hdl 0) ... (dbsl 640 310811, UNICODE[2])

      4 ETW000                                                                              79  0.050669

      4 ETW000  [dev trc     ,00000]  Nls CharacterSet                 NationalChar                 C      EnvHp      ErrHp      ErrBt

      4 ETW000                                                                              48  0.050717

      4 ETW000  [dev trc     ,00000]    0 UTF8                         AL16UTF16                    1 0x1114666a0 0x111471d68 0x111496818

      4 ETW000                                                                              47  0.050764

      4 ETW000  [dev trc     ,00000]  Allocating service context handle for con_hdl=0       42  0.050806

      4 ETW000  [dev trc     ,00000]  Allocating server context handle                      62  0.050868

      4 ETW000  [dev trc     ,00000]  Attaching to DB Server SID (con_hdl=0,svchp=0x111496658,srvhp=0x111497ec0)

      4 ETW000                                                                             144  0.051012

      4 ETW000  [dev trc     ,00000]  Assigning server context 0x111497ec0 to service context 0x111496658

      4 ETW000                                                                          321322  0.372334

      4 ETW000  [dev trc     ,00000]  Allocating user session handle                       144  0.372478

      4 ETW000  [dev trc     ,00000]  Starting user session (con_hdl=0,svchp=0x111496658,srvhp=0x111497ec0,usrhp=0x1114f9200)

      4 ETW000                                                                             135  0.372613

      4 ETW000  [dev trc     ,00000]  Assigning user session 0x1114f9200 to service context 0x111496658

      4 ETW000                                                                           27747  0.400360

      4 ETW000  [dev trc     ,00000]         BEGIN DBMS_APPLICATION_INFO.SET_MODULE(:A0,:A1); END;              

      4 ETW000                                                                             109  0.400469

      4 ETW000  [dev trc     ,00000]         BEGIN DBMS_APPLICATION_INFO.SET_CLIENT_INFO(:A0); END;             

      4 ETW000                                                                             223  0.400692

      4 ETW000  [dev trc     ,00000]         SELECT SID FROM V$MYSTAT WHERE ROWNUM<2                            

      4 ETW000                                                                            1616  0.402308

      4 ETW000  [dev trc     ,00000]  Connected to session 131.                            846  0.403154

      4 ETW000  [dev trc     ,00000]  Now '/@SID' is connected: con_hdl=0, nls_hdl=0, session_id=131.

      4 ETW000                                                                              53  0.403207

      4 ETW000  [dev trc     ,00000]         ALTER SESSION SET NLS_SORT=BINARY                                  

      4 ETW000                                                                              57  0.403264

      4 ETW000  [dev trc     ,00000]         SELECT USERID,PASSWD FROM SAPUSER WHERE USERID IN (:A0, :A1)       

      4 ETW000                                                                             519  0.403783

      4 ETW000  [dbsloci.    ,00000]  *** ERROR => ORA-1403 when accessing table SAPUSER

      4 ETW000                                                                             588  0.404371

      4 ETW000  [dev trc     ,00000]     set_ocica() -> OCI or SQL return code 1403         70  0.404441

      4 ETW000  [dev trc     ,00000]  Disconnecting from connection 0 ...                  256  0.404697

      4 ETW000  [dev trc     ,00000]  Rolling back transaction ...                          99  0.404796

      4 ETW000  [dev trc     ,00000]  Close user session (con_hdl=0,svchp=0x111496658,usrhp=0x1114f9200)

      4 ETW000                                                                             252  0.405048

      4 ETW000  [dev trc     ,00000]  Now connection 0 is disconnected                     891  0.405939

      4 ETW000  [dev trc     ,00000]  Info: rc=99, oerr=1403, try to connect with default password.

      4 ETW000                                                                              84  0.406023

      4 ETW000  [dev trc     ,00000]  Connecting as SAPIES/<pwd>@SID on connection 0 (nls_hdl 0) ... (dbsl 640 310811, UNICODE[2])

      4 ETW000                                                                              50  0.406073

      4 ETW000  [dev trc     ,00000]  Nls CharacterSet                 NationalChar                 C      EnvHp      ErrHp      ErrBt

      4 ETW000                                                                              49  0.406122

      4 ETW000  [dev trc     ,00000]    0 UTF8                         AL16UTF16                    1 0x1114666a0 0x111471d68 0x111496818

      4 ETW000                                                                              48  0.406170

      4 ETW000  [dev trc     ,00000]  Assigning username to user session 0x1114f9200        69  0.406239

      4 ETW000  [dev trc     ,00000]  Assigning password to user session 0x1114f9200        41  0.406280

      4 ETW000  [dev trc     ,00000]  Starting user session (con_hdl=0,svchp=0x111496658,srvhp=0x111497ec0,usrhp=0x1114f9200)

      4 ETW000                                                                             228  0.406508

      4 ETW000  [dboci.c     ,00000]  *** ERROR => OCI-call 'OCISessionBegin' failed: rc = 1017

      4 ETW000                                                                           13319  0.419827

      4 ETW000  [dbsloci.    ,00000]  *** ERROR => CONNECT failed with sql error 1017.

      4 ETW000                                                                              46  0.419873

      4 ETW000  [dev trc     ,00000]     set_ocica() -> OCI or SQL return code 1017         28  0.419901

      4 ETW000  [dblink      ,00430]  ***LOG BY2=>sql error 1017   performing CON [dblink#6 @ 430]

      4 ETW000                                                                             327  0.420228

      4 ETW000  [dblink      ,00430]  ***LOG BY0=>ORA-01017: invalid username/password; logon denied [dblink#6 @ 430]

      4 ETW000                                                                              45  0.420273

      2EETW169 no connect possible: "DBMS = ORACLE                           --- dbs_ora_tnsname = 'SID'"

       

      It seems like connection error between SAP and Oracle.

       

      Anyone can advise and propose any suggestions.

       

      Thank you.

       

      John

      • Re: Oracle Version Upgrade Error
        Orkun Gedik
        Currently Being Moderated

        Hi John,

         

        >> ERROR => ORA-1403 when accessing table SAPUSER

        When did you faced with this problem? Did you check the Note 400241 - Problems with ops$ or sapr3 connect to Oracle?

         

        Best regards,

         

        Orkun Gedik

      • Re: Oracle Version Upgrade Error
        Ivy Toh
        Currently Being Moderated

        Hi John,

         

        About the ORA-1403 when accessing SAPUSER, you can set the password consistently in SAPUSER and in the Oracle DDIC using

        command:

        brconnect -u system/<password> -f chpass -o <sapowner> -p <password>

         

        Cheers,

        Ivy

      • Re: Oracle Version Upgrade Error
        tunga bhaskar
        Currently Being Moderated

        Hi John

         

        ERROR => ORA-1403 could not access table SAPUSER

        There are no entries in "SAPUSER" table or Os user with prefix OPS$ does not exist

        Table  "SAPUSER" contains Schema owner ans pass word  and it is owned by  OPS$HOSTNAME\SIDADM

        Run the SQL ( oradbuser.sql ) which will create the dbuser and entries into table.

        If the entriesare not created then insert manually using Command 

         

        SQL> insert into "OPS$HOSTNAME\SIDADM ".SAPUSER values('SAPUSER','password');

        • Re: Oracle Version Upgrade Error
          Fidel Vales
          Currently Being Moderated

          Hi tunga,

          Unfortunately, you are wrong. The proper note (400241) was already provided.

          Customer has UNIX and your "copy+paste" is refered to a Windows system.

          The script oradbuser.sql  is very, very, very, very old and do not recommended any more to create the ops$user.

          I advice you to get a little more experience and/or tripple ckeck anything you post and read the note 400241

Actions