18 Replies Latest reply: May 9, 2013 4:43 PM by Remya Raj RSS

Connecting Studio to HANA running in AWS

Rav Kanth Bandi
Currently Being Moderated

I am trying to connect SAP HANA Studio to the running HANA instance in AWS, but getting the following issue.

 

------

"The system is not reachable, the log-in data could not be considered.

 

Are you sure you want to add the system into your workspace?"

----

HANA issue.png

 

Elastic IP address was created and associated to HANA instance in AWS.

 

Default log-in details used: SYSTEM/manager

 

HANA running with green status in AWS:

 

Please help as to what I am missing in connecting Studio to HANA running in AWS.

 

Thanks

  • Re: Connecting Studio to HANA running in AWS
    Juergen Schmerder
    Currently Being Moderated

    Please check the following:

     

    • Can you ping your machine?
    • Is port 30015 blocked by a firewall in your network (if you're inside a company network, it may very well be blocked)
    • SSH into your AWS machine and stop and start the server (see the updated getting started guide for instructions on how to do this)

     

    --juergen

  • Re: Connecting Studio to HANA running in AWS
    Juergen Schmerder
    Currently Being Moderated

    If nothing has helped so far, try this: Unable to connect to your running AWS HANA DB? Read this...

     

    Please let us know when the problem is solved (and what solved the problem)

     

    --Juergen

    • Re: Connecting Studio to HANA running in AWS
      Rav Kanth Bandi
      Currently Being Moderated

      Juergen,

       

      Finally I am able to connect HANA Studioi to Instance running in AWS. No changes done other than stopping and starting the HANA DB, as your per your link:http://scn.sap.com/thread/3187520

       

      But, I still see the following issue: "sapstartsrv" Service not started.

       

      HANAissue.jpg

      Can you please help?

       

      Thanks

      • Re: Connecting Studio to HANA running in AWS
        Juergen Schmerder
        Currently Being Moderated

        Hi Rav,

         

        When you added the system to your Hana studio, what did you use as hostname? Check out the end of thread http://scn.sap.com/thread/3183119 - the host are needs to be 'imdbhdb' or our Elastic IP Address. not the amazon public hostname...

        And of course you need that entry in your hosts files that associates 'imdbhdb' with your elastic IP.

         

        Please let me know if that helps, and I'll put it in the FAQ

         

        --juergen

        • Re: Connecting Studio to HANA running in AWS
          Rav Kanth Bandi
          Currently Being Moderated

          Juergen,

           

          1. After launching HANA in AWS, I tried to Connect Studio with HANA, faced the issue of System not reachable. (see screenshot in this thread on May 30, 2012).

           

          2. Using PuTTY, stopped and restarted the HANA db at OS level. This fixed the issue #1 above.

           

          3. Tried connecting Studio to HANA in AWS, using Elastic IP address, not with Public DNS Service. Status is in yellow with message of 'sapstartsrv' service not started. Does adding of system in Studio using Elastic IP address work, or do we need to add the entry in hosts file?

           

          4. I have not yet tried adding Elastic IP in hosts file, but could not do that due to not having administrator rights, and will update here soon. Is there anything else that can be tried other than adding IP in hosts file?

           

          Thanks

        • Re: Connecting Studio to HANA running in AWS
          Juergen Schmerder
          Currently Being Moderated

          To solve your issue #3, you need to add this entry in your hosts file:

           

          <your elastic ip>       imdbhdb

           

          However, if you don't have permissions to make this change on your machine, don't worry - everything will work just fine. sapstartsvr is needed to remotely stop and start your Hana server from the studio. The service is running, but without the hosts file entry, the studio cannot reach it. The yellow status icon is a bit annoying, but that's all.

           

          --Juergen

          • Re: Connecting Studio to HANA running in AWS
            Ravi Srinivas
            Currently Being Moderated

            Hello Guyz,

             

            Urgent help .....

             

            My License key expired, I downloaded the key from SAP and tried to Install,

             

            Am getting an error "nameserver failed to process the request exception failed to install a permanent license"

             

            Is it because HANA studio version incompatability  HANA studio 1.0.28.

             

            Regards,

            Ravi

             

             

            • Re: Connecting Studio to HANA running in AWS
              Ferry Lianto
              Currently Being Moderated

              Hi Ravi,

               

              Just FYI, please open a new discussion thread instead of replying to Juergen's response, since what you ask is unrelated to the original discussion topic.


              Regards,

              Ferry

            • Re: Connecting Studio to HANA running in AWS
              Juergen Schmerder
              Currently Being Moderated

              Hi Ravi,

               

              As indicated by Ferry, it is not a good idea to ask unrelated questions in discussion threads that are already resolved. To increase chances you get an answer to your questions, always (1) search the forum first, then (2) open a new discussion. Don't ask questions in existing threads or in the comments section of a document or blog.

               

              Regarding your issue - occasionally (seems to be related to HANA Systems that were originally installed with a revision <28) the license file is created with a wrong System Number.

               

              Check you latest nameserver_imdbhdb.*.trc file, either from the Studio (double-click connection and see ) or on the server (find it in /usr/sap/HDB/HDB00/imdbhdb/trace). Towards the end of the file, you should find something like:

               

              [10963]{200009}[0] 2012-11-21 08:14:39.127976 i TraceContext TraceContext.cpp(00534) : UserName=SYSTEM

              [10963]{200009}[0] 2012-11-21 08:14:39.127970 e Licensing    AbstractLicenseManager.cpp(00054) : 52 likey_install_from_memory: This system's system number is "000000000xxxxxxxxx",

              but there is a license key for system number "000000000yyyyyyyyy" in the license key file.

              [10963]{200009}[0] 2012-11-21 08:14:39.133006 e Licensing    AbstractLicenseManager.cpp(00818) : TRY TO INSTALL AN INVALID LICENSE: ----- Begin SAP License -----

              SAPSYSTEM=HDB

               

              Now, just copy the value for 000000000xxxxxxxxx and paste it into your HDB.txt license file, overwriting 000000000yyyyyyyyy. Then try to install the license again.

               

              hth

              --Juergen

              • Re: Connecting Studio to HANA running in AWS
                MUNTAZIR SAIYED
                Currently Being Moderated

                HI Juergen

                 

                I am using KT cloud and have installed it. but the licence key is expiring. I followed the process of Installing the licence key and it got installed successfully. But i guess i have the same issue of wrong system number. Where do i find my system number. When you say that "double click on connection" in Studio where is the  connection ?

                 

                Please help or my licence will expire

                • Re: Connecting Studio to HANA running in AWS
                  Juergen Schmerder
                  Currently Being Moderated

                  Hi Muntazir,

                   

                  The connection in HANA studio is the node in the left panel called "Navigator" that shows your HANA db. The text of that node says "HDB" plus the description you chose and if hopefully shows a green status icon. Just double-click that to find the version of your db. The system number, however, is shown on the license screen (right-click the connection node, choose "Properties" and find the license information on the popup.

                  Regarding your license issue: no, with KT we should not have the issue you are referring to (it only occurs for AWS instances that have been originally created on an older HANA build), and you also didn't get the error message.

                  Please try to install your license key again, but this time delete the existing license key before installing the new one (all on the license popup). That should solve your issue and get you a valid license.

                   

                  --Juergen

          • Re: Connecting Studio to HANA running in AWS
            Remya Raj
            Currently Being Moderated

            Hi Juergen,

             

            I was reading this thread in detail as I am facing the same issue.

             

            Steps I did are as follow:

            1) Added the entry in host file as <Elastic IP> imdbhdb

            2) Add system in HANA Studio with user EXTDEV / Password. Tried SYSTEM/manager login, it didn't work as well.

            3) Click Finish and getting the error.

             

            I01.JPG02.JPG

            I am using SAP HANA Studio Ver 1.0.51, another user got logged in on the EXTDEV user so it is definitely up and available.

            I am in a company network, can this be the issue? How do I confirm it? Please help to resolve.


            Regards,

            Remya

Actions