5 Replies Latest reply: Jul 4, 2012 4:02 PM by GANESH SHANKAR RSS

Problem in pie chart labels - Xcelsius 6.0

Daniel Silva
Currently Being Moderated

I have a pie chart which data is dynamically loaded by changing a combo box. In others worlds, when i select a label in combo box, a table is filtered by this label and a second table is filled by theses lines filtered that is used by the pie chart. So, the problem is, sometimes some names of pie chart's labels disappear or are shown wrong, like "1" , "2", ...

Does anybody  know how i can handle it? Does anybody know what causes this issue?

 

ps 1:  The combo box is changed by "drill down" in another pie chart

 

ps 2 : I'm using SAP Dashboard Design

         Version: 6.0.0.0

         Compilation : 14,0,2,364

 

Thank's !

  • Re: Problem in pie chart labels - Xcelsius 6.0
    Sujit Honrao
    Currently Being Moderated

    IF you are saying it works fine at times and does not at others then simply, rebind the components, this can be an issue with the bindings.

     

    Also, you might want to check if every value selected from the combo - is actually passing some rows to the source of pie...if yes, how many rows? and have you mapped the complete range.

     

    I don't see any other reason...let me know if it helps

     

     

    Sujit.

  • Re: Problem in pie chart labels - Xcelsius 6.0
    Nikhil Joy
    Currently Being Moderated

    Hi Daniel,

     

    This might be an issue with mapping.  Make sure that filtered values are inserted in to the second table properly. You can use spreadsheet component to view second table. If it is correct check the mapping you have given for the pie chart.

    While using the spreadsheet component, just check if you can see the wrong values like "1","2" or blank cells in it. trouble shooting would be easier with spreadsheet component.

     

    Let me know the updates.

     

    Regards,

    Nikhil Joy

    • Re: Problem in pie chart labels - Xcelsius 6.0
      Daniel Silva
      Currently Being Moderated

      Hi Nikhil,

       

      I checked with spreadsheet component and values are corret, also  mapping for the pie chart is fine. Values in pieces of pie chart are corret, but labels aren't . I realized that if i uncheck "ignore blank in values" in propriets, labels always are corret, but a fixed number of labels isn't a beautiful solution. I'll see others ways to solve it

       

      Regards ,

       

      Daniel    

  • Re: Problem in pie chart labels - Xcelsius 6.0
    Dhanesh Aradhye
    Currently Being Moderated

    Hi Daniel,

     

    I have faced this issue few times. There is no solution yet. I even contacted SAP for this but no solution as of today.

     

    Here is a work around - do not show the pie chart on initial load of the dashboard. Instead, keep some button like "show pie" and display the pie chart on the click using dynamic visibility. This way, the pie chart will show proper values.

     

    Let me know if this helps.

     

     

    Regards,

    Dhanesh

  • Re: Problem in pie chart labels - Xcelsius 6.0
    GANESH SHANKAR
    Currently Being Moderated

    Hi Daniel,

     

    Check that you have set proper label options in the Appearance tab.

     

    Regards,

     

    Ganesh

Actions