14 Replies Latest reply: Feb 23, 2010 8:44 AM by Michael Teubner RSS

DatabaseStudio 7.8.01.10 on Linux doesn't start

Michael Teubner
Currently Being Moderated

Hello,

i've just installed DatabaseStudio 7.8.01.10 on Linux Opensuse 11.2.

 

The Package from which I installed is called

MAXDBSTDDSK7801_10-20005641.SAR

 

uname -a

Linux box 2.6.31.12-0.1-desktop #1 SMP PREEMPT 2010-01-27 08:20:11 +0100 i686 i686 i386 GNU/Linux

 

java -version

java version "1.6.0_0"

OpenJDK Runtime Environment (IcedTea6 1.6.2) (suse-5.10.1-i386)

OpenJDK Server VM (build 14.0-b16, mixed mode)

 

Installation was successful as user root. But when I try to start DatabasStudio via commandline as normal user or as user root:

box:~> /sapdb/clients/DatabaseStudio/DatabaseStudio/dbstudio -noIntro

I got the following error:

java.io.FileNotFoundException: /sapdb/data/app/dbstd/um.properties (Datei oder Verzeichnis nicht gefunden)

        at java.io.FileOutputStream.open(Native Method)                                                  

        at java.io.FileOutputStream.<init>(FileOutputStream.java:209)                                    

        at java.io.FileOutputStream.<init>(FileOutputStream.java:160)                                    

        at com.sap.sdb.tools.core.internal.CoreUser.checkPropertyFile(CoreUser.java:158)                 

        at com.sap.sdb.tools.core.internal.CoreUser.<init>(CoreUser.java:56)                             

        at com.sap.sdb.tools.core.CorePlugin.getCoreUser(CorePlugin.java:254)                            

        at com.sap.sdb.tools.ui.dbm.DBMUIConsole.open(DBMUIConsole.java:45)                              

        at com.sap.sdb.tools.ui.dbm.DBMUIPlugin.start(DBMUIPlugin.java:129)                              

        at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:1009) 

        at java.security.AccessController.doPrivileged(Native Method)                                    

        at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:1003)

        at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:984)         

...


So I created the directory /sapdb/data/app/dbstd/ set the authorizations and started the program again.

Now I get the following error in a popup window:

An error has occurred. See the log file

/home/xxx/sdb/DatabaseStudio/.metadata/.log.


Here's the content of the logfile:

!SESSION 2010-02-10 14:13:26.204 -


eclipse.buildId=unknown

java.version=1.6.0_0

java.vendor=Sun Microsystems Inc.

BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=de_DE

Framework arguments:  -noIntro

Command-line arguments:  -os linux -ws gtk -arch x86 -noIntro

 

!ENTRY org.eclipse.ui.workbench 4 0 2010-02-10 14:13:31.239

!MESSAGE Widget disposed too early!

     at org.eclipse.ui.internal.WorkbenchPartReference$1.widgetDisposed(WorkbenchPartReference.java:171)

     at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:117)

     at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)

     at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1158)

     at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1182)

...

!ENTRY org.eclipse.ui.workbench 4 0 2010-02-10 14:13:31.312

!MESSAGE Widget disposed too early!

     at org.eclipse.ui.internal.WorkbenchPartReference$1.widgetDisposed(WorkbenchPartReference.java:171)

     at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:117)

     at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)

     at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1158)

     at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1182)

...

!ENTRY org.eclipse.ui.workbench 4 0 2010-02-10 14:13:31.321

!MESSAGE Widget disposed too early!

     at org.eclipse.ui.internal.WorkbenchPartReference$1.widgetDisposed(WorkbenchPartReference.java:171)

     at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:117)

     at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)

     at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1158)

     at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1182)

...

!ENTRY org.eclipse.osgi 4 0 2010-02-10 14:13:31.356

!MESSAGE Application error

!STACK 1

org.eclipse.swt.SWTError: XPCOM error -2147467262

     at org.eclipse.swt.browser.Mozilla.error(Mozilla.java:1597)

     at org.eclipse.swt.browser.Mozilla.setText(Mozilla.java:1820)

     at org.eclipse.swt.browser.Browser.setText(Browser.java:737)

     at org.eclipse.ui.internal.intro.impl.presentations.BrowserIntroPartImplementation.generateContentForPage(BrowserIntroPartImplementation.java:252)

     at org.eclipse.ui.internal.intro.impl.presentations.BrowserIntroPartImplementation.dynamicStandbyStateChanged(BrowserIntroPartImplementation.java:451)

...

!ENTRY org.eclipse.osgi 2 0 2010-02-10 14:13:31.382

!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:

!SUBENTRY 1 org.eclipse.osgi 2 0 2010-02-10 14:13:31.382

!MESSAGE Bundle update@eclipse/plugins/com.sap.sdb.tools.ui.report_7.8.1.v201001222210/ was not resolved.

!SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-10 14:13:31.382

!MESSAGE Missing required bundle org.eclipse.birt.report.model_0.0.0.

!SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-10 14:13:31.382

!MESSAGE Missing required bundle org.eclipse.birt.report.viewer_0.0.0.

!SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-10 14:13:31.382

!MESSAGE Missing required bundle org.eclipse.birt.core_0.0.0.

!SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-10 14:13:31.382

!MESSAGE Missing required bundle org.eclipse.birt.report.engine_0.0.0.

 

!ENTRY org.eclipse.osgi 2 0 2010-02-10 14:13:31.383

!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:

!SUBENTRY 1 org.eclipse.osgi 2 0 2010-02-10 14:13:31.383

!MESSAGE Bundle update@eclipse/plugins/com.sap.sdb.tools.ui.report_7.8.1.v201001222210/ [174] was not resolved.

!SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-10 14:13:31.383

!MESSAGE Missing required bundle org.eclipse.birt.core_0.0.0.

!SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-10 14:13:31.383

!MESSAGE Missing required bundle org.eclipse.birt.report.engine_0.0.0.

!SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-10 14:13:31.383

!MESSAGE Missing required bundle org.eclipse.birt.report.model_0.0.0.

!SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-10 14:13:31.383

!MESSAGE Missing required bundle org.eclipse.birt.report.viewer_0.0.0.

 

 

Any help would be appreciated,

Michael

 

Formatting doesn't work. Sorry for that.

Edited by: Michael Teubner on Feb 10, 2010 2:23 PM

  • Re: DatabaseStudio 7.8.01.10 on Linux doesn't start
    Markus Doehr
    Currently Being Moderated

    > java -version

    > java version "1.6.0_0"

    > OpenJDK Runtime Environment (IcedTea6 1.6.2) (suse-5.10.1-i386)

    > OpenJDK Server VM (build 14.0-b16, mixed mode)

     

    I'd replace that OpenJDK with the offical Sun JDK and try again.

     

     

     

    Markus

    • Re: DatabaseStudio 7.8.01.10 on Linux doesn't start
      Michael Teubner
      Currently Being Moderated

      Hello Markus,

      thank you for your fast answer.

      I followed your advice:

      java version "1.6.0_18"
      Java(TM) SE Runtime Environment (build 1.6.0_18-b07)
      Java HotSpot(TM) Server VM (build 16.0-b13, mixed mode)

      When I start DatabaseStudio I get still a popup:

      An error has occurred. See the log file /home/xxx/sdb/DatabaseStudio/.metadata/.log.

      Here's the content of the log file:

      !SESSION 2010-02-10 14:43:08.864 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.6.0_18
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=de_DE
      Framework arguments:  -noIntro
      Command-line arguments:  -os linux -ws gtk -arch x86 -noIntro
      
      !ENTRY org.eclipse.ui.workbench 4 0 2010-02-10 14:43:14.304
      !MESSAGE Widget disposed too early!
      !STACK 0
      java.lang.RuntimeException: Widget disposed too early!
           at org.eclipse.ui.internal.WorkbenchPartReference$1.widgetDisposed(WorkbenchPartReference.java:171)
           at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:117)
           at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
           at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1158)
           at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1182)
           at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1163)
           at org.eclipse.swt.widgets.Widget.release(Widget.java:1026)
           at org.eclipse.swt.widgets.Control.release(Control.java:3217)
           at org.eclipse.swt.widgets.Composite.releaseChildren(Composite.java:1184)
           at org.eclipse.swt.widgets.Widget.release(Widget.java:1029)
           at org.eclipse.swt.widgets.Control.release(Control.java:3217)
           at org.eclipse.swt.widgets.Composite.releaseChildren(Composite.java:1184)
      ...

       

      Thanks in advance, Michael

      • Re: DatabaseStudio 7.8.01.10 on Linux doesn't start
        Markus Doehr
        Currently Being Moderated

        Hi Michael,

         

        sorry - no idea what this is. A quick search didn't reveal any obvious things so I think you will need to either create a support call (if you're a SAP customer) or wait until someone from the development sees this post here...

         

         

         

        Markus

        • Re: DatabaseStudio 7.8.01.10 on Linux doesn't start
          Wolfgang Auer
          Currently Being Moderated

          Hello,

           

          I think the problem is

           

          java.io.FileNotFoundException: /sapdb/data/app/dbstd/um.properties

           

          This exception seems to mess up the start up of Database Studio.

          Please ckeck if Database Studio has the permissions to create this file.

          Could you create an empty um.properties file in this directory.

           

          Also delete the Database Studio workspace. Should be in the user directory /home/.../sdb/DatabaseStudio.

           

          Regards

            Wolfgang

          • Re: DatabaseStudio 7.8.01.10 on Linux doesn't start
            Michael Teubner
            Currently Being Moderated

            Sorry for the late answer, I was in holiday.

            I created a file called /sapdb/data/app/dbstd/um.properties with rw-permissions to me.

            I hope this is correct, as I am the user who starts the DatabaseStudio (I am in the Group sdba).

             

            I deleted the directory ~/sdb completely and tried to start the DatabaseStudio again.

            The result is a popup which says:

            'An error has occurred. See the log file /home/xxx/sdb/DatabaseStudio/.metadata/.log.'

             

            Here is the content of the log file:

            !SESSION 2010-02-22 09:43:53.903 -----------------------------------------------
            eclipse.buildId=unknown
            java.version=1.6.0_18
            java.vendor=Sun Microsystems Inc.
            BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=de_DE
            Framework arguments:  -NoIntro
            Command-line arguments:  -os linux -ws gtk -arch x86 -NoIntro
            !ENTRY org.eclipse.ui.workbench 4 0 2010-02-22 09:44:00.693
            !MESSAGE Widget disposed too early!
            !STACK 0
            java.lang.RuntimeException: Widget disposed too early!
            at org.eclipse.ui.internal.WorkbenchPartReference$1.widgetDisposed(WorkbenchPartReference.java:171)
            at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:117)
            at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
            at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1158)
            at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1182)
            at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1163)
            at org.eclipse.swt.widgets.Widget.release(Widget.java:1026)
            at org.eclipse.swt.widgets.Control.release(Control.java:3217)
            at org.eclipse.swt.widgets.Composite.releaseChildren(Composite.java:1184)
            at org.eclipse.swt.widgets.Widget.release(Widget.java:1029)
            at org.eclipse.swt.widgets.Control.release(Control.java:3217)
            at org.eclipse.swt.widgets.Composite.releaseChildren(Composite.java:1184)
            at org.eclipse.swt.widgets.Widget.release(Widget.java:1029)
            at org.eclipse.swt.widgets.Control.release(Control.java:3217)
            at org.eclipse.swt.widgets.Composite.releaseChildren(Composite.java:1184)
            at org.eclipse.swt.widgets.Canvas.releaseChildren(Canvas.java:211)
            at org.eclipse.swt.widgets.Decorations.releaseChildren(Decorations.java:466)
            at org.eclipse.swt.widgets.Shell.releaseChildren(Shell.java:1948)
            at org.eclipse.swt.widgets.Widget.release(Widget.java:1029)
            at org.eclipse.swt.widgets.Control.release(Control.java:3217)
            at org.eclipse.swt.widgets.Widget.dispose(Widget.java:442)
            ...

             

            • Re: DatabaseStudio 7.8.01.10 on Linux doesn't start
              Michael Teubner
              Currently Being Moderated

              The above error occures 3 times and then the following error comes in the log:

              !ENTRY org.eclipse.osgi 4 0 2010-02-22 09:44:00.823
              !MESSAGE Application error
              !STACK 1
              org.eclipse.swt.SWTError: XPCOM error -2147467262
              at org.eclipse.swt.browser.Mozilla.error(Mozilla.java:1597)
              at org.eclipse.swt.browser.Mozilla.setText(Mozilla.java:1820)
              at org.eclipse.swt.browser.Browser.setText(Browser.java:737)
              at org.eclipse.ui.internal.intro.impl.presentations.BrowserIntroPartImplementation.generateContentForPage(BrowserIntroPartImplementation.java:252)
              at org.eclipse.ui.internal.intro.impl.presentations.BrowserIntroPartImplementation.dynamicStandbyStateChanged(BrowserIntroPartImplementation.java:451)
              at org.eclipse.ui.internal.intro.impl.presentations.BrowserIntroPartImplementation.doStandbyStateChanged(BrowserIntroPartImplementation.java:658)
              at org.eclipse.ui.internal.intro.impl.model.AbstractIntroPartImplementation.standbyStateChanged(AbstractIntroPartImplementation.java:249)
              at org.eclipse.ui.internal.intro.impl.model.IntroPartPresentation.standbyStateChanged(IntroPartPresentation.java:443)
              at org.eclipse.ui.intro.config.CustomizableIntroPart.standbyStateChanged(CustomizableIntroPart.java:266)
              at org.eclipse.ui.internal.ViewIntroAdapterPart$2.run(ViewIntroAdapterPart.java:74)
              at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
              at org.eclipse.ui.internal.ViewIntroAdapterPart.setStandby(ViewIntroAdapterPart.java:70)
              at org.eclipse.ui.internal.ViewIntroAdapterPart$1.propertyChanged(ViewIntroAdapterPart.java:55)
              at org.eclipse.ui.internal.WorkbenchPartReference.fireInternalPropertyChange(WorkbenchPartReference.java:374)
              at org.eclipse.ui.internal.WorkbenchPartReference.fireZoomChange(WorkbenchPartReference.java:539)

               

              • Re: DatabaseStudio 7.8.01.10 on Linux doesn't start
                Michael Teubner
                Currently Being Moderated

                Followed by this:

                !ENTRY org.eclipse.osgi 2 0 2010-02-22 09:44:00.838
                !MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
                !SUBENTRY 1 org.eclipse.osgi 2 0 2010-02-22 09:44:00.838
                !MESSAGE Bundle update@eclipse/plugins/com.sap.sdb.tools.ui.report_7.8.1.v201001222210/ was not resolved.
                !SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-22 09:44:00.838
                !MESSAGE Missing required bundle org.eclipse.birt.core_0.0.0.
                !SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-22 09:44:00.838
                !MESSAGE Missing required bundle org.eclipse.birt.report.engine_0.0.0.
                !SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-22 09:44:00.838
                !MESSAGE Missing required bundle org.eclipse.birt.report.viewer_0.0.0.
                !SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-22 09:44:00.838
                !MESSAGE Missing required bundle org.eclipse.birt.report.model_0.0.0.
                
                !ENTRY org.eclipse.osgi 2 0 2010-02-22 09:44:00.839
                !MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
                !SUBENTRY 1 org.eclipse.osgi 2 0 2010-02-22 09:44:00.839
                !MESSAGE Bundle update@eclipse/plugins/com.sap.sdb.tools.ui.report_7.8.1.v201001222210/ [43] was not resolved.
                !SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-22 09:44:00.839
                !MESSAGE Missing required bundle org.eclipse.birt.core_0.0.0.
                !SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-22 09:44:00.839
                !MESSAGE Missing required bundle org.eclipse.birt.report.engine_0.0.0.
                !SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-22 09:44:00.839
                !MESSAGE Missing required bundle org.eclipse.birt.report.model_0.0.0.
                !SUBENTRY 2 com.sap.sdb.tools.ui.report 2 0 2010-02-22 09:44:00.839
                !MESSAGE Missing required bundle org.eclipse.birt.report.viewer_0.0.0.

                 

                Regards, Michael

  • Re: DatabaseStudio 7.8.01.10 on Linux doesn't start
    Rajesh Narkhede
    Currently Being Moderated

    Hi,

     

    Its not actually SAP issue, but eclipse...

     

    Make sure that XULRUNNER package is installed.

     

    Then append eclipse.ini as below :

    -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner/xulrunner

    Please correct the path of "xulrunner" if different.

     

    Regards.

     

    Rajesh Narkhede

  • Re: DatabaseStudio 7.8.01.10 on Linux doesn't start
    Nelis Lamprecht
    Currently Being Moderated

     

    box:~> /sapdb/clients/DatabaseStudio/DatabaseStudio/dbstudio -noIntro

     

     

    Try changing to the above directory(/sapdb/clients/DatabaseStudio/DatabaseStudio) first and then running ./dbstudio -noIntro

     

    Do you still get an error ?

     

     

    Nelis

Actions