Currently Being Moderated

Introduction

In a blog recently published, I tried to explain what Hub systems are and why this landscape pattern term is used to describe landscapes. The essence was, that Hubs are those systems that are reused, and that this reuse needs to be taken into account in updates or upgrades of your system landscapes.

But when you have upgraded your system in the end, the update needs to be reflected in the landscape description in the SAP Solution Manager. If set up as recommended, the SLD Data Supplier of your system will send updated data to the SLD, including the new software component version. But in many cases, the product instances (groups of software components, knowledge about which is required be the MOpz) is not part of this data sent by the SLD. For newer product versions (those based on EHP1 for SAP NetWeaver 7.0 and higher, for example EHP 4 for SAP ERP 6.0) the SLD data will be complete. Nevertheless, some manual action is required, because SLD works on Technical Systems.

Technology driven upgrade would upgrade anProducts, Product Systems, Product Instances, Technical Systems, and Landscape Patterns in the SAP Solution Manager. In this case, the manual steps are as described in the following. Here is what to do…

The Initial Situation

  • An upgrade of a Java-based Hub system has been performed on a technical system, which also contained product instances of the SAP Business Suite.
  • Now some of these product instances have functionally equivalent instances (FEI), which have been exchanged during the upgrade.

So the problem is that the updated system registers its new instance number in the SAP NetWeaver System Landscape Directory (SLD), but in SMSY the old version is used (also).

Solution /Workaround

The data in SMSY needs to be corrected manually. You should solve this problem for all systems, but is mandatory for stand-alone products (SAP SRM, SAP CRM, SAP SCM, and SAP MDMCATALOG MGMT).

Prerequisite

Before you can correct your SMSY data, update the PPMS Content – minimum requirement is version ST 400 SP26.
This version has been made available as a file - see SAP Note 1603103 - SMSY: NW 7.3 Upgrade (SAP Service Marketplace login required).

Steps

You have performed an upgrade of a Java based technical system to SAP NetWeaver 7.3. After the upgrade, in the SAP Solution Manager open transaction SMSY and proceed as follows:

  1. Correct the Product Version:
    1. Navigate to the Product System, which was upgraded to SAP NetWeaver release 7.3.
    2. Change its Product Version to the one of SAP NetWeaver 7.3.
  2. Correct the Product Instance Selection in transaction SMSY:
    1. Navigate to the SAP Business Suite Product System, which has Product Instances running on the SAP NetWeaver Hub.
    2. On tab Instances remove the check mark on the product instances, which were replaced by NW 7.3 FEI
      Therefore you need to check all relevant Instances if an FEI is available, which is indicated by having the same name + NW 7.3.

        Example:

  • Unmark “CRM Application Server Java” then
  • Mark “CRM Application Server Java NW7.3” instead.

Additional Information

  • Also check SAP Note 1468349 - SAP Business Suite 7 for SAP NetWeaver 7.3 hub systems (SAP Service Marketplace login required)
  • Technical Systems should register in the SLD whenever possible, because automatic and repeated registration helps keeping system data up-to-date. Information on the SLD can be found under System Landscape Directory (SLD) 
  • Information in Transaction SMSY for systems registered via the SLD can be checked using teh landscape verification tool. Information on the landscape verification tool can be found under Landscape Verification

Comments

Actions

Filter Blog

By date:
By tag: