8 Replies Latest reply: Aug 12, 2008 9:37 AM by Andrzej Chmura RSS

Output type SPED

Pedro Grabulho
Currently Being Moderated

Hi Gurus,

 

First of all I would like to know if anybody has already used the standard output type for the Deliveries (V2): SPED, which generates one inbound delivery based on the outbound one?

If so, does anyone knows which are the requirements to use it, and which are the mapped fields between these two documents?

 

Thank you in advance for your cooperation. Helpful answers will be rewarded.

 

Best regards,

Pedro.

  • Re: Output type SPED
    M. de Zeeuw
    Currently Being Moderated

    Hi,

     

    I am using it on my current project. We're using it for STO's (obviously) and main settings are the customizing for the message determination and create condition records for it. Fields that are being mapped are all plant and SLOC details, HU's, batches, valuation types etc.

     

     

    Regards,

     

    MdZ

  • Re: Output type SPED
    Andrzej Chmura
    Currently Being Moderated

    Hello Pedro,

     

    I am using it in production system to transfer HU from outboiund to inbound delivery using STO scenario.

     

    Please refer to OSS note which describe functionality of SPED:

     

    [Note 1119073 - FAQ: Automatic inbound delivery creation for stock transfers|https://websmp130.sap-ag.de/sap(bD1wbCZjPTAwMQ==)/bc/bsp/spn/sapnotes/index2.htm?numm=1119073].

     

    You can find configuration tips in another OSS note:

     

    [Note 965176 - Creation of inbound delivery during two-step stock transfers|https://websmp130.sap-ag.de/sap(bD1wbCZjPTAwMQ==)/bc/bsp/spn/sapnotes/index2.htm?numm=965176]

     

    It works OK. Please analyse also all related OSS notes.

     

    Andrzej

    • Re: Output type SPED
      Pedro Grabulho
      Currently Being Moderated

      Hello Andrzej,

       

      Your scenario is very similar to mine. Because I wanted to maintain the standard, Iu2019ve generated a ZSPD output type in order to use other table conditions and assign to it a different access sequence. If I process manually the ZSPD, it works perfectly and generates my Inbound Delivery. The problem is to the trigger the output automatically. After a GI is posted, the program checks if there exists a subsequent document u20187u2019 (VBFA-VBELN) that corresponds to the Inbound delivery (I am using the requirement 408)u2026 I suppose that is something in control data of the output determination procedure, but I donu2019t figure where it can beu2026 What was implemented before my arrival was to generate 2 documents in the same flow used the requirement u20181u2019. Those condition types were based in developed programsu2026 the flow started to increase and they start to have errors and with that more error handling.

      Can you have a clue how can I trigger? Iu2019ve maintained the conditions table for that condition type, but without the automatic and expected result.

       

      Thank you in advance for your cooperation! 

       

      Best regards,

      Pedro.

      • Re: Output type SPED
        M. de Zeeuw
        Currently Being Moderated

        Hi,

         

        You mention that you can manually process it, does that mean that the message type is not determined automatically or does it come up in the inbound delivery but it won't run?

         

         

        MdZ

      • Re: Output type SPED
        Andrzej Chmura
        Currently Being Moderated

        Hello,

         

        I do not exactly understand your problem .

        I use output procedure V10000 and also requirement 408 for SPED.

        In condition record you must set in field medium value 8 (Special function). Depending on your requirements you can set dispatch time for

         

        "3" -     Send with application own transaction (in this case you can process SPED in transaction VL71)

        "4" -     Send immediately (when saving the application)

         

        Andrzej

        • Re: Output type SPED
          Pedro Grabulho
          Currently Being Moderated

          Hello MdZ and Andrzej,

           

          I did all the correct procedures and everything that you have mentioned, but the message didn't appear on the output for delivery (not green, yellow or red). So I though that probably it was because I was using Outbound Deliveries that were already in the system and I just processed the GI.

          Apparently, it worked for the whole new flow that started from the STO with different supplying plants, shipping points and assignment of the new conditions. (welcome to the amazing world of informatics...   ). It seems to me that I've miss some condition assigned.

           

          I will continue with more tests.

           

          Thank you guys!!

           

          Best regards,

          Pedro.

Actions