5 Replies Latest reply: Feb 13, 2009 12:41 AM by Ingo Hilgefort RSS

Can't saving Crystal Reports to BW

Sebastian Li
Currently Being Moderated

Hello there.

 

I've got a problem with saving reports to the BW-System from a client pc.

I'm using the toolbar of the Integration Kit for saving.

 

Here's the error message (I get it in german, so maybe it's not 100% the english one):

 

Failed to open and/or saving. The server returned errorcode 6.

Failed to open the report.

 

I've installed the BO Client Tools plus the Fix Pack 2 (Build 12.0.0.840).

SAP Integration Kit and Crystal Reports were on version 12.0.0.840, too. Both with Fix Pack 2 installed.

 

Thanks in advance for your help.

 

Greetings,

Sebastian

  • Re: Can't saving Crystal Reports to BW
    Ingo Hilgefort
    Currently Being Moderated

    hi Sebastian,

     

    I assume the SAP GUI is installed as well ?

     

    did you check the authorization part ?

     

    when does it fail ? during the save into BW or when publishing to the BOE server ?

     

    Ingo

    • Re: Can't saving Crystal Reports to BW
      Sebastian Li
      Currently Being Moderated

      Hello Ingo.

       

      Thanks again for your answer.

       

      I've tested it on a client from a college and there the hole publishing process (saving to BW and content publishing) is working fine. The report is saved and accessable in BW and BO.

       

      But on my client pc the error occurs when I want to save the report to the BW.

      The error message comes up immediately after the window where to choose if the report should be prepared for translating and published to enterprise.

       

      Somehow curious is the fact that I'm able to open reports from the BW.

      Only the saving isn't possible.

       

      Greetings

      Sebastian

      • Re: Can't saving Crystal Reports to BW
        Ingo Hilgefort
        Currently Being Moderated

        HI,

        and you are using the same SAP user credentials ?

         

        Ingo

        • Re: Can't saving Crystal Reports to BW
          Sebastian Li
          Currently Being Moderated

          Hi Ingo.

           

          Sure. I'm using the same credentials.

          Meanwhile I've installed Crystal Reports and the Integration Kit on a virtual machine thats running on my client. (connected with network address translation, meaning the vm has the same ip as the host)

           

          I think it's a problem with the versions.

           

          On my virtual machine I've installed version 12.0.0.683 of Crystal and the Integration Kit. Here the saving and publishing are working!

           

          On my client pc (in my case also the the host) the version 12.0.0.840 is installed. Thats the 12.0.0.683 build plus the FixPack2. Here it is not working.

           

          I've checked the versions on my BO-server, too. Everything on build 12.0.0.683.

           

           

          Sebastian

Actions