13 Replies Latest reply: Oct 2, 2011 6:52 AM by Muhammad Kashif RSS

How to enable REST

Selva Kumar P
Currently Being Moderated

Dear all,

 

We are using Tomcat 5.520.

 

I start tomcat, and access the following URL

http://localhost:8080/dswsbobje/services/

 

It gives the result in explorer

Please enable REST support in WEB-INF/conf/axis2.xml and WEB-INF/web.xml

 

What is this error ?

How to resolve this error?

 

Kindly guide me da..

 

Regards,

skiruba

  • Re: How to enable REST
    Efstratios Karaivazoglou
    Currently Being Moderated

    Hi,

     

    this is not necessarily something you should care about. The URL you mentioned is supposed to be used by clients (like the LiveOffice and QueryAsAWebService Connections in xcelsius) in order to access web services exposed by your BOBJ server. This error message relates to an tomcat component which is not relevant to the BOBJ functionality.

     

    You can test your web services using LiveOffice or the QueryAsAWebService configuration tool.

     

    Regards,

     

    Stratos

    • Re: How to enable REST
      Selva Kumar P
      Currently Being Moderated

      hi

       

      sorry for late reply..

       

      How to check in web services using LiveOffice or the QueryAsAWebService configuration tool.

      please guid me..

       

      Regards,

      kiruba

      • Re: How to enable REST
        Efstratios Karaivazoglou
        Currently Being Moderated

        Hi kiruba,

         

        did you install live office on your client? If yes then please start excel, open the "liveoffice" menu and choose "options". Go to the "Enterprise" tab, select the "use specified logon criteria" checkbox and enter valid BOBJ credentials in the user name and password fields. The  Web Services URL should be:

         

        http://<name of your BOBKJ web server>:8080/dswsbobje/services/session

         

        Under System you should enter your CMS server (same as on the InfoView)

        Do not forget to choose the appropriate authorization type depending on which BOBJ credentials you are using.

         

        If everything is configured ok then you can try to insert Crystal or Web Intelligence reports in Excel: Open again the "LiveOfficeMenu" and select "Insert->Crystal Reports Content" or "Insert->Web Intelligence Content". A browser window appears that lets you navigate through the BOBJ repository and choose the report you want to import.

         

        Regards

         

        Stratos

        • Re: How to enable REST
          Selva Kumar P
          Currently Being Moderated

          hi dear,

           

          We are not using live office. only BO has installed.

           

          It is must this configuration.

           

          the issue is we have give the path.

          http://<name of your BOBJ web server>:8080/dswsbobje/services/

          getting an error like

           

          Please enable REST support in WEB-INF/conf/axis2.xml and WEB-INF/web.xml

           

          Regards,

          kiruba.

          • Re: How to enable REST
            Efstratios Karaivazoglou
            Currently Being Moderated

            Hi kiruba,

             

            do you have the BOBJ client tools installed? You can use then QueryAsAWebService to test your web services. Just start the program (normally to be found under Start->Programs->Business Objects XI 3.0->Business Objects Enterprise Clients Tools->QueryAsAWebService) and the connection wizard will start. Choose to add a new server and give your BOBJ server name together with your user id and password  for the BOBJ server. Then you will be prompted to create a web service exposing a universe out of your BOBJ repository. Give the name of the service and in the next window we must see a list of the available universes. If you do then your web services are installed correctly.

             

            Regards,

             

            Stratos

             

            Edited by: Efstratios Karaivazoglou on Feb 25, 2009 3:35 PM

            • Re: How to enable REST
              Currently Being Moderated

              Hi,

               

              I am also facing the same error message but with a bit different workflow.

               

              What I am doing is I am trying to login into Live Office (BO Enterprise is 3.1) the url: https://<ServerName>:<Port>/dswsbobje/services/session

               

              It comes up with the exclamation mark and does not allows to login. When I hover my mouse over that exclamation mark, it shows that the "underlaying connection is closed."

               

              Now, when I use the same url in the browser, it gives me the error: "Please enable REST support in WEB-INF/conf/axis2.xml and WEB-INF/web.xml"

               

              I tried checking the axis validation page (url: https://<ServerName>:<Port>/dswsbobje) and it askes for the validation, also when I go for the validation, it validates (reaches the Happy Axis page).

               

              One Interesting thing is, the same url validates and allows login in QaaWS.

               

              Please let me know if this can be resolved. Thanks in advance for your help.

               

              Regards,

              Shirish

              • Re: How to enable REST
                Efstratios Karaivazoglou
                Currently Being Moderated

                Hi Shirish,

                 

                I noticed you use https as transfer protocol. Did you try the QueryAsAWebService and LiveOffice clients from the same machine?

                 

                Regards,

                 

                Stratos

                • Re: How to enable REST
                  Currently Being Moderated

                  Hey, thanks for the reply.

                   

                  Yes, the Live Office and the QaaWS are installed on the same machine.

                   

                  Thanks,

                  Shirish

                  • Re: How to enable REST
                    Efstratios Karaivazoglou
                    Currently Being Moderated

                    Hi  Shirey,

                     

                    strange behaviour. Are you using the SAP authentification to access reports in LiveOffice. It may be an option to reinstall LIveOffice. Make sure that you are using LiveOffice XI 3.1 and that you have the same fix packs on your client installed as on your BOBJ server.

                     

                    As said before you should not care about the "REST ..." error message. It is the default Tomcat response and I also get it in my setup but everything (both LiveOffice and QaaWS) works fine.

                     

                    Regards,

                     

                    Stratos

                    • Re: How to enable REST
                      Currently Being Moderated

                      Hey Stratos,

                       

                      Thanks for the reply.

                       

                      That error "Please enable REST support in WEB-INF/conf/axis2.xml and WEB-INF/web.xml" is not coming while logging into Live Office, but it is coming when I use the Live Office connection URL in the Browser.

                       

                      Till now, I am able to find out that the browser message: "Please enable REST support" is for Highlevel WSDL , webservice programming.

                       

                      It comes with Tomcat 5.5 and you need to enable that. This is not our concern, and hence we can safely ignore that message.

                       

                      Issue is I am not able to login to the Live Office. When I try to update the URL, at the Live Office logon, it just not allows me to hit the OK button.

                       

                      This can be due to the version mismatch of the Client and Server. BO Server is surely 3.1, I will check again the client tool's version.

                       

                      Please let me know if you have something on this.

                       

                      Thanks in advance,

                       

                      Regards,

                      Shirish

  • Re: How to enable REST
    Sumesh Madathingal
    Currently Being Moderated

    Hi Everyone,

     

    Is the issue resolved..We are also facing the same issues.It gives the result in explorer

    Please enable REST support in WEB-INF/conf/axis2.xml and WEB-INF/web.xml

  • Re: How to enable REST
    Muhammad Kashif
    Currently Being Moderated

    How to enable REST

    By default REST is disabled in Axis 2. We need to enable it. We need to go to the following folder. Assuming that Business Objects and TomCat is installed on C: drive and you have 64 bit operating system. if you have 32 bit operating system then it will be like

     

    1.     C:\Program Files\Business Objects\Tomcat55\webapps\dswsbobje\WEB-INF\conf              (for 32 Bit OS)

    2.     C:\Program Files (x86)\Business Objects\Tomcat55\webapps\dswsbobje\WEB-INF\conf         (for 64 Bit OS)

    3.     There is a file with the name axis2.xml

    4.     This file is an XML File and contains many parameteres as well as many other things.

    5.     Copy and paste this file with a different name to keep one original copy of the file as a backup.

    6.     Open the axis2.xml file in Notepad or 'XML Editor' to edit

    7.     Find out the REST word

    8.     You will see a line like this

    <parameter name="disableREST" locked="true">true</parameter>

    We need to replace' true' with 'false' to enable REST, and after the changing that line will look like following

    <parameter name="disableREST" locked="true">false</parameter>

    9.     Now save the file and restart the web server or to make it simple restart your computer if Web server is installed on your local computer. And most probably your live office will be working fine.

Actions