13 Replies Latest reply: Mar 17, 2009 10:13 AM by Nitin Salunkhe RSS

STMS problem

Nitin Salunkhe
Currently Being Moderated

Hi,

we have added our production server in STMS configuration

But it is not reading our common Transpord directory's request

 

we are on DB2 9.1 and using win2003 64bit

 

we found differnce in transport tool parameters in STMS transactions.

There are additionl entries in Dev and Qty but not in PRD.

 

 

Thanks in advance.

 

Regards,

Nitin Salunkhe

  • Re: STMS problem
    Deepanshu Sharma
    Currently Being Moderated

    Hi Nitin,

     

    Are all three servers in same zone.

     

    To tcode 'dico' to reconfigure your TMS again. (delete and setup a new one.) ...

     

    Cheers

    Deepanshu

  • Re: STMS problem
    Dibya R Das
    Currently Being Moderated

    Hi,

     

    Follow this SAP Note end-to-end, this should solve your problem:

     

    https://service.sap.com/sap/support/notes/62739

     

    - Regards, Dibya

    • Re: STMS problem
      Nitin Salunkhe
      Currently Being Moderated

      Hi deepanshu,

      there is no such tcode in the system as dico?

      and I cant delete TMS config as I have already set up quality and Dev

       

      after deletion TMS config which cause me to assign target client to each request again..

       

      Regards,

      Nitin Salunkhe

  • Re: STMS problem
    Nick Loy
    Currently Being Moderated

    Hi Nitin,

     

    In your scenario i will recommend to delete your PRO from STMS landscape, then re-add the same to existing landscape. But only the thing is you need to add the old requests ASnWhen required.

     

     

    Regards

    Nick Loy

    • Re: STMS problem
      Nitin Salunkhe
      Currently Being Moderated

      Thanks all

      for your valuable replys

      I tried to delete PRD sysetm from landscape and add it again but not work.

      I faced same problem in Quality but I found finaly it is authorization issue

      I added that time Service ID on both dev and qty server with domain admin rights

      and it worked but now it is not.

       

      Second thing as I mentioned earlier transport tool parameters differ in production thatn qty and dev as follows:

       

      Qty and dev :

       

      TRANSDIR          
      oiaeod00\sapmnt\trans

      CTC                                     1

      DBHOST          oiaeod00

      DBNAME          EOD

      DBTYPE          db6

      IMPORT_SINGLE_ONLY          0

      IMPORT_SINGLE_STRATEGY          0

      NBUFFORM          1

      NO_IMPORT_ALL          0

      REPEATONERROR                      9

      STOPONERROR                      9

      TP_VERSION          266

      WORKFLOW_STRATEGY          0

       

       

      PRD :

       

      TRANSDIR          
      oiaeod00\sapmnt\trans

      CTC                      1

      DBHOST          oiaeop00

      DBNAME          EOP

      DBTYPE          db6

      NBUFFORM          1

      TP_VERSION          266

       

       

      any other suggetion pls

       

      Regards,

      Nitin Salunkhe

      • Re: STMS problem
        Dibya R Das
        Currently Being Moderated

        Hi,

         

        There is nothing to worry as these are local parameters for the SAP Systems - and hence they will differ. Only things that should be same DBTYPE i.e. db6 and the tranport directory.

         

        Rest can differ.

         

        - Regards, Dibya

      • Re: STMS problem
        Rahul Sriram
        Currently Being Moderated

        ok., when u trying o update ocnfiguration wht exactly is the error

         

        & when u login 000 DDIC user & check Consistency for trans dirctory & transtool consistency which is not stable

        .

         

        if any passwords changed for SAPServiceSID that also needs to ba changed care where your SAP services are running.

         

        also pls tell where excatly & what error u are getting

  • Re: STMS problem
    Nick Loy
    Currently Being Moderated

    Hi Nitin,

     

    Great.. your problem got resolved. And change all paremeters as global then all system pareameteres will become as same. You can change these parameters in your domain controller.

     

     

    Regards

    Nick Loy

  • Re: STMS problem
    Nick Loy
    Currently Being Moderated

    Hi Nitin,

     

    STMS>>>SYSTEMS>>>click on your domain controller system>>>>double click>>>>TTANSPORT TOOL>>>>change>>>>select check box under GLOBAL tab(you need to select one by one which pareameters you want to set them globally)

     

    This should be done in Domain controller only.

     

     

    Regards

    Nick Loy

    • Re: STMS problem
      Nitin Salunkhe
      Currently Being Moderated

      Hi Nick

      thanks for your reply

      I tried that but only defalut tick for global exist on TRANSDIR parameter

      and I cant tick other paramters in change mode also.

       

      for New parameters it is allowing me.

       

      I have added all request in production by tp command. as it was not showing

      but now all new requests are coming in queue.

      but this parameters still not same as with DEV and QTY.

      so dont know where this will going to effect

       

      Regards,

      Nitin Salunkhe

  • Re: STMS problem
    Nick Loy
    Currently Being Moderated

    Hi Nitin,

     

    Some parameters are not usefull(which you mentioned above).

    Because the parameter value is showing as defaule.

     

    Ex: NO_IMPORT_ALL parameter is used to disable the full truck(which will restrict from import all requests) with parameter value 1.

    But above that is showing 0 which is not usable.

     

    Can you explain which parameters you want to keep in your landscape and which are excludable?

     

    And one more hint: You can delete non default parameters from TRANSPORT TOOL tab and recreate (Ex. NO_IMPORT_ALL) then you can able to choose the global tick mark(Edit).

     

    Regards

    Nick Loy

  • Re: STMS problem
    Nitin Salunkhe
    Currently Being Moderated

    Not facing any more problem in STMS

    but as per discussion parameters diff no problem so closing

Actions