11 Replies Latest reply: Aug 22, 2011 10:30 PM by Romerito Silva RSS

Unable to launch the application integration directory

ramesh dv
Currently Being Moderated

I am able to launch Integration Repository and Unable to launch the appliaction Integration Directory error

 

I have check SLDCHECK it's working and also RWB working fine.

 

looking forward your reply on this issue

 

regards

Ramesh

  • Re: Unable to launch the application integration directory
    Shabarish Vijayakumar
    Currently Being Moderated

    /people/shabarish.vijayakumar/blog/2006/02/13/unable-to-open-iresrid-xipipi-71-updated-for-pi-71-support

    ref. this and check if it helps

  • Re: Unable to launch the application integration directory
    joel trinidade
    Currently Being Moderated

    Hi Ramesh,

    I am including a list of possible solutions. There could be many reasons to this problem so i am giving you all possible solutions.

     

    I think you need to clera your JWS cache. to do this, just open your Java Web Start, go to FILE-->PREFERENCES >Advanced> and select the option CLEAR APPLICATION FOLDER.

     

    or

     

    I tried sldcheck transaction and found out that sld is not working .

    When I go through system log user was locked which is used for sldaccess maintained in sldapicust transaction.

    After unlocking same user , problem was resolved.

     

    or

     

    suggest you try installing j2sdk-1_4_2_09.

     

    or

     

    Go thru this blog Unable to open Integration Builder?checklist

    https://www.sdn.sap.com/sdn/weblogs.sdn?blog=/pub/wlg/1688 [original link is broken] [original link is broken] [original link is broken]

     

    or

     

    Java Web Start

    /people/sameer.shadab/blog/2005/11/27/java-web-start

     

    Regards

    joel

  • Re: Unable to launch the application integration directory
    XI trigger
    Currently Being Moderated

    Hi

     

    Check u r local -->drivers -- etc folder --> host file --> u migth have maintained two ip with same host

     

    this may be one of the reason

     

    paste u r error

     

    rgds

    srini

  • Re: Unable to launch the application integration directory
    ramesh dv
    Currently Being Moderated

    An error occurred while launching/running the application.

     

    Title: Integration Builder

    Vendor: SAP AG

    Category: Download Error

     

    Unable to load resource: http://lgscms.lgsglobal.com:50100/dir/directory/aii_ibdir_client.jar

     

    *Launch file :*

    jnlp spec="1.0+" codebase="http://lgscms.lgsglobal.com:50100/dir">

        <information>

            <title>Integration Builder</title>

            <vendor>SAP AG</vendor>

            <homepage href="http://www.sap.com" />

            <description type="one-line">Directory</description>

            <description type="short">Directory</description>

            <description type="tooltip">Directory</description>

            <icon hight="64" href="start/graphics/sap6464.gif" type="splash" width="64" />

            <icon hight="32" href="start/graphics/SAP3232.gif" width="32" />

        </information>

        <security>

            <all-permissions />

        </security>

        <resources>

            <j2se version="1.4+" initial-heap-size="32m" max-heap-size="512m" />

            <jar href="directory/aii_ibdir_client.jar" />

            <jar href="directory/aii_ibdir_core.jar" />

            <jar href="directory/aii_ibdir_sbeans.jar" />

            <jar href="directory/aii_ibdir_rb.jar" />

            <jar href="directory/aii_ib_client.jar" />

            <jar href="directory/aii_ib_core.jar" />

            <jar href="directory/aii_ib_sbeans.jar" />

            <jar href="directory/aii_ib_rb.jar" />

            <jar href="directory/aii_util_icons.jar" />

            <jar href="directory/aii_util_swing.jar" />

            <jar href="directory/aii_util_xml.jar" />

            <jar href="directory/aii_util_xsd.jar" />

            <jar href="directory/aii_utilxi_misc.jar" />

            <jar href="directory/aii_util_rb.jar" />

            <jar href="directory/clientaii_ib_sbeans.jar" />

            <jar href="directory/clientaii_ibdir_sbeans.jar" />

            <jar href="directory/frog.jar" />

            <jar href="directory/focus14.jar" />

            <jar href="directory/sapxmltoolkit.jar" />

            <jar href="directory/jta.jar" />

            <jar href="directory/ejb20.jar" />

            <jar href="directory/exception.jar" />

            <jar href="directory/logging.jar" />

            <jar href="directory/guidgenerator.jar" />

            <jar href="directory/jperflib.jar" />

            <jar href="directory/sapni.jar" />

            <jar href="directory/sapj2eeclient.jar" />

            <property name="sap.theme" value="Streamline" />

            <property name="jnlp.log.initialConfiguration" value="FILE, SIMPLE" />

        <property name="jnlp.com.sap.aii.ib.client.properties" value="com.sap.aii.ib.client., com.sap.aii.ib.core., com.sap.aii.util.xml., com.sap.aii.connect., com.sap.aii.repository.mapping.additionaltypes, com.sap.aii.docu., com.sap.aii.ibrep.core., com.sap.aii.ibdir.core.*" /><property name="jnlp.com.sap.aii.connect.integrationserver.r3.sysnr" value="01" /><property name="jnlp.com.sap.aii.connect.landscape.contextroot" value="sld" /><property name="jnlp.com.sap.aii.connect.cr.name" value="lgscms.lgsglobal.com" /><property name="jnlp.com.sap.aii.ib.client.content.languages" value="EN,DE" /><property name="jnlp.com.sap.aii.connect.repository.contextroot" value="rep" /><property name="jnlp.com.sap.aii.ib.client.login.languages" value="EN,DE" /><property name="jnlp.com.sap.aii.connect.directory.rmiport" value="50104" /><property name="jnlp.com.sap.aii.connect.cr.contextroot" value="sld" /><property name="jnlp.com.sap.aii.connect.rwb.r3.client" value="001" /><property name="jnlp.com.sap.aii.connect.directory.contextroot" value="dir" /><property name="jnlp.com.sap.aii.connect.rwb.contextroot" value="rwb" /><property name="jnlp.com.sap.aii.connect.landscape.httpsport" value="@com.sap.aii.server.httpsport.lcr@" /><property name="jnlp.com.sap.aii.connect.repository.rmiport" value="50104" /><property name="jnlp.com.sap.aii.connect.repository.httpport" value="50100" /><property name="jnlp.com.sap.aii.connect.directory.name" value="lgscms.lgsglobal.com" /><property name="jnlp.com.sap.aii.connect.cr.httpsport" value="@com.sap.aii.server.httpsport.cr@" /><property name="jnlp.com.sap.aii.connect.repository.name" value="172.16.16.42" /><property name="jnlp.com.sap.aii.connect.integrationserver.contextroot" value="run" /><property name="jnlp.com.sap.aii.connect.integrationserver.name" value="lgscms.lgsglobal.com" /><property name="jnlp.com.sap.aii.connect.rwb.httpsport" value="@com.sap.aii.connect.rwb.httpsport@" /><property name="jnlp.com.sap.aii.connect.landscape.httpport" value="50100" /><property name="jnlp.com.sap.aii.docu.languages" value="null" /><property name="jnlp.com.sap.aii.ib.client.jnlp.j2se.initialheapsize" value="32m" /><property name="jnlp.com.sap.aii.util.xml.parserFactory" value="com.sap.engine.lib.jaxp.SAXParserFactoryImpl" /><property name="jnlp.com.sap.aii.connect.directory.httpport" value="50100" /><property name="jnlp.com.sap.aii.connect.directory.httpsport" value="@com.sap.aii.server.httpsport.directory@" /><property name="jnlp.com.sap.aii.connect.integrationserver.r3.httpport" value="8001" /><property name="jnlp.com.sap.aii.connect.rwb.name" value="lgscms.lgsglobal.com" /><property name="jnlp.com.sap.aii.connect.integrationserver.r3.client" value="001" /><property name="jnlp.com.sap.aii.connect.cr.httpport" value="50100" /><property name="jnlp.com.sap.aii.connect.landscape.name" value="lgscms" /><property name="jnlp.SAPMYNAME" value="lgscms_LXI_01" /><property name="jnlp.com.sap.aii.connect.rwb.httpport" value="50100" /><property name="jnlp.com.sap.aii.docu.url" value="null" /><property name="jnlp.com.sap.aii.ib.client.applicationname.directory" value="sap.com/com.sap.xi.directory/" /><property name="jnlp.com.sap.aii.util.xml.transformerFactory" value="com.sap.engine.lib.jaxp.TransformerFactoryImpl" /><property name="jnlp.com.sap.aii.ib.client.applicationname.repository" value="sap.com/com.sap.xi.repository/" /><property name="jnlp.com.sap.aii.ib.client.login.InitialContextFactory" value="com.sap.engine.services.jndi.InitialContextFactoryImpl" /><property name="jnlp.com.sap.aii.connect.integrationserver.httpport" value="50100" /><property name="jnlp.client" value="true" /><property name="jnlp.com.sap.aii.connect.repository.httpsport" value="@com.sap.aii.server.httpsport.repository@" /><property name="jnlp.com.sap.aii.ib.client.jnlp.j2se.maxheapsize" value="512m" /><property name="jnlp.com.sap.aii.connect.integrationserver.httpsport" value="@com.sap.aii.connect.integrationserver.httpsport@" /><property name="jnlp.com.sap.aii.connect.integrationbuilder.startpage.url" value="rep/start/index.jsp" /><property name="jnlp.com.sap.aii.connect.integrationserver.r3.httpsport" value="@com.sap.aii.connect.integrationserver.r3.httpsport@" /><property name="jnlp.com.sap.aii.connect.rwb.r3.sysnr" value="01" /><property name="jnlp.com.sap.aii.util.xml.schemaValidator" value="com.sap.engine.lib.schema.validator.SchemaValidator" /><property name="jnlp.rc.release" value="7_00" /><property name="jnlp.rc.applname" value="DIRECTORY" /><property name="jnlp.rc.supportpackage" value="06" /><property name="jnlp.rc.synctime" value="${sync.time}" /></resources>

        <application-desc main-class="com.sap.aii.ibdir.gui.appl.ApplicationImpl">

            <argument>webstart</argument>

        </application-desc>

    </jnlp>

    • Re: Unable to launch the application integration directory
      XI trigger
      Currently Being Moderated

      Hi

       

      maintain u r

       

      <ip> host in --> host file

       

      see if u r having any duplicate host names too

       

      it wud work

       

      rgds

      srini

    • Re: Unable to launch the application integration directory
      Shabarish Vijayakumar
      Currently Being Moderated

      1. did you follow the blog i had mentioned?

      2. check the java SDK version. for XI 3.0 and PI 7.0, have the SDK version 1.4.xx i.e below less than 1.5

      • Re: Unable to launch the application integration directory
        Amar Srinivas Eli
        Currently Being Moderated

        Hi!

         

        I have faced this issue daily so many times when ever I closed IR and ID and before opening next time I will the do this simple activity and then I will launch Integration Builder and continue my work..

         

         

        1) Got o RUN--> type JAVAWS...

            then java loads and java application properties will open

         

        2) In this u can check 2 tabs a) USER and b) SYSTEM

           THere in the User tab u can able to Java CaCHE applications viewers which occured due to intial 

           loading of java while opening IR and ID.

         

        3) Select those CAHCE and click remove application.

         

         

        Now open your Integration Builder URl and u can open ur IR and ID very easily in normal way.

         

         

        II) ANother WAY

         

        1) Go to Control Pannel--> select java and double click -->

         

        2)  open Setttings present in the general tab.

         

        3) Now click View Applications and remove cache applications

         

        4) If still not working u can Click Delete files so that jnlp loaded files will be deleted and it will launch IR and ID freshly.

         

        III) Thrid way::

         

        1) go to run>CMD>type ( java -version)

        so that u can able to view your java version...

         

        C:\Documents and Settings\XXXXXX>java -version

        java version "1.5.0"

        Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0-

        Java HotSpot(TM) Client VM (build 1.5.0-b64, mixed mode)

         

         

        2) Ask your network people to install updates or else new Java version or else to re-install the same version.

         

        Regards::

        Amar Srinivas

        • Re: Unable to launch the application integration directory
          ramesh dv
          Currently Being Moderated

          I have uninstalled all higher version java 1.5 and above on system

           

          my current version java jre 1.4.2.09 still i am facing the same problem. I am able to launch the Integration repository when i try to launch Integration Directory (Unable to launch the application Integration Directory)

           

          I have also chekd the host file i have only 1 ip pointing same host name.

           

          I have also cleard the cache on javaws to now its empty - still i am not able to launch ID

          • Re: Unable to launch the application integration directory
            Amar Srinivas Eli
            Currently Being Moderated

            Hi! Ramesh,

             

            Just try with latest versoin either java 1.5 or1.6

             

            also if any more version are already installed there in ur system..then

            1) go to >conrol Pannel>double click JAVA> click java tab next to general tab> in that view Java Application RUn time settings>click view> and click only one which is latest version if there are 2-3 old versions.

             

             

            2) go to SAME PATH and above to java application Run time settings click and open JAVA RUN TIME Settings and then select if any updated versions are installed to the current verssion..

             

            Now try again..If still any issues are there contact basis people to open the java or j2ee logs..

             

            Regards::

            Amar Srinivas ELi

      • Re: Unable to launch the application integration directory
        ramesh dv
        Currently Being Moderated

        it's PI 7.0 and Java version 1.4.2.09

         

        I have uninstalled all the higher verion and resinstalled the 1.4.2.09, but still i face the same issue

  • Re: Unable to launch the application integration directory
    Romerito Silva
    Currently Being Moderated

    Guys,

    You can go on NWA and re-generate and re-signature the java packages.

    This error occurs because the packages were signed wrong.

     

    Try this and let me know if are working!

     

    regards,

    Romerito

Actions