13 Replies Latest reply: Mar 31, 2010 10:23 PM by anup garg RSS

AET issue: Problem in generating Z fields

chand shaik
Currently Being Moderated

Hi Experts,

 

We released the service request of the Zfields to Quality server. But request is released with problem as u2018Enhancement   is not active and cannot be transportedu2019.

 

Note: We created Zfields using AET tool. Fields was created successfully but with error (Fields was not generated). However we are able use those fields without an issue.

 

I tried to regenerate the Extension ID of the Zfield in extension analyzer. But it is not generating and showing message as u2018ZAEXT00004V     was not generatedu2019

 

Please help me to rectify this scenario

 

Thanks in advance

Chand

  • Re: AET issue: Problem in generating Z fields
    Steve Jonathan Tirtha
    Currently Being Moderated

    Hi,

     

    we do not allow user to transport inactive/error enhancement.

    If AET shows that the field enhancement still has an error, there muss be something not correctly generated.

    You might able use the field, as soon the field is generated in the BOL structure.

     

    Please open the enhancement using transaction AXTSHOW, in this transaction you will have the Generate button, to generate the field from the transaction. Otherwise you can also use the report AXT_EXT_GENERATE to generate the field.

     

    If you're still not able to generate the field successfully, please provide me the complete error message.

     

    Regards,

    Steve

  • Re: AET issue: Problem in generating Z fields
    Steve Jonathan Tirtha
    Currently Being Moderated

    Hi,

     

    I try to give you some feedbacks:

    1. This error: E060 (AXT_COMMON): Unknown dynpro popup was raised during generation of BWA_DATASOURCE_FIELD 0CRM_SRV_PROCESS_H, should not come if you generate the enhancement using AXTSHOW. I hope, you did not forget to press the "Generate Button". The error comes only if you generate the enhancement in WebUI. The reason for this is because AET uses some NetWeaver API for the generation, some of the API are not dynrpo free. It means the API requires user interaction. This cannot be visualize in WebUI.

     

    2. You said, you've already released on enhancement with error. An enhancement with error cannot be transported. The BEFORE_EXPORT FM will raise an error, if you try to export an enhancement with error.

     

    If you do not come any further, please create a CSN message. This kind of issue needs to be investigated directly in the customer system.

     

    Regards,

    Steve

    • Re: AET issue: Problem in generating Z fields
      chand shaik
      Currently Being Moderated

      You are right steve. Error Message(Unknown dynpro popup was raised during generation of BWA_DATASOURCE_FIELD 0CRM_SRV_PROCESS_H) was raised when I was created the fields in AET only but not in AXTSHOW.

      Fields was created successfully but with error.we are able use those fields without an issue.

       

      After that only I tried to re-generate the enhancement in AXTSHOW. Then I got message as 'ZAEXT00004V was not generatedu2019

       

      Then I released the service request of the Zfields to Quality server.But request is released with problem as u2018Enhancement is not active and cannot be transportedu2019

       

      Again I tried to re-generate the enhancement in AXTSHOW. Then I got message as 'ZAEXT00004V was not generatedu2019.

       

      As your input i cannot transoprt the request (which is released with errors) to Quality.

      I dont know about CSN message. can you please help what is CSN message and how it will help me rectify the problem.

       

      Regards

      Chand

  • Re: AET issue: Problem in generating Z fields
    Steve Jonathan Tirtha
    Currently Being Moderated

    Hi,

     

    the message "<EXT_ID> was not generated" is raised, because the generation is failed.

    Can you go back to AXTSHOW and see in the Log Message what is the error?

    And maybe just copy paste the error in this posting.

     

    On the other hand, you can create a CSN message to SAP support. Please inform your self from other collegues how to create a CSN message. But I hope, we can solve your problem via this forum.

     

    Regards,

    Steve

  • Re: AET issue: Problem in generating Z fields
    Steve Jonathan Tirtha
    Currently Being Moderated

    Hi Chand and Sijo,

     

    the error message "Unknown Dynpro ....." is raised under circumstances where AET calls Netweaver generation class or function module which raise a dynpro that requires user interaction.

    In CRM Web UI we cannot simulate the Dynpro, therefore the generation process will be terminated and this error will be raised.

    However, if you run the generation from SAP GUI using AXTSHOW this should work.

     

    I do not know exactly what causes the error in your system. Therefore, please raise a CSN message.

     

    Regards,

    Steve

Actions