11 Replies Latest reply: Mar 19, 2010 11:06 AM by Dharmendra Kumar RSS

2EETW169 no connect possible: "DBMS = ORACLE --- dbs_ora_tnsname = 'DEV'"

Ankita Kapoor
Currently Being Moderated

Hello,

 

I have upgraded from oracle 9i to 10g on windows itanium2 64 bit server and now running "R3trans-x" from user - <sid>adm is failing .

 

Pls guide me how to resolve this issue.

 

 

******

 

The error details are -

C:\Documents and Settings\devadm>r3trans -x

This is r3trans version 6.13 (release 640 - 26.05.09 - 10:25:00).

unicode enabled version

2EETW169 no connect possible: "DBMS = ORACLE                           --- dbs_o

ra_tnsname = 'DEV'"

r3trans finished (0012).

 

C:\Documents and Settings\devadm>more trans.log

4 ETW000 r3trans version 6.13 (release 640 - 26.05.09 - 10:25:00).

4 ETW000 unicode enabled version

4 ETW000 ===============================================

4 ETW000

4 ETW000 date&time   : 03.12.2009 - 12:27:30

4 ETW000 control file: <no ctrlfile>

4 ETW000 R3trans was called as follows: r3trans -x

4 ETW000  trace at level 2 opened for a given file pointer

4 ETW000  [dev trc     ,00000]  Thu Dec 03 12:27:30 2009

   12931  0.012931

4 ETW000  [dev trc     ,00000]  db_con_init called

      38  0.012969

4 ETW000  [dev trc     ,00000]  create_con (con_name=R/3)

    5688  0.018657

4 ETW000  [dev trc     ,00000]  Loading DB library 'dboraslib.dll' ...

      56  0.018713

4 ETW000  [dev trc     ,00000]  DlLoadLib success: LoadLibrary("dboraslib.dll"),

hdl 0, addr 0000000010000000

4 ETW000

   39285  0.057998

4 ETW000  [dev trc     ,00000]      using "K:\usr\sap\DEV\SYS\exe\uc\NtIa64\dbor

aslib.dll"

4 ETW000

      44  0.058042

4 ETW000  [dev trc     ,00000]  Library 'dboraslib.dll' loaded

      31  0.058073

4 ETW000  [dev trc     ,00000]  function DbSlExpFuns loaded from library dborasl

ib.dll

4 ETW000

    2600  0.060673

4 ETW000  [dev trc     ,00000]  Version of 'dboraslib.dll' is "640.00", patchlev

el (0.276)

4 ETW000

   31129  0.091802

4 ETW000  [dev trc     ,00000]  function dsql_db_init loaded from library dboras

lib.dll

4 ETW000

    2958  0.094760

4 ETW000  [dev trc     ,00000]  function dbdd_exp_funs loaded from library dbora

slib.dll

4 ETW000

      58  0.094818

4 ETW000  [dev trc     ,00000]  New connection 0 created

      47  0.094865

4 ETW000  [dev trc     ,00000]  000: name = R/3, con_id = -000000001, state = DI

SCONNECTED, tx = NO , hc = NO , perm = YES,

4 ETW000                             reco = NO , frco = NO , timeout = 000, con_

max = 255, con_opt = 255, occ = NO

4 ETW000

      88  0.094953

4 ETW000  [dev trc     ,00000]  db_con_connect (con_name=R/3)

      37  0.094990

4 ETW000  [dev trc     ,00000]  find_con_by_name found the following connection

for reuse:

4 ETW000

      44  0.095034

4 ETW000  [dev trc     ,00000]  000: name = R/3, con_id = 000000000, state = DIS

CONNECTED, tx = NO , hc = NO , perm = YES,

4 ETW000                             reco = NO , frco = NO , timeout = 000, con_

max = 255, con_opt = 255, occ = NO

4 ETW000

      78  0.095112

4 ETW000  [dev trc     ,00000]  Setting DIR_CLIENT_ORAHOME is not set as environ

ment variable,

4 ETW000                        assuming using instant client with unspecified l

ocation.

4 ETW000

   13641  0.108753

4 ETW000  [dev trc     ,00000]  -->oci_initialize (con_hdl=0)

    5503  0.114256

4 ETW000  [dev trc     ,00000]  got NLS_LANG='AMERICAN_AMERICA.UTF8' from enviro

nment

4 ETW000

      53  0.114309

4 ETW000  [dev trc     ,00000]  Thu Dec 03 12:27:31 2009

  515401  0.629710

4 ETW000  [dboci.c     ,00000]  *** ERROR => OCI-call 'OCIEnvCreate(mode=16384)'

failed: rc = -1

4 ETW000

      60  0.629770

4 ETW000  [dev trc     ,00000]     set_ocica() -> OCI or SQL return code -1

      40  0.629810

4 ETW000  [dboci.c     ,00000]  *** ERROR => OCI-call 'OCIErrorGet' failed: rc =

-2

4 ETW000

     129  0.629939

4 ETW000  [dblink      ,00430]  ***LOG BY2=>sql error -1     performing CON [dbl

ink#6 @ 430]

4 ETW000

   27514  0.657453

4 ETW000  [dblink      ,00430]  ***LOG BY0=>Cannot get Oracle error text. [dblin

k#6 @ 430]

4 ETW000

      48  0.657501

2EETW169 no connect possible: "DBMS = ORACLE                           --- dbs_o

ra_tnsname = 'DEV'"

 

C:\Documents and Settings\devadm>

 

 

 

*****************************************

Pls help

 

 

Regards,

Ankita

Actions