15 Replies Latest reply: Aug 23, 2010 12:42 PM by Guest RSS

Express document error

acapulco acapulco
Currently Being Moderated

Gurus,

When i do MIGO,I am getting this error

 

Express document "Update was terminated" received from author XXXX

 

I know the the problem is with Number range,How to fix it in OMBT?

  • Re: Express document error
    Rajendra Sawant
    Currently Being Moderated

    Hi

     

    in ombt click on change group , then select proper group where u want to maintain number range.

    Select that group and go to interval there click on maintain , here you can maintain year wise number range.

  • Re: Express document error
    Currently Being Moderated

    >

    acapulcosdn wrote:

     

    > Gurus,

    > When i do MIGO,I am getting this error

    >

    > Express document "Update was terminated" received from author XXXX

    >

    > I know the the problem is with Number range,How to fix it in OMBT?

     

    Basically this error occurs if printer is not set properly, or number ranges are not getting updated properly. Check the latest number ranges for material document or accounting document, if its problem with material document, when you try to save the document, it will not generate any document, if its problem with accounting document, material document should be created when saving and when accounting document is created it gives this error.

     

    Check whats the current accounting number generated by the system, by viewing correct document number created. Then check the number in spro. They both should be same. If not update the backend number and your problem will be resolved.

  • Re: Express document error
    Currently Being Moderated

    Check this blog I created:

     

    'Express document Update Was Terminated' Error

     

    I came across one problem at one of my projects which I would like to share for everyone's experience.

     

    The problem was when client was doing MIGO and when he was saving the document, it was making the MM document, but when you hit back button or go for display it

    came up with this error 'UPDATE WAS TERMINATED'. This problem came up in both MIGO and SD billing document posting.

     

    Now I had to jott down what the problem really was, so I started closing up on problem, by creating many PO's and doing MIGO'S against them with different document types, all went great and those documents got posted, but when I used the same GL'S as client was using as he was charging it to cost center and the GL'S used there were consumption GL'S,those GL'S were causing the problem. How I found out that GL was causing problem, as I used another GL which was not for consumption and the document got posted.

     

    Now as the problem got cornered, now we had to figure out how to solve it. Here at client we have two plants, one for Pakistan and one for Philippines, so I checked the same scenario on Pakistan and the document got posted with consumption GL as well. So now its more clear that problem is with client Philippines posting.

     

    So I sat down with (ABAP) consultant to check out the problem. He went through his checking and pointed out that one document No.  40000400 was not getting updated. Now the question came what document this number is assigned to. Suddenly it clicked my mind to check the client Pk document which was posted with same Gl, so when we displayed that document we came to

    know that this number range was getting assigned to CONTROLLING DOCUMENT.

     

    So we went back in customizing, and found out that CONTROLLING DOCUMENT current number was stuck on 40000100, whereas the last number recorded in table was 40000400, so we updated the current number there and thats the end PROBLEM SOLVED. This controlling document Number was causing this problem on both MIGO and SD billing document.

     

    Another solution which came to our mind was to clear the Buffer, so that the number ranges of the clients gets updated and we notified our basis person as well but in mean time we solved the issue.

     

    Edited by: Afshad Irani on Aug 23, 2010 1:32 PM

    • Re: Express document error
      Currently Being Moderated

      Continued

       

      Problem No. 2

       

      At one other time, this same error came up, when we were trying to do GOODS ISSUE against STO, whenever we were processing this document, this error popped up and we could not complete the document.

       

      The fix we found out was this error was coming up due to printer setup not maintained, as when we were processing the document it was looking for printer and since no setup was defined, it was giving this error. Fix was we went here: SYSTEM>USER PROFILE>OWN DATA, then clicked on DEFAULTS tab, then under SPOOL CONTROL, maintained the OUTPUT DEVICE field and clicked OUTPUT IMMEDIATELY check and the issue got resolved.

       

      Problem No. 3

       

      Another same error came up when our client was trying to complete release strategy of PO through ME29N, when they finished the releases and tried to save the document, this error popped up, on inquiring we found out that the message determined in MESSAGE button of PO, was coming different than message record we maintained in MN04, now why was the message different coming up when the message record was something different.

       

      On inquiring here: Spro>Materials Management>Purchasing>Messages>Output Control>Message Types>Define Message Types for Purchase Order>Fine-Tuned Control: Purchase Order, we found out that other condition record was defaulted as there was check mark in U box, which was overriding our condition record set in MN04, we removed those checks, then saved the document, and once transported on PRD, the issue got fixed and now it was picking up our original message record set in MN04.

       

      These were my personal experience, with this error and the fixes which I found for removing this error.

  • Re: Express document error
    Jürgen L
    Currently Being Moderated

    explain a bit more detail about your OMBT. what do you see there and what had you done ?

    • Re: Express document error
      acapulco acapulco
      Currently Being Moderated

      Hi,

      When i post migo the document created is   5000000010 & when i see the last number created in OMBT it is 5000000019.

      • Re: Express document error
        Currently Being Moderated

        >

        acapulcosdn wrote:

         

        > Hi,

        > When i post migo the document created is   5000000010 & when i see the last number created in OMBT it is 5000000019.

         

        Your current number is 5-10, so change the number range in OMBT to 5-10 or 5-11 and check then whether the error still persists.

         

        AND

         

        The number range object Matbeleg for Material documents is controlled by Document type in SNRO. Check in SNRO whether there is any buffer set for the numbers. Change the buffer to 1.

         

        Edited by: Afshad Irani on Aug 23, 2010 3:10 PM

        • Re: Express document error
          acapulco acapulco
          Currently Being Moderated

          Hi,

          Now what i have done is against 9999, i have entered to range number to the last number which was created.Then i have entered yr 2010 & assigned new number range.I tried to post the document in MIGO,again same error.

          • Re: Express document error
            Jürgen L
            Currently Being Moderated

            standard settings for number range buffers is 10, which means that SAP takes 10 numbers from the table and stores it in memory.

            so if you change the number range, then SAP may still have several numbers left in memory, and will first look into the number range table when all those numbers in memory are used.

             

            Easiest way to empty this buffer is by logoff the system an logon again.

             

            However, unused numbers will not really cause posting errors, this will only happen if you have already a record in the database for a number that SAP uses to create a new record.

             

            Best you check the number range  for the buffer setting and then check the table entries for the highest number, and then set the number range to a number that is higher than highest number + number from buffer.

             

            Such changes should in any case be done during a time with less traffic, eg. evenings or weekends

          • Re: Express document error
            Currently Being Moderated

            >

            acapulcosdn wrote:

             

            > Hi,

            > Now what i have done is against 9999, i have entered to range number to the last number which was created.Then i have entered yr 2010 & assigned new number range.I tried to post the document in MIGO,again same error.

             

            Look up under groups, material documents for goods receipts, we,wf,wo,ww document types are attached to this group, here which number ranges are assigned to this group, update the status to the current number of this group and make sure to check the snro setting as well and change the buffer to 1 there as well.

      • Re: Express document error
        Rajendra Sawant
        Currently Being Moderated

        Hi

         

        Check ur number range buffer .Set to 1.

Actions