13 Replies Latest reply: Jul 24, 2012 12:12 AM by Jason White RSS

BDLS failed in new system

Arnaud Lambert
Currently Being Moderated

Hi all,

 

We are experiencing an error when runing BDLS in SAP BW 7.0.

 

To give you an overview, I am working on a new production system called BWP (copy of an acceptance system).

Attached to this new BW system, we have a new source system called BRP.

 

In order to change the source system of the old system, I run BDLS (after a successfull test run) with the second option (following a client copy). I noticed that unfortunately, nothing was changed.

 

So, I decided to run BDLS again with the first option.

First, I did a successfull test run, and I noticed that much more table will be converted.

After the test run, I launched the real conversion...

 

Unfortunately, after a while, BDLS is stop and I have the following message:

"The datasource XX_XX_XXXX_XXXX(BRP100)" does not exist in object version A".

 

On my side I tried lot of things:

- I tried to activate the datasource, but it's not working.

- I tried to change value in the table RSDS (datasource) but one more time it didn't worked.

- I tried to reconnect the original system to replicate the datasource in order to activate it, but it didn't work.-

 

Do you have any ideas how to bypass this error?

If you have any experience to share about BDLS, do not hesitate

  • Re: BDLS failed in new system
    Arun Varadarajan
    Currently Being Moderated

    have you run BDLS in BRP to point to your new BW system..?

  • Re: BDLS failed in new system
    Colum Cronin
    Currently Being Moderated

    Hi,

    This is error code RSDS062. It means that the datasource cannot be found in the tbl RSDS.

    So search in RSDS for the datasource, & check what version it is.

    If OBJVER is M, then it must be activated.

     

    Did you follow SAP Note 886102 for the system copy?

    You need to follow each step of the scenario pertaining to your copy.

     

    When running BDLS, generally four scenarios can happen:

    1) no records for either the old or the new name -> table skipped

    2) records with the old name exist -> conversion goes through

    3) records with the new name exist -> table skipped with warning =>

        manual intervention needed, but doublecheck is recommended. In th

        case the conversion log shows '<<' at the affected tables.

    4) records with the old and the new name coexist -> records are skip

        with warning or error (depending on the flag for existence check,

        which is always set except test conversions) -> you have to analy

        the records and to manually delete that records which hold the ol

        logical name and have their identical counterparts which are hold

        the new name.

     

    Also, implement these notes if missing from your BW system:

    1224597  P19:BDLS:DataSource not converted

    1142908 70SP19: BDLS does not convert DTPs

    1149141 70SP18/19: BDLS: Improvements log

    1148403 70SP18: BDLS after early replication

     

    Rgds,

    Colum

    • Re: BDLS failed in new system
      Arnaud Lambert
      Currently Being Moderated

      Hi Cronin,

       

      Regarding the data source, it exist in RSDS:

       

      Table:          RSDS

         DATASOURCE                                      LOGSYS   OBJVERS OBJSTAT ACTIVFL TYPE PRIMSEGID

         XX_XX_XXXXX_XXXXXX_XXXXXX     ERO100     A       INA             D    0001

         XX_XX_XXXXX_XXXXXX_XXXXXX     ERO100     M       INA             D    0001

       

      I tried to activate via the datasource tab in RSA1. It failed.

      I tried to change the value in RSDS with ACT in OBJSTAT but it didn't work.

      I also tried the program RSDS_DATASOURCE_ACTIVATE_ALL  but it failed.

      I also tried to reconnect the source system to replicate the data source, but one more time, it failed.

       

      Is there another way to activate this datasource?

       

      Edited by: Arnaud Lambert on Oct 6, 2010 10:24 AM

  • Re: BDLS failed in new system
    Johannes Michel
    Currently Being Moderated

    Hi Arnaud,

     

    we had exactly the same problem after a SCM system copy. I have updatet the table table RSDS with sql commands. After this update the BDLS run was ok.

    Then I couldn`t execute RSA1 because the logical system has changed. I had to modify table RSBASIDOC manually. Have you some news about this problem with the error message RSDS062? I ask, because we have a few copies per year. It can`t be to intervene manually every time.

     

    Regards,

     

    Joe

    • Re: BDLS failed in new system
      David Schiffhauer
      Currently Being Moderated

      I had similar problems, similar error message from BDLS regarding "The DataSource DS1(RQACLNTxxx) does not exist in object version A"

       

      Table RSDS showed the following:

      DATASOURCE - LOGSYS - OBJVERS - OBJSTAT

      ZDS1 - RPRCLNTxxx A - ACT

      ZDS1 - RPRCLNTxxx M - ACT

       

      I re-ran BDLS, this time specifying a change from  RPRCLNTxxx to  RQACLNTxxx only in table RSDS.

      Once that completed I ran BDLS for other tables.

       

      Results?  The programs completed successfully, and the infopackages, transformations, PSAs, etc. re-appeared. 

       

      It makes some sense; I can understand maybe if there's a foreign key or something preventing a transformation from referencing a data source that doesn't appear properly in table RSDS.

  • Re: BDLS failed in new system
    Jason White
    Currently Being Moderated

    We faced the same issue, after years of trouble we got SAP involved.  It turns out to be that in the source BW system (Production) there were some entries for the target ECC system (QA).  Check table RSOLTPSOURCE in your productive system for entries of the target systems.

Actions