6 Replies Latest reply: Jan 30, 2011 10:54 PM by Rafael Zaragatzky RSS

STO for project stock

Rafael Zaragatzky
Currently Being Moderated

Dear colleagues,

 

This is the first time I am setting up project stock, so I must be doing something wrong! I have a project stock in plant A (big qty, special stock Q) that I want to transport to plant B by means of a intra-company stock transport order (UB order).

 

I have created STO with item category U and account assignment Q (the same WBS element that exists in plant A with high stock). No problem in the STO, but when I am trying to create the delivery, the systems says that only 0 pieces are available.

 

I have also put high qty in the warehouse stock (no special stock) in the same storage location in plant A and tried STO without account assignment (warehouse stock) - this one works okay.

 

What can be the reason? It seems like the ATP check looks in a "wrong place", e.g. in another storage location.

 

If you don't have an idea what can be wrong, maybe you know how I can check what the system is checking (where to debug or some kind of log)? We run ATP check in ECC (not APO).

 

Many thanks in advance,

Raf

  • Re: STO for project stock
    Csaba Szommer
    Currently Being Moderated

    a) Settings for your PO type/plant:

    SPRO > Materials Management > Purchasing > Purchase Order > Set up Stock Transport Order > Assign Delivery Type and Checking Rule

    b) Setting in material master: MARC-MTVFP (checking group)

     

    Based on a) & b) you can check settings in SPRO > Materials Management > Purchasing > Purchase Order > Set up Stock Transport Order > Define Checking Rule

     

    You can check the actrual situation in CO09, entering:

    - proper checkig rule (see above)

    - WBS

    - proper organisational data

     

    Edited by: Csaba Szommer on Jan 28, 2011 5:21 PM

    • Re: STO for project stock
      Rafael Zaragatzky
      Currently Being Moderated

      Thank you, Csaba.

       

      As I mentioned, there's no problem with the stock transport of the warehouse stock between these two plants, so I believe MTVFP is okay. When it comes to the setting of the checking rule for STO, I don't think the problem is there either, since even the STO for the project stock is created without problems (and gets committed qty). The problem arises only when I try to create the delivery (for the project stock) for this STO. The avail. check in delivery fails (though it works okay for delivery of warehouse stock and there's almost unlimited stock of the needed WBS).

       

      If I try CO09 with checking rule B (the one used be deliveries?) it shows only two stock lines: 100 000 pcs of the project stock and 100 000 pcs in storage location 1008 (the correct one), while the delivery that I am trying to create is only for 1000 pcs.

       

      Any ideas why the avail. check fails?

      TIA

      Raf

      • Re: STO for project stock
        Dogboy 49
        Currently Being Moderated

        Raf,

        When you view the STO requirement in MD04 in the supplying plant, is the requirement also for the WBS segment?  Or, is it for warehouse stock (generic stock)?

         

        If you wish to have the STO requirement plan for WBS stock in the supplying plant, make sure that the Material Master of the material in the supplying plant does not have 'Individ/coll' indicator set to 'collective requirements only" (MRP4 tab).

         

        FYI once you get the requirement of the STO in the supplying plant to be 'WBS specific', the ATP checking rule for the delivery will be BQ, not B.

         

        Best Regards,

        DB49

         

        Edited by: Dogboy49 on Jan 30, 2011 8:42 AM

        • Re: STO for project stock
          Rafael Zaragatzky
          Currently Being Moderated

          Thank you, DB49.

           

          A lot of useful info at the same time!

           

          - MD04 in the supplying plant shows the STO under the project segment, not the general segment

          - Individual/collective in the material master - you are right; we had this problem in the beginning before we discovered the error. The problem that I describe appeared however already after we fixed the material master.

          - Checking rule BQ - thank you for the tip! However, the display of CO09 is the same for B and for BQ:

          Shows only two stock lines: 100 000 pcs of the project stock and 100 000 pcs in storage location 1008 (the correct one), while the delivery that I am trying to create is only for 1000 pcs.

           

          I have now tried VL10B again - still the same message "Only 0 ST of material 0101195175 available". So what does "he" want?!

           

          TIA for any ideas,

          Raf

          • Re: STO for project stock
            Dogboy 49
            Currently Being Moderated

            Raf,

            In CO09, the quantity that is of interest to you is the *** ATP qty, not the rec/reqd qty.

             

            I will assume that you have not involved batches in the STO.  I will assume that your availability checking group is for individual requirements (OVZ2, select availability check, ensure that 'total delivery rqment' is 'A')

             

            Finally, I will assume that you know that there are no other requirements for this stock that might have already been confirmed (CO09 *** ATP qty is greater than the delivery you want to create)

             

            In MD04, if the requirement is relevant for a storage location, then you should probably ensure that your scope of check "no storage location inspection" is checked, or make sure that the stock and requirement are for the same location.  You can see scope of check in CO09, you can change it in OVZ9 or similar.

             

            You mentioned some previous setup errors.  You should probably run program SDRQCR21 to ensure that the SD requirements file (VBBE) is still consistent with reality.

             

            Best Regards,

            DB49

            • Re: STO for project stock
              Rafael Zaragatzky
              Currently Being Moderated

              Hi DB49,

               

              Many thanks for keeping up with my case! I have indeed specified avail. check on storage location level because this is the requirement (the flag "no SLoc insp." is not set). When doing STO for the warehouse stock VL10B creates the delivery without the storage location (if there enough stock on plant level) and the users assign the storage location manually - then the system carries out the avil. check for this storage location.

               

              But now I set the tick in the checking rule for BQ, just to see i fit can help some way. VL10B generated the delivery with a storage location and an incorrect one! This explains why the avail. check failed when I did it with storage location.

               

              I will have now to dig into my storage loc. determination - see why it finds a storage location when transporting proj. stock, but not when transporting whse stock.

               

              Many thanks for your help!

              Raf

Actions