34 Replies Latest reply: Aug 13, 2013 4:02 PM by jitendra kansal RSS

SUP-Error creating Unwired Server Connection connection to MyUnwiredServer

Katlego Jack Mohlankana Maja
Currently Being Moderated

Hi all,

I've installed the SUP 1.5.2 and selected the Evaulatiuon (30 day trial) and my Unwired Server cannot start. When i try to test the connection in Enterprise Explorer -> Unwired Servers -> My Unwired Server i get the error.

 

com.sybase.uep.admin.client.AdminException: com.sybase.djc.SystemException: Error: Connecting to host: HOSTNAME.DOMAIN_NAME, port: 2000.

     at com.sybase.sup.admin.client.impl.AdminContext.initialize(AdminContext.java:106)

     at com.sybase.sup.admin.client.impl.AdminContext.getInstance(AdminContext.java:40)

     at com.sybase.sup.admin.client.impl.ServerConnectionImpl.<init>(ServerConnectionImpl.java:22)

     at com.sybase.sup.admin.client.impl.ServerConnectionImpl.<init>(ServerConnectionImpl.java:29)

     at com.sybase.uep.admin.client.ServerConnectionManager.ping(ServerConnectionManager.java:191)

     at com.sybase.uep.admin.client.ServerConnectionManager.updateConnectionProperties(ServerConnectionManager.java:98)

     at com.sybase.uep.admin.client.ServerConnectionManager.clusterConnect(ServerConnectionManager.java:68)

     at com.sybase.uep.datasources.uepprofile.UEPServerConnection.<init>(UEPServerConnection.java:59)

     at com.sybase.uep.datasources.uepprofile.UEPConnectionFactory.createConnection(UEPConnectionFactory.java:16)

     at org.eclipse.datatools.connectivity.internal.ConnectionFactoryProvider.createConnection(Unknown Source)

     at org.eclipse.datatools.connectivity.internal.ConnectionProfile.createConnection(Unknown Source)

     at org.eclipse.datatools.connectivity.internal.ManagedConnection.createConnection(Unknown Source)

     at org.eclipse.datatools.connectivity.internal.CreateConnectionJob.run(Unknown Source)

     at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

Caused by: com.sybase.djc.SystemException: Error: Connecting to host: HOSTNAME.DOMAIN_NAME, port: 2000.

     at com.sybase.djc.rmi.iiop.client.Connection.init(Connection.java:619)

     at com.sybase.djc.rmi.iiop.client.Connection.getInstance(Connection.java:65)

     at com.sybase.djc.rmi.iiop.client.ConnectionPool.iiopConnection(ConnectionPool.java:455)

     at com.sybase.djc.rmi.iiop.client.ConnectionPool.newConnection(ConnectionPool.java:410)

     at com.sybase.djc.rmi.iiop.client.ConnectionPool.get(ConnectionPool.java:152)

     at com.sybase.djc.rmi.iiop.client.ConnectionPool_DJC.get(ConnectionPool_DJC.java:30)

     at com.sybase.djc.rmi.iiop.ObjectRef.$connect(ObjectRef.java:275)

     at com.sybase.djc.org.omg.CosNaming.iiop_stubs.NamingContext._is_a(NamingContext.java:60)

     at com.sybase.djc.rmi.iiop.client.ClientNamingContext.init(ClientNamingContext.java:697)

     at com.sybase.djc.rmi.iiop.client.ClientNamingContext.getInstance(ClientNamingContext.java:76)

     at com.sybase.sup.admin.client.impl.AdminContext.initialize(AdminContext.java:99)

     ... 13 more

Caused by: java.net.ConnectException: Connection refused: connect

     at java.net.PlainSocketImpl.socketConnect(Native Method)

     at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)

     at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)

     at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)

     at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)

     at java.net.Socket.connect(Socket.java:525)

     at java.net.Socket.connect(Socket.java:475)

     at java.net.Socket.<init>(Socket.java:372)

     at java.net.Socket.<init>(Socket.java:186)

     at com.sybase.djc.rmi.iiop.client.Connection.init(Connection.java:607)

     ... 23 more

 

 

When starting  the service manually in Control Panel -> Admin Tools -> Services i get error:

Could not start the SybaseUnwiredPlatformHOST_NAMEServer1 service.

All others services has started successfully.

 

I assume i'm not able to connect to the unwired server becuase the service is not started and i've got no idea why the service can't start. Can someone give me a direction as to what could be the problem.

 

Thank you.

Actions