14 Replies Latest reply: May 9, 2011 7:51 AM by Bradley Jackson RSS

Oracle 11g issue after Unicode Conversion

Bradley Jackson
Currently Being Moderated

Hi all,

 

Over this weekend I have done a Unicode conversion on our QA system. We have a CI server and a DB server.

 

Following the steps for the Target System Installation (once the export completed successfully) I installed the Global Preparation on the DB server, and then did the Database Installation, all went well.

 

The issue is that I have now installed the Central Instance (on the separate server) and it reaches a point in the installation where it needs to check that the database is running on the DB server (which is up) and then start up the SAP instance.

 

But I get an error, and if I run a R3trans -x I get a RC=12 and the following output from the trans.log.

 

Any assistance would be appreciated.

 

Brad

 

 

zamdv20187:vrqadm 30> cat /tmp/sapinst_instdir/ERPEhP4/LM/COPY/ORA/SYSTEM/DISTRIBUTED/AS-ABAP/CI/start_VRQ_DVEBMGS04.log

Database VRQ must be started on remote server

Log on to remote server and start database

zamdv20187:vrqadm 31> R3trans -x

This is R3trans version 6.14 (release 701 - 26.01.09 - 12:46:00).

unicode enabled version

2EETW169 no connect possible: "DBMS = ORACLE                           --- dbs_ora_tnsname = 'VRQ'"

R3trans finished (0012).

zamdv20187:vrqadm 32> cat trans.log

4 ETW000 R3trans version 6.14 (release 701 - 26.01.09 - 12:46:00).

4 ETW000 unicode enabled version

4 ETW000 ===============================================

4 ETW000

4 ETW000 date&time   : 08.05.2011 - 16:03:35

4 ETW000 control file: <no ctrlfile>

4 ETW000 R3trans was called as follows: R3trans -x

4 ETW000  trace at level 2 opened for a given file pointer

4 ETW000  [dev trc     ,00000]  Sun May  8 16:03:35 2011                             147  0.000147

4 ETW000  [dev trc     ,00000]  db_con_init called                                    34  0.000181

4 ETW000  [dev trc     ,00000]  create_con (con_name=R/3)                             52  0.000233

4 ETW000  [dev trc     ,00000]  Loading DB library '/usr/sap/VRQ/SYS/exe/run/dboraslib.so' ...

4 ETW000                                                                              32  0.000265

4 ETW000  [dev trc     ,00000]  load shared library (/usr/sap/VRQ/SYS/exe/run/dboraslib.so), hdl 0

4 ETW000                                                                           15466  0.015731

4 ETW000  [dev trc     ,00000]  Library '/usr/sap/VRQ/SYS/exe/run/dboraslib.so' loaded

4 ETW000                                                                              31  0.015762

4 ETW000  [dev trc     ,00000]  function DbSlExpFuns loaded from library /usr/sap/VRQ/SYS/exe/run/dboraslib.so

4 ETW000                                                                              53  0.015815

4 ETW000  [dev trc     ,00000]  Version of '/usr/sap/VRQ/SYS/exe/run/dboraslib.so' is "700.08", patchlevel (0.25)

4 ETW000                                                                              75  0.015890

4 ETW000  [dev trc     ,00000]  function dsql_db_init loaded from library /usr/sap/VRQ/SYS/exe/run/dboraslib.so

4 ETW000                                                                              21  0.015911

4 ETW000  [dev trc     ,00000]  function dbdd_exp_funs loaded from library /usr/sap/VRQ/SYS/exe/run/dboraslib.so

4 ETW000                                                                              66  0.015977

4 ETW000  [dev trc     ,00000]  New connection 0 created                              22  0.015999

4 ETW000  [dev trc     ,00000]  0: name = R/3, con_id = -000000001 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 255, con_opt = 255, occ                                                                              = NO

4 ETW000                                                                              30  0.016029

4 ETW000  [dev trc     ,00000]  db_con_connect (con_name=R/3)                         30  0.016059

4 ETW000  [dev trc     ,00000]  find_con_by_name found the following connection for reuse:

4 ETW000                                                                              45  0.016104

4 ETW000  [dev trc     ,00000]  0: name = R/3, con_id = 000000000 state = DISCONNECTED, perm = YES, reco = NO , timeout = 000, con_max = 255, con_opt = 255, occ                                                                              = NO

4 ETW000                                                                              23  0.016127

4 ETW000  [dev trc     ,00000]  Oracle Client Version: '10.2.0.2.0'                  590  0.016717

4 ETW000  [dev trc     ,00000]  -->oci_initialize (con_hdl=0)                         33  0.016750

4 ETW000  [dev trc     ,00000]  Client character set UTF16 -> UTF8                  3220  0.019970

4 ETW000  [dev trc     ,00000]  Client NLS setting (OCINlsGetInfo): 'AMERICAN_AMERICA.UTF8'

4 ETW000                                                                              59  0.020029

4 ETW000  [dev trc     ,00000]  Logon as OPS$-user to get SAPVRQ's password           16  0.020045

4 ETW000  [dev trc     ,00000]  Connecting as /@VRQ on connection 0 (nls_hdl 0) ... (dbsl 700 151208)

4 ETW000                                                                              20  0.020065

4 ETW000  [dev trc     ,00000]  Nls CharacterSet                 NationalCharSet              C      EnvHp      ErrHp ErrHpBatch

4 ETW000                                                                              55  0.020120

4 ETW000  [dev trc     ,00000]    0 UTF8                                                      0 0x148e0b70 0x148e85c0 0x148f8cb8

4 ETW000                                                                              62  0.020182

4 ETW000  [dev trc     ,00000]  Allocating service context handle for con_hdl=0       35  0.020217

4 ETW000  [dev trc     ,00000]  Allocating server context handle                      19  0.020236

4 ETW000  [dev trc     ,00000]  Attaching to DB Server VRQ (con_hdl=0,svchp=0x148f8be8,srvhp=0x148fbf48)

4 ETW000                                                                              56  0.020292

4 ETW000  [dev trc     ,00000]  Assigning server context 0x148fbf48 to service context 0x148f8be8

4 ETW000                                                                           45608  0.065900

4 ETW000  [dev trc     ,00000]  Allocating user session handle                       116  0.066016

4 ETW000  [dev trc     ,00000]  Starting user session: OCISessionBegin(con_hdl=0, usr='/',svchp=0x148f8be8, srvhp=0x148fbf48, usrhp=0x148e8dd8)

4 ETW000                                                                              75  0.066091

4 ETW000  [dev trc     ,00000]  Assigning user session 0x148e8dd8 to service context 0x148f8be8

4 ETW000                                                                           22344  0.088435

4 ETW000  [dev trc     ,00000]  -->oci_prepare_stmt(con_hdl=0, len=53, stmth_p=0x14904af0)

4 ETW000                                                                             189  0.088624

4 ETW000  [dev trc     ,00000]         BEGIN DBMS_APPLICATION_INFO.SET_MODULE(:A0,:A1); END;

4 ETW000                                                                              50  0.088674

4 ETW000  [dev trc     ,00000]  CbApplInfoGet() failed! Ignore, but uninstall callback to avoid more erroneous calls

4 ETW000                                                                             408  0.089082

4 ETW000  [dev trc     ,00000]  -->oci_prepare_stmt(con_hdl=0, len=54, stmth_p=0x14905b48)

4 ETW000                                                                              41  0.089123

4 ETW000  [dev trc     ,00000]         BEGIN DBMS_APPLICATION_INFO.SET_CLIENT_INFO(:A0); END;

4 ETW000                                                                              40  0.089163

4 ETW000  [dev trc     ,00000]  -->oci_prepare_stmt(con_hdl=0, len=0, stmth_p=0x14905b48)

4 ETW000                                                                            2950  0.092113

4 ETW000  [dev trc     ,00000]         SELECT SID FROM V$MYSTAT WHERE ROWNUM<2

4 ETW000                                                                              46  0.092159

4 ETW000  [dev trc     ,00000]  Connected to session 132.                           1445  0.093604

4 ETW000  [dev trc     ,00000]  Now '/@VRQ' is connected: con_hdl=0, nls_hdl=0, session_id=132.

4 ETW000                                                                              73  0.093677

4 ETW000  [dev trc     ,00000]  -->oci_prepare_stmt(con_hdl=0, len=0, stmth_p=0x14905b48)

4 ETW000                                                                              54  0.093731

4 ETW000  [dev trc     ,00000]         ALTER SESSION SET NLS_SORT = BINARY

4 ETW000                                                                              40  0.093771

4 ETW000  [dev trc     ,00000]  -->oci_prepare_stmt(con_hdl=0, len=0, stmth_p=0x14905b48)

4 ETW000                                                                            1303  0.095074

4 ETW000  [dev trc     ,00000]         SELECT USERID, PASSWD FROM SAPUSER WHERE USERID IN (:A0, :A1)

4 ETW000                                                                              45  0.095119

4 ETW000  [dbsloci.    ,00000]  *** ERROR => ORA-1403 when accessing table SAPUSER

4 ETW000                                                                            1519  0.096638

4 ETW000  [dev trc     ,00000]     set_ocica() -> OCI or SQL return code 1403         82  0.096720

4 ETW000  [dev trc     ,00000]  Disconnecting from connection 0 ...                  271  0.096991

4 ETW000  [dev trc     ,00000]  Rolling back transaction ...                          69  0.097060

4 ETW000  [dev trc     ,00000]  Closing user session (con_hdl=0,svchp=0x148f8be8,usrhp=0x148e8dd8)

4 ETW000                                                                             739  0.097799

4 ETW000  [dev trc     ,00000]  Now I'm disconnected from ORACLE                    1796  0.099595

4 ETW000  [dev trc     ,00000]  Try to connect with default password                  32  0.099627

4 ETW000  [dev trc     ,00000]  Connecting as SAPVRQ/<pwd>@VRQ on connection 0 (nls_hdl 0) ... (dbsl 700 151208)

4 ETW000                                                                              44  0.099671

4 ETW000  [dev trc     ,00000]  Nls CharacterSet                 NationalCharSet              C      EnvHp      ErrHp ErrHpBatch

4 ETW000                                                                              77  0.099748

4 ETW000  [dev trc     ,00000]    0 UTF8                                                      0 0x148e0b70 0x148e85c0 0x148f8cb8

4 ETW000                                                                              43  0.099791

4 ETW000  [dev trc     ,00000]  Assigning username to user session: con_hdl=0, usrhp=0x148e8dd8

4 ETW000                                                                              40  0.099831

4 ETW000  [dev trc     ,00000]  Assigning password to user session: con_hdl=0, usrhp=0x148e8dd8

4 ETW000                                                                             106  0.099937

4 ETW000  [dev trc     ,00000]  Starting user session: OCISessionBegin(con_hdl=0, usr=SAPVRQ/<pwd>, svchp=0x148f8be8, srvhp=0x148fbf48, usrhp=0x148e8dd8)

4 ETW000                                                                              78  0.100015

4 ETW000  [dboci.c     ,00000]  *** ERROR => OCI-call 'OCISessionBegin' failed with rc=1017

4 ETW000                                                                           11982  0.111997

4 ETW000  [dbsloci.    ,00000]  *** ERROR => CONNECT failed with sql error '1017'

4 ETW000                                                                              52  0.112049

4 ETW000  [dev trc     ,00000]     set_ocica() -> OCI or SQL return code 1017         28  0.112077

4 ETW000  [dblink      ,00431]  ***LOG BY2=>sql error 1017   performing CON [dblink#3 @ 431]

4 ETW000                                                                             271  0.112348

4 ETW000  [dblink      ,00431]  ***LOG BY0=>ORA-01017: invalid username/password; logon denied [dblink#3 @ 431]

4 ETW000                                                                              66  0.112414

2EETW169 no connect possible: "DBMS = ORACLE                           --- dbs_ora_tnsname = 'VRQ'"

zamdv20187:vrqadm 33>

  • Re: Oracle 11g issue after Unicode Conversion
    Volker Borowski
    Currently Being Moderated
    Bradley Jackson wrote:

     

    > 4 ETW000  [dev trc     ,00000]  Now '/@VRQ' is connected: con_hdl=0, nls_hdl=0, session_id=132.

     

    > 4 ETW000  [dev trc     ,00000]         SELECT USERID, PASSWD FROM SAPUSER WHERE USERID IN (:A0, :A1)

    > 4 ETW000  [dbsloci.    ,00000]  *** ERROR => ORA-1403 when accessing table SAPUSER

     

     

     

    Hi,

     

    this looks as if somehow the OPS$ connect was not installed completely, when you installed the DB part.

    If the DB part was really completed successfully, try to set the password for the schema user (SAPSR3?)

    on the DB server using brtools. This should initialize the SAPUSER table if it is not existing.

     

    Hope this helps

    Volker

    • Re: Oracle 11g issue after Unicode Conversion
      Bradley Jackson
      Currently Being Moderated

      Hi Volker,

       

      I tried your suggestion, and it still did not help.

       

      What is curious is that on the DB server, I can run SQLPLUS and use that system/password and it logs in correctly.

       

      But I still have this issue with the CI.

       

      Any other ideas?

       

      Thanks for the attention.

      • Re: Oracle 11g issue after Unicode Conversion
        Fidel Vales
        Currently Being Moderated

        > What is curious is that on the DB server, I can run SQLPLUS and use that system/password and it logs in correctly.

        good, unfortunately SAP does not connect as system

         

        Lets try to read your log file (difficult task)

        1) connection as ops$ user:

        > Logon as OPS$-user to get SAPVRQ's password

        > Connecting as /@VRQ on connection 0

        ...

        > Now '/@VRQ' is connected:

        so, the connection as ops$ is working

        2) now lets get the password for the user SAPVRQ:

        > SELECT USERID, PASSWD FROM SAPUSER WHERE USERID IN (:A0, :A1)

        > *** ERROR => ORA-1403 when accessing table SAPUSER

        Ohhhhhhh, SAP can't get the password as the table does not have data.

        The rest is easy, it tries with the default password and it fails with ORA-1017

         

        now, you ony have to search for notes with the error ORA-1403 and you get the solution (change the password with brconnect i)

        looking for the exact error using the top corner box I get two nice notes. First one tells you the same I did:

        SAP Note 400241 Problems with ops$ or sapr3 connect to Oracle

         

        > brconnect -u system/<password> -f chpass -o <sapowner> -p <password>

         

        You only needed to

        1) read the error file you posted. With the advantage that it was formatted and would be easier to read

        2) look for notes with the error

         

        those two steps would have taken less than, lets say, 10 minutes

         

        Please, learn how to search for notes. Sometimes you get a faster solution (you only need to work a little)

        • Re: Oracle 11g issue after Unicode Conversion
          Bradley Jackson
          Currently Being Moderated

          Hi Fidel,

           

          I'm sorry for asking these questions, it's been a really long weekend.

           

          I'm assuming we're dealing with section 1b of the note.

           

          Is the "sapowner" referred to in the help SAPVRQ in my case?

           

           

          1b) Log entries:  Logon as OPS$ user to get <sapowner>'s password

                            Connecting as /@<sid> on connection 0 ...

                            Now I'm connected to ORACLE

                            Got <sapowner>'s password from table SAPUSER

                            Disconnecting from connection 0 ...

                            Now I'm disconnected from ORACLE

                            Try to connect with the password I got from OPS$-user

                            Connecting as <sapowner>/<pwd>@<sid> on connection 0

                            *** ERROR => OCI-call 'olog' failed: rc = 1017

                            *** ERROR => CONNECT failed with sql error '1017'

                     If the system issues ORA-01017 at this point, the < sapowner> password in the table SAPUSER is incorrect. In this situation, proceed as follows:

           

              Use the following BRCONNECT call (BRCONNECT 6.10 or higher) to set the password consistently in SAPUSER and in the Oracle DDIC:

           

              brconnect -u system/<password> -f chpass -o <sapowner> -p <password>

           

              Alternatively, change the password in the table SAPUSER:

           

              DELETE FROM "OPS$<sid>ADM".SAPUSER;

              INSERT INTO "OPS$<sid>ADM".SAPUSER VALUES ('<sapowner>', '<password>');

           

              Important: The table SAPUSER must exist only once in each system for OPS$<sid>ADM. For this reason, execute the statements mentioned above for OPS$<sid>ADM (regardless of the operating system user that is actually being used). All other OPS$ users can use a synonym to access the table SAPUSER.

           

              If the connection still terminates in the same way, check the "General checks" section once again.

          • Re: Oracle 11g issue after Unicode Conversion
            Bradley Jackson
            Currently Being Moderated

            Fidel,

             

            Firstly, thanks for the suggestions up to now.

             

            Secondly, I updated the SQL as follows, does it seem correct?

             

            SQL> DELETE FROM "OPS$VRQADM".SAPUSER;

             

            1 row deleted.

             

             

            SQL> INSERT INTO "OPS$VRQADM".SAPUSER VALUES ('SAPVRQ','*********');

             

            1 row created.

             

            SQL>

             

             

            I retried the R3trans, but I get the same error, would it be advisable to restart the database to clear any caching?

             

            Thanks again.

            • Re: Oracle 11g issue after Unicode Conversion
              Bradley Jackson
              Currently Being Moderated

              Hey Fidel,

               

              I made the above changes and restarted the db, same output.

               

              zamds20162:oravrq 72> R3trans -x

              This is R3trans version 6.14 (release 701 - 05.04.11 - 11:45:00).

              unicode enabled version

              2EETW169 no connect possible: "DBMS = ORACLE                           --- dbs_ora_tnsname = 'VRQ'"

              R3trans finished (0012).

              zamds20162:oravrq 73> cat trans.log

              4 ETW000 R3trans version 6.14 (release 701 - 05.04.11 - 11:45:00).

              4 ETW000 unicode enabled version

              4 ETW000 ===============================================

              4 ETW000

              4 ETW000 date&time   : 08.05.2011 - 21:54:44

              4 ETW000 control file: <no ctrlfile>

              4 ETW000 R3trans was called as follows: R3trans -x

              4 ETW000  trace at level 2 opened for a given file pointer

              4 ETW000  [     dev trc,00000]  Sun May  8 21:54:44 2011                                                 152  0.000152

              4 ETW000  [     dev trc,00000]  db_con_init called                                                        38  0.000190

              4 ETW000  [     dev trc,00000]  create_con (con_name=R/3)                                                 69  0.000259

              4 ETW000  [     dev trc,00000]  Loading DB library '/usr/sap/VRQ/SYS/exe/run/dboraslib.so' ...            87  0.000346

              4 ETW000  [     dev trc,00000]  DlLoadLib() success: dlopen("/usr/sap/VRQ/SYS/exe/run/dboraslib.so"), hdl 0

              4 ETW000                                                                                18615  0.018961

              4 ETW000  [     dev trc,00000]  Library '/usr/sap/VRQ/SYS/exe/run/dboraslib.so' loaded                    44  0.019005

              4 ETW000  [     dev trc,00000]  function DbSlExpFuns loaded from library /usr/sap/VRQ/SYS/exe/run/dboraslib.so

              4 ETW000                                                                                75  0.019080

              4 ETW000  [     dev trc,00000]  Version of '/usr/sap/VRQ/SYS/exe/run/dboraslib.so' is "700.08", patchlevel (0.25)

              4 ETW000                                                                                109  0.019189

              4 ETW000  [     dev trc,00000]  function dsql_db_init loaded from library /usr/sap/VRQ/SYS/exe/run/dboraslib.so

              4 ETW000                                                                                44  0.019233

              4 ETW000  [     dev trc,00000]  function dbdd_exp_funs loaded from library /usr/sap/VRQ/SYS/exe/run/dboraslib.so

              4 ETW000                                                                                85  0.019318

              4 ETW000  [     dev trc,00000]  New connection 0 created                                                  46  0.019364

              4 ETW000  [     dev trc,00000]  000: name = R/3, con_id = -000000001, state = DISCONNECTED, tx = NO , hc = NO , perm = YES,

              4 ETW000                             reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

              4 ETW000                                                                                121  0.019485

              4 ETW000  [     dev trc,00000]  db_con_connect (con_name=R/3)                                             54  0.019539

              4 ETW000  [     dev trc,00000]  find_con_by_name found the following connection for reuse:                40  0.019579

              4 ETW000  [     dev trc,00000]  000: name = R/3, con_id = 000000000, state = DISCONNECTED, tx = NO , hc = NO , perm = YES,

              4 ETW000                             reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

              4 ETW000                                                                                77  0.019656

              4 ETW000  [     dev trc,00000]  Oracle Client Version: '11.2.0.1.0'                                      583  0.020239

              4 ETW000  [     dev trc,00000]  -->oci_initialize (con_hdl=0)                                             46  0.020285

              4 ETW000  [     dev trc,00000]  Client character set UTF16 -> UTF8                                     28210  0.048495

              4 ETW000  [     dev trc,00000]  Client NLS setting (OCINlsGetInfo): 'AMERICAN_AMERICA.UTF8'               61  0.048556

              4 ETW000  [     dev trc,00000]  Logon as OPS$-user to get SAPSR3's password                               35  0.048591

              4 ETW000  [     dev trc,00000]  Connecting as /@VRQ on connection 0 (nls_hdl 0) ... (dbsl 700 151208)

              4 ETW000                                                                                56  0.048647

              4 ETW000  [     dev trc,00000]  Nls CharacterSet                 NationalCharSet              C      EnvHp      ErrHp ErrHpBatch

              4 ETW000                                                                                114  0.048761

              4 ETW000  [     dev trc,00000]    0 UTF8                                                      0 0x11eb8910 0x11ec3b78 0x11ec4bf8

              4 ETW000                                                                                56  0.048817

              4 ETW000  [     dev trc,00000]  Allocating service context handle for con_hdl=0                           55  0.048872

              4 ETW000  [     dev trc,00000]  Allocating server context handle                                          41  0.048913

              4 ETW000  [     dev trc,00000]  Attaching to DB Server VRQ (con_hdl=0,svchp=0x11ec3a98,srvhp=0x11ec5d10)

              4 ETW000                                                                                107  0.049020

              4 ETW000  [     dev trc,00000]  Assigning server context 0x11ec5d10 to service context 0x11ec3a98      40079  0.089099

              4 ETW000  [     dev trc,00000]  Allocating user session handle                                            91  0.089190

              4 ETW000  [     dev trc,00000]  Starting user session: OCISessionBegin(con_hdl=0, usr='/',svchp=0x11ec3a98, srvhp=0x11ec5d10, usrhp=0x11ef5450)

              4 ETW000                                                                                68  0.089258

              4 ETW000  [     dev trc,00000]  Assigning user session 0x11ef5450 to service context 0x11ec3a98        17219  0.106477

              4 ETW000  [     dev trc,00000]  -->oci_prepare_stmt(con_hdl=0, len=53, stmth_p=0x11ed7548)               143  0.106620

              4 ETW000  [     dev trc,00000]         BEGIN DBMS_APPLICATION_INFO.SET_MODULE(:A0,:A1); END;

              4 ETW000                                                                                58  0.106678

              4 ETW000  [     dev trc,00000]  CbApplInfoGet() failed! Ignore, but uninstall callback to avoid more erroneous calls

              4 ETW000                                                                                234  0.106912

              4 ETW000  [     dev trc,00000]  -->oci_prepare_stmt(con_hdl=0, len=54, stmth_p=0x11ed85a0)                36  0.106948

              4 ETW000  [     dev trc,00000]         BEGIN DBMS_APPLICATION_INFO.SET_CLIENT_INFO(:A0); END;

              4 ETW000                                                                                51  0.106999

              4 ETW000  [     dev trc,00000]  -->oci_prepare_stmt(con_hdl=0, len=0, stmth_p=0x11ed85a0)               2772  0.109771

              4 ETW000  [     dev trc,00000]         SELECT SID FROM V$MYSTAT WHERE ROWNUM<2

              4 ETW000                                                                                75  0.109846

              4 ETW000  [     dev trc,00000]  Connected to session 22.                                                1690  0.111536

              4 ETW000  [     dev trc,00000]  Now '/@VRQ' is connected: con_hdl=0, nls_hdl=0, session_id=22.            41  0.111577

              4 ETW000  [     dev trc,00000]  -->oci_prepare_stmt(con_hdl=0, len=0, stmth_p=0x11ed85a0)                 34  0.111611

              4 ETW000  [     dev trc,00000]         ALTER SESSION SET NLS_SORT = BINARY

              4 ETW000                                                                                62  0.111673

              4 ETW000  [     dev trc,00000]  -->oci_prepare_stmt(con_hdl=0, len=0, stmth_p=0x11ed85a0)                540  0.112213

              4 ETW000  [     dev trc,00000]         SELECT USERID, PASSWD FROM SAPUSER WHERE USERID IN (:A0, :A1)

              4 ETW000                                                                                60  0.112273

              4 ETW000  [     dev trc,00000]  OCI-call failed with -1=OCI_ERROR                                       2622  0.114895

              4 ETW000  [     dev trc,00000]     SQL error 942: 'ORA-00942: table or view does not exist'               49  0.114944

              4 ETW000  [    dbsloci.,00000]  *** ERROR => ORA-942 when accessing table SAPUSER                        109  0.115053

              4 ETW000  [     dev trc,00000]     set_ocica() -> OCI or SQL return code 942                              43  0.115096

              4 ETW000  [     dev trc,00000]  Disconnecting from connection 0 ...                                      160  0.115256

              4 ETW000  [     dev trc,00000]  Rolling back transaction ...                                              68  0.115324

              4 ETW000  [     dev trc,00000]  Closing user session (con_hdl=0,svchp=0x11ec3a98,usrhp=0x11ef5450)       259  0.115583

              4 ETW000  [     dev trc,00000]  Now I'm disconnected from ORACLE                                        1002  0.116585

              4 ETW000  [     dev trc,00000]  Try to connect with default password                                      39  0.116624

              4 ETW000  [     dev trc,00000]  Connecting as SAPSR3/<pwd>@VRQ on connection 0 (nls_hdl 0) ... (dbsl 700 151208)

              4 ETW000                                                                                52  0.116676

              4 ETW000  [     dev trc,00000]  Nls CharacterSet                 NationalCharSet              C      EnvHp      ErrHp ErrHpBatch

              4 ETW000                                                                                66  0.116742

              4 ETW000  [     dev trc,00000]    0 UTF8                                                      0 0x11eb8910 0x11ec3b78 0x11ec4bf8

              4 ETW000                                                                                47  0.116789

              4 ETW000  [     dev trc,00000]  Assigning username to user session: con_hdl=0, usrhp=0x11ef5450           38  0.116827

              4 ETW000  [     dev trc,00000]  Assigning password to user session: con_hdl=0, usrhp=0x11ef5450           53  0.116880

              4 ETW000  [     dev trc,00000]  Starting user session: OCISessionBegin(con_hdl=0, usr=SAPSR3/<pwd>, svchp=0x11ec3a98, srvhp=0x11ec5d10, usrhp=0x11ef5450)

              4 ETW000                                                                                408  0.117288

              4 ETW000  [    dboci.c ,00000]  *** ERROR => OCI-call 'OCISessionBegin' failed with rc=1017            12699  0.129987

              4 ETW000  [    dbsloci.,00000]  *** ERROR => CONNECT failed with sql error '1017'                         50  0.130037

              4 ETW000  [     dev trc,00000]     set_ocica() -> OCI or SQL return code 1017                             39  0.130076

              4 ETW000  [    dblink  ,00433]  ***LOG BY2=>sql error 1017   performing CON [dblink#4 @ 433]             214  0.130290

              4 ETW000  [    dblink  ,00433]  ***LOG BY0=>ORA-01017: invalid username/password; logon denied [dblink#4 @ 433]

              4 ETW000                                                                                52  0.130342

              2EETW169 no connect possible: "DBMS = ORACLE                           --- dbs_ora_tnsname = 'VRQ'"

              • Re: Oracle 11g issue after Unicode Conversion
                Michael Hofmänner
                Currently Being Moderated

                I often temporary try to set the sap schema user password to SAP as a workaround in these situations. So i can sort out the problem after the migration.

                 

                ALTER USER SAPSR3 IDENTIFIED BY SAP;

                 

                Careful with 11g the password becomes case sensitive.

                 

                Cheers Michael

                 

                (why do you do the conversion on a QAS system over the weekend?)

                • Re: Oracle 11g issue after Unicode Conversion
                  Bradley Jackson
                  Currently Being Moderated

                  Hey Michael,

                   

                  The suggestion you provide is regarding user SAPSR3, but isn't the user it's trying to use SAPVRQ

                   

                  as indicated in this line?

                   

                  Connecting as SAPVRQ/<pwd>@VRQ on connection 0

                   

                  Otherwise, I am completely willing to try the suggestion.

                   

                  Also, will I need to restart the DB to clear the cache, or should the change happen without that need, or should I run a commit after?

                  • Re: Oracle 11g issue after Unicode Conversion
                    Michael Hofmänner
                    Currently Being Moderated

                    Of course if your schema user's name is SAPVRQ you would have to replace SAPSR3.

                     

                    Cheers Michael

                  • Re: Oracle 11g issue after Unicode Conversion
                    Bradley Jackson
                    Currently Being Moderated

                    Hi Michael,

                     

                    Does this make any sense to you?

                     

                    I have tried to change the password for the user SAPVRQ (the one it's trying to connect with) but it says the user doesn't exist.

                     

                    So I then tried to create it, it seemed to succeed, I ran a commit, and then when I tried to test by changing the password again, it says the user STILL doesn't exist. What am I doing wrong?

                     

                    zamds20162:oravrq 57> sqlplus / as sysdba

                     

                    SQL*Plus: Release 11.2.0.1.0 Production on Mon May 9 07:10:42 2011

                     

                    Copyright (c) 1982, 2009, Oracle.  All rights reserved.

                     

                     

                    Connected to:

                    Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production

                    With the Partitioning, OLAP, Data Mining and Real Application Testing options

                     

                    SQL> alter user SAPVRQ identified by SAP;

                    alter user SAPVRQ identified by SAP

                               *

                    ERROR at line 1:

                    ORA-01918: user 'SAPVRQ' does not exist

                     

                     

                    SQL> INSERT INTO "OPS$VRQADM".SAPUSER VALUES ('SAPVRQ','**********');

                     

                    1 row created.

                     

                    SQL> commit;

                     

                    Commit complete.

                     

                    SQL> Disconnected from Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production

                    With the Partitioning, OLAP, Data Mining and Real Application Testing options

                    zamds20162:oravrq 58> sqlplus / as sysdba

                     

                    SQL*Plus: Release 11.2.0.1.0 Production on Mon May 9 07:13:03 2011

                     

                    Copyright (c) 1982, 2009, Oracle.  All rights reserved.

                     

                     

                    Connected to:

                    Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production

                    With the Partitioning, OLAP, Data Mining and Real Application Testing options

                     

                    SQL> alter user SAPVRQ identified by SAP;

                    alter user SAPVRQ identified by SAP

                               *

                    ERROR at line 1:

                    ORA-01918: user 'SAPVRQ' does not exist

                     

                     

                    SQL>

                     

                    Edited by: Bradley Jackson on May 9, 2011 7:15 AM

Actions