8 Replies Latest reply: Nov 13, 2012 4:54 PM by Gerald Fust RSS

Portal 7.02 SP6 on Google Chrome throws error.

Arul Narayan
Currently Being Moderated

Portal 7.02 SP6 on Google Chrome throws error:

"

Could not open iView. The iView is not compatible with your browser, operating system, or device. Contact your system administrator for more information.

"

Is there a fix for this issue. Please advise. Thanks.

  • Re: Portal 7.02 SP6 on Google Chrome throws error.
    Srikishan D
    Currently Being Moderated

    Hi,

     

    SAP Netweaver 7.02 is not supported on Google Chrome Browser.

    You need IE, Mozilla Firefox or Apple Safari.

     

    Check link for browsers supported:

    https://service.sap.com/~sapidb/011000358700001225132009E

     

    Regards,

    Srikishan

  • Re: Portal 7.02 SP6 on Google Chrome throws error.
    Edison Buttenbender
    Currently Being Moderated

    Hello Kris,

    As SAP documentation explain Chrome is not supported for EP version 7.02 SP06. SAP will not provide any fix for that version and once you are interested to know when it will be compatible you can test it applying SP9 using an specific .PAR file as per other similar cases. It may help you to use Chrome in that version. as SP10 was already released and as I could see it is still not valid for chrome that is a good tip in my opinion.

    Hope this helps,

    Edison

  • Re: Portal 7.02 SP6 on Google Chrome throws error.
    Arul Narayan
    Currently Being Moderated

    Thanks guys for your replies. I already know the information in PAM.

     

    We have another Portal running on 7.0 SP20 and it works perfectly fine in Google Chrome.

    It is strange that newer versions will stop working.

     

    Based on latest statistics Google Chrome's usage is increasing as compared to other browsers and SAP should start supporting based on widely used browsers.

     

    http://www.w3schools.com/browsers/browsers_stats.asp

    • Re: Portal 7.02 SP6 on Google Chrome throws error.
      Edison Buttenbender
      Currently Being Moderated

      Hi,

      Ensure you have tested the workaround.

      Even if you still have an specific error scenario please let me know...

      Edison

    • Re: Portal 7.02 SP6 on Google Chrome throws error.
      Olivier CHRETIEN
      Currently Being Moderated

       

      > Based on latest statistics Google Chrome's usage is increasing as compared to other browsers and SAP should start supporting based on widely used browsers.

       

       

      Well, I would say it more strongly:  a portal software should be completely browser neutral.

      How can you a publish a SAP Portal on the internet where you cannot control the browser used ?

      This is a major issue for SAP EP.

       

      Regards,

      Olivier

      • Re: Portal 7.02 SP6 on Google Chrome throws error.
        Tobias Hofmann
        Currently Being Moderated

        To (freely) quote an SAP executive that I asked about browser support:

        "what kind of browsers should SAP support? It does not make sense to support non-enterprise ready browsers".

        I interpret that as: when you spent some serious $$$ for the SAP Portal you should get your infrastructure in line with the corporates ERP vendor strategy == buy Microsoft, use IE 6, 7 or 8

         

        At least FF support is speeding up, even when it's impossible for SAP to keep up with the release cycles of Mozilla (when SAP releases a SPS Mozilla already released 2 new FF versions).

         

        This sorts out effectively Google and Opera (what is Statoil using?) and a bunch of mobile browers (all). Why Safari is considered more enterprise ready than Chrome? My 2ct: Apple is an SAP customer and they paid for getting support.

         

        Guess we'll have to wait for Google start using SAP and the Portal.

         

        br,

        Tobias

  • Re: Portal 7.02 SP6 on Google Chrome throws error.
    Tobias Hofmann
    Currently Being Moderated

    Hi,

     

    every page/iview has a property called: supported user agents. By default you can only select MS IE and Mozilla (depending on SP: Safari too) from a pre-defined list.[1] To get the content working for other browsers you can change the browser identification sent by the browser to the portal or make the portal content accept every browser identification.

     

    In the PCD go to the multiple property replacement wizard and select the content you need to expose to Chrome. Select the replace property option. Select the property "SupportedUserAgents" and insert (,,*) as the value. That should do the trick.

     

    br,

    Tobias

     

    [1] This list allows you to create content than can be accessed by Safari, but not by IE or FF or by IE but not by FF and Safari. Not sure how to deal with content that needs to be exposed to IE and Safari ...

    • Re: Portal 7.02 SP6 on Google Chrome throws error.
      Gerald Fust
      Currently Being Moderated

      Tobias:

       

      If I may ask a follow-on question.  We are on Netweaver 7.02, SP10.

       

      The options for Supported User Agent are:

      • MSIE, Netscape, Mozilla, Safari
      • MSIE
      • Netscape, Mozilla
      • Safari

       

      The options for Unsupported User Agents are:

      • MSIE
      • Netscape, Mozilla

       

      I don't see in here any combination that allows IE and Mozilla, but prevents Safari.  Since the SAP Learning Solution BSP is not supported in Safari, it would be good to indicate that the iView.  Am I missing something?  How would a portal administrator allow IE and Mozilla, but exclude Safari?

       

      Thank you,

      Jerry

Actions