14 Replies Latest reply: Dec 14, 2011 10:28 AM by Vincent Lim RSS

"connect failed with DBLI_RC_LOAD_LIB_FAILED."

Bharathi S
Currently Being Moderated

Hi,

 

During Upgrade from R/3 4.6c to ECC6.0 EHP4, we stuck up with this error in the phase '5.Preprocessing'

 

 

 

                                                                                                    • ******* LIST OF ERRORS AND RETURN CODES ******* ************************************************** ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ SHADOW IMPORT ERRORS and RETURN CODE in SAPKLDESR1EHP4ERP6X0.DV1 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 2EETW169 no connect possible: "connect failed with DBLI_RC_LOAD_LIB_FAILED." Long text: Cause R3trans cannot logon to the database. System Response The program is cancelled. What to do In the R3trans log you will find an SQL error number, which gives you the cause of the error. Environment variables not set (or incorrectly set) are the most frequent reason for the error (TWO_TASK or ORACLE_SID/ORACLE_HOME). 1 ETP111 exit code : "12" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ SHADOW IMPORT ERRORS and RETURN CODE in SAPKLDESR1EHP4ERP6X1.DV1 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 2EETW169 no connect possible: "connect failed with DBLI_RC_LOAD_LIB_FAILED." Long text: see above 1 ETP111 exit code : "12"

 

 

cmd: 'r3trans -d' shows,

This is r3trans version 6.05 (release 46D - 09.04.09 - 12:39:00).

r3trans finished (0000).

 

Kindly help us to resolve this issue.

 

Regards,

Bharathi.

  • Re: "connect failed with DBLI_RC_LOAD_LIB_FAILED."
    Orkun Gedik
    Currently Being Moderated

    Hi,

     

    Check "dbms_type" environment variable has been set.

     

    Additionally, you can check the note 556232 - Environment settings for R/3/Oracle on Windows

     

    Best regards,

     

    Orkun Gedik

     

    Edited by: Orkun Gedik on Dec 12, 2011 4:34 PM

  • Re: "connect failed with DBLI_RC_LOAD_LIB_FAILED."
    Currently Being Moderated

    also check the environment varialbles ORACLE_SID and ORACLE_HOME as per your log.

  • Re: "connect failed with DBLI_RC_LOAD_LIB_FAILED."
    Vincent Lim
    Currently Being Moderated

    check your env and path setting, and make sure it could locate dboraslib.dll  module (Assuming you're running windows).

    If missing dboraslib.dll, get a copy and extracted from lib_dbsl_xxx.CAR

     

    Regards,

    Vincent

    • Re: "connect failed with DBLI_RC_LOAD_LIB_FAILED."
      Bharathi S
      Currently Being Moderated

      Dear Vincent,

       

      Thanks for the update.

       

      As per the SAP Note: 556232 we check all env and path setting, It seems to be fine.

      And 'dboraslib.dll' file is located in the following path,

      1. I:\usr\sap\trans\eps\in

      2. I:\usr\sap\<SID>\sys\exe\run

      3. I:\usr\sap\<SID>\upg\abap\exe

      4. I:\usr\sap\<SID>\upg\abap\exenew

      5. I:\usr\sap\<SID>\upg\abap\tools

      6. I:\usr\sap\<SID>\sys\exe\NUC\NTIA64

       

      Please suggest how to proceed now.

       

      OS: Windows 2003

      DB: Oracle 10g

       

      Regards,

      Bharathi

       

      Edited by: BharathiSMB on Dec 13, 2011 6:02 AM

      • Re: "connect failed with DBLI_RC_LOAD_LIB_FAILED."
        Deepak Kori
        Currently Being Moderated

        Hi Bharathi,

         

        Is your shadow instance up and running ?

        Share the logs of R3trans -d ?

         

        Regards,

        Deepak Kori

      • Re: "connect failed with DBLI_RC_LOAD_LIB_FAILED."
        Vincent Lim
        Currently Being Moderated

        I think the error itself quite misleading......it said  "R3trans log you will find an SQL error number", did you see any ORA error in trans.log ?

        Do you know exactly which phase in preprocessing ? they are many upgrade phases in preprocessing. 

        For example, in phase SHADOW_IMPORT_INC , the shadow instance is supposed to be down. I think you need to check upgrade log as well.

         

        If you shadow instance is suppose to be up, but dying, check dev_disp, dev_w0 for error first.

         

        Regards,

        Vincent

        • Re: "connect failed with DBLI_RC_LOAD_LIB_FAILED."
          Bharathi S
          Currently Being Moderated

          Dear Vincent,

           

          Thanks for the update.

           

          Here is my last finding on our system during upgrade.

           

          R3trans from UPG folder:

          I:\usr\sap\DV1\upg\abap\exenew>R3trans.exe -d

          This is R3trans.exe version 6.14 (release 701 - 03.06.11 - 17:57:00).

          unicode enabled version

          2EETW169 no connect possible: "connect failed with DBLI_RC_LOAD_LIB_FAILED."

          R3trans.exe finished (0012).

           

          R3trans from Source System (4.6c):

          C:\Documents and Settings\dv1adm>r3trans -d

          This is r3trans version 6.05 (release 46D - 09.04.09 - 12:39:00).

          r3trans finished (0000).

           

          SAPup.ECO LOG:

              1. Phase SHADOW_IMPORT_UPG1:

          Deleting file I:\usr\sap\DV1\upg\abap\log\PHASES.LOG

          SAPup> Starting subprocess tp.exe with id 1060 at 20111213172655

           

          EXECUTING I:\usr\sap\DV1\upg\abap\exenew\tp.exe pf=I:\usr\sap\DV1\upg\abap\bin\SHDUPGIMP1.TPP put DV1

          Environment: JAVA_HOME=C:\j2sdk1.4.2_32-x64\bin

          Environment: NLS_LANG=AMERICAN_AMERICA.WE8DEC

          Environment: ORACLE_HOME=H:\oracle\DV1\102

          Environment: ORACLE_SID=DV1

          Environment: PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH

          Environment: Path=H:\oracle\DV1\102\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program Files\The Open Group\WMI Mapper\bin;C:\Program Files\Hewlett-Packard\nParCommands\;C:\WINDOWS\syswow64;C:\j2sdk1.4.2_32-x64\bin;;I:\usr\sap\DV1\sys\exe\run;H:\oracle\DV1\102\bin

          Environment: auth_shadow_upgrade=0

          Environment: dbs_ora_schema=SAPR3

          Environment: dbs_ora_tnsname=DV1

          This is I:\usr\sap\DV1\upg\abap\exenew\tp.exe version 372.04.40 (release 701)

          This is I:\usr\sap\DV1\upg\abap\exenew\R3trans.exe version 6.14 (release 701 - 03.06.11 - 17:57:00).

          unicode enabled version

          2EETW169 no connect possible: "connect failed with DBLI_RC_LOAD_LIB_FAILED."

          This is I:\usr\sap\DV1\upg\abap\exenew\R3trans.exe version 6.14 (release 701 - 03.06.11 - 17:57:00).

          unicode enabled version

          2EETW169 no connect possible: "connect failed with DBLI_RC_LOAD_LIB_FAILED."

          I:\usr\sap\DV1\upg\abap\exenew\R3trans.exe finished (0012).

          I:\usr\sap\DV1\upg\abap\exenew\R3trans.exe finished (0012).

          Warning: Parameter INTERRUPT is no longer used.

          Warning: Parameter DAYLIGHT_SHUTDOWN is no longer used.

          Warning: Parameter WITH_TACOB is no longer used.

          Warning: Parameter IMPDP_BY_EVENT is no longer used.

          Warning: Parameter INTERRUPT is no longer used.

          Warning: Parameter DAYLIGHT_SHUTDOWN is no longer used.

          Warning: Parameter WITH_TACOB is no longer used.

          Warning: Parameter IMPDP_BY_EVENT is no longer used.

          Warning: Parameter DBCONFPATH is no longer used.

          stopping on error 12 during SHADOW IMPORT

           

          tp returncode summary:

           

          TOOLS: Highest return code of single steps was: 12

          WARNS: Highest tp internal warning was: 0118

          tp finished with return code: 12

          meaning:

            A tool used by tp aborted

          sapparam: sapargv( argc, argv) has not been called.

          sapparam(1c): No Profile used.

          sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline

          ERROR: stopping on error 12 during SHADOW IMPORT

          Process with ID 18012 terminated with status 12

          Deleting file I:\usr\sap\DV1\upg\abap\log\SHDUPGIMP1.ELG

          Moving file I:\usr\sap\DV1\upg\abap\log\PROT.TMP to I:\usr\sap\DV1\upg\abap\log\SAPKLDESR1EHP4ERP6X0.DV1

          Moving file I:\usr\sap\DV1\upg\abap\log\PROT.TMP to I:\usr\sap\DV1\upg\abap\log\SAPKLDESR1EHP4ERP6X1.DV1

          Moving file I:\usr\sap\DV1\upg\abap\log\SHDUPGIMP1.ELG to I:\usr\sap\DV1\upg\abap\tmp\SHDUPGIMP1.ELG

          Deleting file I:\usr\sap\DV1\upg\abap\tmp\MSGIN.LST

          Deleting file I:\usr\sap\DV1\upg\abap\tmp\MSGOUT.LST

          Deleting file I:\usr\sap\DV1\upg\abap\tmp\MSGOUT.LOG

          Deleting file I:\usr\sap\DV1\upg\abap\tmp\SHDUPGIMP1.ELG

          Deleting file I:\usr\sap\DV1\upg\abap\log\TP.ECO

           

          Please suggest us.

           

          Regards,

          Bharathi

           

          Edited by: BharathiSMB on Dec 14, 2011 7:05 AM

          • Re: "connect failed with DBLI_RC_LOAD_LIB_FAILED."
            Orkun Gedik
            Currently Being Moderated

            Hi,

             

            Copy dboraslib.dll into I:\usr\sap\DV1\upg\abap\exenew and try to execute "R3trans -d"

             

            Best regards,

             

            Orkun Gedik

            • Re: "connect failed with DBLI_RC_LOAD_LIB_FAILED."
              Bharathi S
              Currently Being Moderated

              Dear Vincent/Orkun Gedik

               

               

              Thanks for the update.

               

               

              I replaced latest dboraslib.dll in the path,

              1. I:\usr\sap\DV1\upg\abap\exenew

              2. I:\usr\sap\DV1\upg\abap\exe

               

               

              And tried to execute the command 'R3trans -d' it shows,

              I:\usr\sap\DV1\upg\abap\exenew>r3trans.exe -d

              This is r3trans.exe version 6.14 (release 701 - 03.06.11 - 17:57:00).

              unicode enabled version

              2EETW169 no connect possible: "DBMS = ORACLE

              --- dbs_ora_tnsname = 'DV1'"

              r3trans.exe finished (0012).

               

               

              Trans log:

              4 ETW000 r3trans.exe version 6.14 (release 701 - 03.06.11 - 17:57:00).

              4 ETW000 unicode enabled version

              4 ETW000 ===============================================

              4 ETW000

              4 ETW000 date&time   : 14.12.2011 - 13:41:26

              4 ETW000 control file: <no ctrlfile>

              4 ETW000 R3trans was called as follows: r3trans.exe -d

              4 ETW000  trace at level 2 opened for a given file pointer

              4 ETW000  [     dev trc,00000]  Wed Dec 14 13:41:28 2011                                                   0  0.000000

              4 ETW000  [     dev trc,00000]  db_con_init called                                                         0  0.000000

              4 ETW000  [     dev trc,00000]  create_con (con_name=R/3)                                                  0  0.000000

              4 ETW000  [     dev trc,00000]  Loading DB library 'dboraslib.dll' ...                                     0  0.000000

              4 ETW000  [     dev trc,00000]  DlLoadLib success: LoadLibrary("dboraslib.dll"), hdl 0, addr 0000000187950000

              4 ETW000                                                                                2216  0.002216

              4 ETW000  [     dev trc,00000]      using "I:\usr\sap\DV1\upg\abap\exenew\dboraslib.dll"                  31  0.002247

              4 ETW000  [     dev trc,00000]  Library 'dboraslib.dll' loaded                                            33  0.002280

              4 ETW000  [     dev trc,00000]  function DbSlExpFuns loaded from library dboraslib.dll                    39  0.002319

              4 ETW000  [     dev trc,00000]  Version of 'dboraslib.dll' is "700.08", patchlevel (0.148)               179  0.002498

              4 ETW000  [     dev trc,00000]  function dsql_db_init loaded from library dboraslib.dll                   35  0.002533

              4 ETW000  [     dev trc,00000]  function dbdd_exp_funs loaded from library dboraslib.dll                  44  0.002577

              4 ETW000  [     dev trc,00000]  New connection 0 created                                                  44  0.002621

              4 ETW000  [     dev trc,00000]  000: name = R/3, con_id = -000000001, state = DISCONNECTED, tx = NO , hc = NO , perm = YES,

              4 ETW000                             reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

              4 ETW000                                                                                92  0.002713

              4 ETW000  [     dev trc,00000]  db_con_connect (con_name=R/3)                                             38  0.002751

              4 ETW000  [     dev trc,00000]  find_con_by_name found the following connection for reuse:                32  0.002783

              4 ETW000  [     dev trc,00000]  000: name = R/3, con_id = 000000000, state = DISCONNECTED, tx = NO , hc = NO , perm = YES,

              4 ETW000                             reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

              4 ETW000                                                                                82  0.002865

              4 ETW000  [     dev trc,00000]  CLIENT_ORACLE_HOME is not set as environment variable or                 263  0.003128

              4 ETW000                        DIR_CLIENT_ORAHOME is not set as profile parameter.

              4 ETW000                          assuming using instant client with unspecified location.

              4 ETW000  [     dev trc,00000]  -->oci_init1                                                              83  0.003211

              4 ETW000  [     dev trc,00000]  Oracle Client Version: '10.2.0.2.0', (dbsl 701 170611, UNICODE[2])     13919  0.017130

              4 ETW000  [     dev trc,00000]    Default connection: tnsname ='DV1'                                      53  0.017183

              4 ETW000  [     dev trc,00000]  -->oci_initialize(con=0, char='UTF16', nchar='AL16UTF16', uc_ln=2)        49  0.017232

              4 ETW000  [     dev trc,00000]  Application info callback registered.                                     36  0.017268

              4 ETW000  [     dev trc,00000]  OCIEnvCreate(mode=16384=OCI_UTF16) returned 0 (for default NLS handle)

              4 ETW000                                                                                3807  0.021075

              4 ETW000  [     dev trc,00000]     OCIHandleAlloc(OCI_HTYPE_ERROR, con_hdl=0, ErrHp=000000000A093D80)

              4 ETW000                                                                                162  0.021237

              4 ETW000  [     dev trc,00000]     OCIHandleAlloc(OCI_HTYPE_ERROR, con_hdl=0, ErrBt=000000000A095548)

              4 ETW000                                                                                59  0.021296

              4 ETW000  [     dev trc,00000]  NLS env.: lang=41004D00450052004900430041004E00                          198  0.021494

              4 ETW000  [     dev trc,00000]            terr=41004D0045005200490043004100                               43  0.021537

              4 ETW000  [     dev trc,00000]            char=55005400460031003600                                       37  0.021574

              4 ETW000  [     dev trc,00000]  Client NLS setting (by OCINlsGetInfo): con=0, 'AMERICAN_AMERICA.UTF16'

              4 ETW000                                                                                51  0.021625

              4 ETW000  [     dev trc,00000]  charset='UTF16', ncharset='AL16UTF16', UNI_ASC=FALSE                      36  0.021661

              4 ETW000  [     dev trc,00000]  Logon as OPS$-user to get SAPR3's password                                55  0.021716

              4 ETW000  [     dev trc,00000]  Connecting as /@DV1 on connection 0 (nls 0) ... (dbsl 701 170611, UNICODE[2])

              4 ETW000                                                                                55  0.021771

              4 ETW000  [     dev trc,00000]  Allocating service context handle for con_hdl=0                           48  0.021819

              4 ETW000  [     dev trc,00000]  Allocating server context handle                                          41  0.021860

              4 ETW000  [     dev trc,00000]  Attaching to DB Server DV1 (con_hdl=0,svchp=000000000A095408,srvhp=000000000A095C88)

              4 ETW000                                                                                77  0.021937

              4 ETW000  [     dev trc,00000]  Assigning server context 000000000A095C88 to service context 000000000A095408

              4 ETW000                                                                                34044  0.055981

              4 ETW000  [     dev trc,00000]  Allocating user session handle                                            76  0.056057

              4 ETW000  [     dev trc,00000]  Starting user session: OCISessionBegin(con_hdl=0, usr='/',svchp=000000000A095408, srvhp=000000000A095C88, usrhp=000000000A094598)

              4 ETW000                                                                                92  0.056149

              4 ETW000  [     dev trc,00000]  Assigning user session 000000000A094598 to service context 000000000A095408

              4 ETW000                                                                                53146  0.109295

              4 ETW000  [     dev trc,00000]  -->oci_prepare_stmt(con_hdl=0, len=52, stmth_p=000000000A09F4B8)          86  0.109381

              4 ETW000  [     dev trc,00000]         BEGIN DBMS_APPLICATION_INFO.SET_MODULE(:A0,:A1);END;                                                                     

              4 ETW000                                                                                60  0.109441

              4 ETW000  [     dev trc,00000]  -  oci_bind   ( 0: SQLT_STR, l=600, con_hdl=0, stmth_p=000000000A09F4B8, vp=0000000187D4AA50,ip=0000000187AC5200,rlp=0000000000000000,rcp=0000000000000000)

              4 ETW000                                                                                168  0.109609

              4 ETW000  [     dev trc,00000]  -  oci_bind   ( 1: SQLT_STR, l=600, con_hdl=0, stmth_p=000000000A09F4B8, vp=0000000187D4CCF0,ip=0000000187AC5202,rlp=0000000000000000,rcp=0000000000000000)

              4 ETW000                                                                                100  0.109709

              4 ETW000  [     dev trc,00000]     CbApplInfoGet() failed (ignored 1).                                    43  0.109752

              4 ETW000  [     dev trc,00000]  -->oci_prepare_stmt(con_hdl=0, len=54, stmth_p=000000000A0A0510)          40  0.109792

              4 ETW000  [     dev trc,00000]         BEGIN DBMS_APPLICATION_INFO.SET_CLIENT_INFO(:A0); END;                                                                   

              4 ETW000                                                                                71  0.109863

              4 ETW000  [     dev trc,00000]  -  oci_bind   ( 0: SQLT_STR, l= 40, con_hdl=0, stmth_p=000000000A0A0510, vp=0000000187D48580,ip=0000000000000000,rlp=0000000000000000,rcp=0000000000000000)

              4 ETW000                                                                                89  0.109952

              4 ETW000  [     dev trc,00000]  -->oci_execute_stmt(con_hdl=0, stmth_p=000000000A0A0510, iters=1, rowoff=0, dml_batch_errors=0)

              4 ETW000                                                                                79  0.110031

              4 ETW000  [     dev trc,00000]  <--oci_execute_stmt(rc=0, iters-errors = 1-0) [time 0,000s]              696  0.110727

              4 ETW000  [     dev trc,00000]  -->oci_prepare_stmt(con_hdl=0, len=0, stmth_p=000000000A0A0510)           61  0.110788

              4 ETW000  [     dev trc,00000]         SELECT SID FROM V$MYSTAT WHERE ROWNUM<2                                                                               

              4 ETW000                                                                                59  0.110847

              4 ETW000  [     dev trc,00000]  -->oci_define ( 0: SQLT_INT, l=  4, con_hdl=0, stmth_p=000000000A0A0510, vp=000000000202F5B4,ip=000000000202F5B0,rlp=0000000000000000,rcp=0000000000000000)

              4 ETW000                                                                                92  0.110939

              4 ETW000  [     dev trc,00000]  -->oci_execute_stmt(con_hdl=0, stmth_p=000000000A0A0510, iters=1, rowoff=0, dml_batch_errors=0)

              4 ETW000                                                                                77  0.111016

              4 ETW000  [     dev trc,00000]  <--oci_execute_stmt(rc=0, iters-errors = 1-0) [time 0,000s]              463  0.111479

              4 ETW000  [     dev trc,00000]  Now '/@DV1' is connected: con_hdl=0, nls_hdl=0, session_id=38.            45  0.111524

              4 ETW000  [     dev trc,00000]  -->oci_prepare_stmt(con_hdl=0, len=0, stmth_p=000000000A0A0510)           46  0.111570

              4 ETW000  [     dev trc,00000]         ALTER SESSION SET NLS_SORT = BINARY                                                                               

              4 ETW000                                                                                59  0.111629

              4 ETW000  [     dev trc,00000]  -->oci_execute_stmt(con_hdl=0, stmth_p=000000000A0A0510, iters=1, rowoff=0, dml_batch_errors=0)

              4 ETW000                                                                                67  0.111696

              4 ETW000  [     dev trc,00000]  <--oci_execute_stmt(rc=0, iters-errors = 1-0) [time 0,000s]              356  0.112052

              4 ETW000  [     dev trc,00000]  -->oci_prepare_stmt(con_hdl=0, len=0, stmth_p=000000000A0A0510)           55  0.112107

              4 ETW000  [     dev trc,00000]         SELECT USERID,PASSWD FROM SAPUSER WHERE USERID IN (:A0,:A1)                                                              

              4 ETW000                                                                                60  0.112167

              4 ETW000  [     dev trc,00000]  -  oci_bind   ( 0: SQLT_STR, l=256, con_hdl=0, stmth_p=000000000A0A0510, vp=0000000187DDBCB0,ip=0000000000000000,rlp=0000000000000000,rcp=0000000000000000)

              4 ETW000                                                                                95  0.112262

              4 ETW000  [     dev trc,00000]  -  oci_bind   ( 1: SQLT_STR, l=256, con_hdl=0, stmth_p=000000000A0A0510, vp=000000000202F250,ip=0000000000000000,rlp=0000000000000000,rcp=0000000000000000)

              4 ETW000                                                                                74  0.112336

              4 ETW000  [     dev trc,00000]  -->oci_define ( 0: SQLT_STR, l=512, con_hdl=0, stmth_p=000000000A0A0510, vp=000000000202F650,ip=000000000202F014,rlp=0000000000000000,rcp=0000000000000000)

              4 ETW000                                                                                74  0.112410

              4 ETW000  [     dev trc,00000]  -->oci_define ( 1: SQLT_AFC, l=512, con_hdl=0, stmth_p=000000000A0A0510, vp=000000000202F450,ip=000000000202F016,rlp=0000000000000000,rcp=0000000000000000)

              4 ETW000                                                                                75  0.112485

              4 ETW000  [     dev trc,00000]  -->oci_execute_stmt(con_hdl=0, stmth_p=000000000A0A0510, iters=1, rowoff=0, dml_batch_errors=0)

              4 ETW000                                                                                59  0.112544

              4 ETW000  [     dev trc,00000]  <--oci_execute_stmt(rc=0, iters-errors = 1-0) [time 0,000s]              392  0.112936

              4 ETW000  [    dbsloci.,00000]  *** ERROR => Cannot decrypt password I got from table SAPUSER: rc = 16

              4 ETW000                                                                                141  0.113077

              4 ETW000  [     dev trc,00000]  Disconnecting from connection 0 ...                                       38  0.113115

              4 ETW000  [     dev trc,00000]  Rolling back transaction ...                                              67  0.113182

              4 ETW000  [     dev trc,00000]  Closing user session (con_hdl=0,svchp=000000000A095408,usrhp=000000000A094598)

              4 ETW000                                                                                232  0.113414

              4 ETW000  [     dev trc,00000]  Disconnected (con=0) from ORACLE.                                        605  0.114019

              4 ETW000  [     dev trc,00000]  SAPUSER or connect error 18=DBSL_ERR_CONNECT, oerr=0.                     39  0.114058

              2EETW169 no connect possible: "DBMS = ORACLE                           --- dbs_ora_tnsname = 'DV1'"

               

               

              Please help us.

               

              Regards,

              Bharathi

               

              Edited by: BharathiSMB on Dec 14, 2011 10:04 AM

              • Re: "connect failed with DBLI_RC_LOAD_LIB_FAILED."
                Vincent Lim
                Currently Being Moderated

                Now I see this error:

                 

                4 ETW000  [     dev trc,00000]  Oracle Client Version: '10.2.0.2.0', (dbsl 701 170611, UNICODE[2])     13919  0.017130
                4 ETW000  [     dev trc,00000]    Default connection: tnsname ='DV1'                                      53  0.017183
                4 ETW000  [     dev trc,00000]  -->oci_initialize(con=0, char='UTF16', nchar='AL16UTF16', uc_ln=2)        49  0.017232
                4 ETW000  [     dev trc,00000]  Application info callback registered.                                     36  0.017268
                4 ETW000  [     dev trc,00000]  (-) OCIEnvCreate(mode=16384=OCI_UTF16) returned 0 (for default NLS handle

                )

                 

                *** ERROR => Cannot decrypt password I got from table SAPUSER: rc = 16

                 

                 

                I believe oracle client 10.2.0.2 is not supported, please refer to

                SAP note 819829, apply latest instant client and retry.

                 

                and also this could be unicode or non-unicode kernel issue. Please check if you using correct kernel

                 

                 

                Regards,

                Vincent

          • Re: "connect failed with DBLI_RC_LOAD_LIB_FAILED."
            Vincent Lim
            Currently Being Moderated

            Your R3trans output from I:\usr\sap\DV1\upg\abap\exenew, indicates either couldn't locate the correct dboraslib.dll or even if dboraslib.dll exists in correct path, it could have incompatibility issue.

             

            This dll is mainly used to load oracle client.

             

            Regards,

            Vincent

Actions