11 Replies Latest reply: Apr 24, 2012 3:21 PM by Rakesh MV RSS

Decimal Formatting in Adobe forms

Rakesh MV
Currently Being Moderated

Hello All,

I have a requirement to design invoice adobe form, in which I have fields such as  amount and quantity.   For English customers, it is behaving correctly.  But unfortunately it is behaving strangely for French Customers and that too for French Customers with Company code language french.    Please let me know, how to solve this problem.

It is showing in below format

123,45 for 123.45

1,23 for 1.23

1 234,45 for 1,234.45

It is taking commas for decimal and a blank space for commas

Thanks,

Rakesh

  • Re: Decimal Formatting in Adobe forms
    Tao Lin
    Currently Being Moderated

    Hi Rakesh,

     

    go to layout and find the amount fields. Check tab "Object"-"Field"-"Patterns..." and set the number type for the fields.

     

    Best regards,

     

    Tao

    • Re: Decimal Formatting in Adobe forms
      Rakesh MV
      Currently Being Moderated

      Hi Tao,

       

      I have checked fields.  But my problem for only some type of customers.  For English Customers it is working fine.  For French Customers it is giving me problem.  Could you suggest me any other option

       

      Thanks,

      Rakesh

      • Re: Decimal Formatting in Adobe forms
        Tao Lin
        Currently Being Moderated

        Hi Rakesh,

         

        if you set number type manually (as I suggested above), the output type is the same for all customers. If you let it (by default) choose display type automatically, then it depends on the country-setting (instead of language) of the print program.

         

        My suggestion is to set the set number type manually, so that you do not need to change the print program.

         

        Best regards.

        Tao

  • Re: Decimal Formatting in Adobe forms
    Nitin Kumar
    Currently Being Moderated

    Hi Rakesh,

     

    The display of the numbers as 1 234,45 or 1,234.45 in ur case is because of the details stored in the USER DATA.

     

    Once logged in SAP go to: SYSTEM: USER PROFILE: OWN DATA ---- Now in this select the 'DEFAULTS'. Check the 'DECIMAL NOTATION'. Change that to the required format and then re-login and then test.

     

    But this change needs to be done for each individually.

    Instead as said by TAO, give the desired PATTERN in the PALETTES: OBJECT: FIELD:-PATTERN.
    Then this pattern will appear for all the logons.

    Cheers

    • Re: Decimal Formatting in Adobe forms
      Rakesh MV
      Currently Being Moderated

      Hello Nitin,

       

      I have checked the user profile and the decimal notation over there is correct.  I have placed the correct patterns in the object-> Field-> Pattern.  But the problem is not yet solved.  Problem is only for some customers.  For French Customers and whose company code language is French.  For remaining customers, it is working good.

       

      Thanks,

      Rakesh

Actions