14 Replies Latest reply: Oct 28, 2013 7:19 PM by Ludek Uher RSS

Why am I unable to install Crystal Reports 2011?

Johnathan Adams
Currently Being Moderated

I am using a windows 7 64-bit machine.  I am trying to install Crystal Reports 2011 from SAP's downloads.  The file downloads fine and it extracts correctly, but I can't seem to install it.  When I open the extracted folder and go to the setup.exe file, I double click it and it prompts me for admin rights. I click okay to give admin privileges to the application.  This user has admin rights on this machine I know that for sure. 

 

However the program will do nothing after that.  The windows 7 spinning circle comes up for about a second or two then nothing.  I have tried disabling my antivirus to do the install with no luck.  Does anyone have any ideas I could try to get this working?  Could it be conflicting somehow that I'm using a 64-bit machine?

  • Re: Why am I unable to install Crystal Reports 2011?
    Abhilash Kumar
    Currently Being Moderated

    Hi Johnathan,

     

    Make sure the installer is on the Local drive.

     

    Could you try logging in as a Local Admin and then see if the installation works?

     

    Also, did you try installing the product on another machine?

     

    -Abhilash

    • Re: Why am I unable to install Crystal Reports 2011?
      Johnathan Adams
      Currently Being Moderated

      Thank you for the response Abhilash,

       

      The install file is located on the users C drive.  The user logging in is a local admin.  Also I tried installing the software on another machine we have and it seems to start the install just fine.  If an older version of crystal reports was on the machine in the past could that be affecting it?

    • Re: Why am I unable to install Crystal Reports 2011?
      Ribu Rajan
      Currently Being Moderated

      I have same issue with SAP Crystal Report 11(Report Viewer version 14),

      Am getting this error in both 32 bit and 64 bit OS

       

      ************** Exception Text **************

      System.Runtime.InteropServices.COMException (0x80040154):

      Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))

         at System.Windows.Forms.UnsafeNativeMethods.CoCreateInstance(Guid& clsid, Object punkOuter, Int32 context, Guid& iid)

         at System.Windows.Forms.AxHost.CreateWithLicense(String license, Guid clsid)

         at System.Windows.Forms.AxHost.CreateInstanceCore(Guid clsid)

         at System.Windows.Forms.AxHost.CreateInstance()

         at System.Windows.Forms.AxHost.GetOcxCreate()

         at System.Windows.Forms.AxHost.TransitionUpTo(Int32 state)

         at System.Windows.Forms.AxHost.CreateHandle()

         at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)

         at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)

         at System.Windows.Forms.Control.CreateControl()

         at System.Windows.Forms.Control.WmShowWindow(Message& m)

         at System.Windows.Forms.Control.WndProc(Message& m)

         at System.Windows.Forms.ScrollableControl.WndProc(Message& m)

         at System.Windows.Forms.ContainerControl.WndProc(Message& m)

         at System.Windows.Forms.Form.WmShowWindow(Message& m)

         at System.Windows.Forms.Form.WndProc(Message& m)

         at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)

         at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

         at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

       

       

      I installed all the available run times and other supporting setups..  but still having the same issue.

       

      Please let me find a solution....

      waiting for you guys reply...

       

      Thanks

      ribu

  • Re: Why am I unable to install Crystal Reports 2011?
    Shahnawaz Sayyed
    Currently Being Moderated

    Hi Johnathan,

     

    1. Did you have any CR version previous to CR 2011 on the same machine.?

    2. Run windows clean up utility to remove if any CR components still exist on the same machine which are not been removed or have been installed partially

     

     

    Please verify if following steps were adopted or not:

     

    - Do not run the installation from archived package, extract the package first. 

    - Copy the installation package to hard drive if possible to avoid any networking issues.

    - Login to the machine as Local ADMINISTRATOR, if possible.

    - Temporary disable any kind of firewall, antivirus, network security etc., if possible. Please note CR 2011 installation requires open port 4520 for communication. Blocked port 4520 may cause the following error:

    Microsoft Visual C++ Runtime Library

    Runtime Error!

    - On the latest versions of Windows, even if logged in As local Administrator, right-click setup.exe file and select "Run as Administrator".  If you do not have Administrator account, try right click "Run as" Select current user and uncheck the "Protect my computer and data from unauthorized program activity".

    7. Make sure there is enough space on the computer. If not sure about the space, run "Custom" installation with minimum components. Non-mandatory components could be added at any time.

    - Copy and paste the license key, or type it in Capital case.

    - If there are some previous failed BI 4.0 product installations try to rename the C:\Program Files (x86)\SAP BusinessObjects\InstallData folder to "InstallDataOLD

     

    - Shahnawaz

  • Re: Why am I unable to install Crystal Reports 2011?
    Jane Macintyre
    Currently Being Moderated

    Hi Jonathan

     

    Did you get this resolved? I am having the same problem with the CR download.

     

    thanks

    Jane

    • Re: Why am I unable to install Crystal Reports 2011?
      Johnathan Adams
      Currently Being Moderated

      I never got a solution to this error, I've just been using a different PC.  I would like to get a resolution however if you find anything let me know.  My guess is that it has something to do with the fact I had an older version of CR on the machine.

       

      I've done literally thousands of installs of other software and I have tried everything I can think of.  Just about given up on this though.  I was thinking that I might have to reinstall windows to get it to work, but I would hate to do that on this user's machine.

      • Re: Why am I unable to install Crystal Reports 2011?
        Don Williams
        Currently Being Moderated

        Hi All,

         

        There can be multiple reasons why the install fails:

         

        ABOVE ALL, CLOSE EVERY PROGRAM BEFORE INSTALLING

         

        1st, make sure you have FULL Admin rights, CR needs to update the registry as well as register ActiveX/COM dll's. Check with your lcoal Network and PC Admin group in IT, if you have one, and verify your lcoal Profile has not been altered, you may think you have admin rights but they can push out limitations without you know it.

        2nd, MS VS 2005 C++ Security update is required, download it from MS

        3rd, Microsofts 2.0 and 3.5 Framework must also be installed before you run the installer.

        4th, Since CR 9 and above we are fully side by side compatible with other versions, 8.5 and previous are not side by side so, they creates a folder located in c:\windows\Crystal. If that folder exists then DO NOT try to install CR 9 or above. If it exists and you no longer require CR 8.5 or earlier then delete the folder and look for crpe32.dll in the \windows\system32 folder and delete it. Bunch of other stuff needs to be removed so you'll have play, those uninstalls were never clean due to issues with MSIExec. Best to use a clean PC to install onto.

        5th, located in your C:\Users\%usersID%\AppData\Local\Temp there should be a log file that is created when the installer is running, before you cancel or stop the installer look for and open the file. Look for Access Denied or errors registering components etc. May help to determine what is being blocked or missing dependency. if you can't find the log then enable logging in MSIExec, search MS's site for how to.

        And if the installer fails go into C:\Program Files (x86)\SAP BusinessObjects and delate all files and folders, also look in your temp folders for any CR temp folders and files and delete.

        If there are report errors, like 1904, thos are MSIExec error codes, search Microsofts site for wha they mean.

        The use REGEDIT to remove all HKEY_CURRENT_USER\Software\SAP BusinessObjects and HKEY_LOCAL_MACHINE\SOFTWARE\SAP BusinessObjects. Or Export to file first just in case...

        Also note: some users Profiles have been corrupted, some users resolved this by deleting their profile on the PC and re-creating it. Check with your IT guys for more info on how to and what you loose when doing this.

         

        Finally, don't just say it fails, look for logs, look for any clues in the logs as to why it's failing, try looking in the Event logs as well as any AV and/or fire wall logs for access denied or similar types of errors.

        Millions of users don't have problems so it is your local PC environment with the issue and a little digging usually finds the cause.

         

        There is always a reason why it fails, you just have to look for them.

         

        OF course A BIG WARNING, back up everything first before making any changes or deletions to your file system and local registry.

         

        Finally if all else fails and you don't need anything on your PC and you have EVERYTHING backed up I like to use FDISK to wipe the hard drive and start over. It could be you may even have a virus running that you are not aware of and it's blocking the install....

         

        Good luck

        Don

  • Re: Why am I unable to install Crystal Reports 2011?
    Christopher Bacon
    Currently Being Moderated

    I cannot even get the setup.exe to run and SAP have a really terrible support.  I emails my problem and they give me support line number.  Call support line they tell me to go to this website.  Looks like you have to help yourself by looking through 1,000 of postings to find someone with same problem as you.