8 Replies Latest reply: May 20, 2008 4:29 AM by Albert Lee RSS

How to reduce the spacing between words

Albert Lee
Currently Being Moderated

Hi all,


I need to create a form using smartform.


The problem is, the spacing between words are too wide for my form comparing to the original paper form.


I am using the same font (Times) as the original, but the spacing between words in my new form is much wider than the original one, resulting in a single line sentence in the original form overflow into second line in my new form.


I cannot find any setting to reduce the distances between words (not individual characters)


How can I do it, anybody can help on this?




  • Re: How to reduce the spacing between words
    jagadeeshwar bachu
    Currently Being Moderated



    pls add 'C' (Condence ) in variable.




  • Re: How to reduce the spacing between words
    shiva kumar
    Currently Being Moderated


    use &ekpo-ebeln(C)& it is for reducing the space...


    if you are trying to codense the space in prog and then want to pass that to script use


    condense ekpo-ebeln <no-gaps>.

    <no-gaps> is optional ...so as per your requirement you can use it



    Shiva Kumar

    • Re: How to reduce the spacing between words
      Albert Lee
      Currently Being Moderated

      Hi Shiva,


      "use &ekpo-ebeln(C)& it is for reducing the space..."


      I do not understand &ekpo-ebeln(C)&, is this field a standard field or i need to declare it at the global variable? Does it contain all the text in my form?


      I have tried condense, condense is to reduce the space between words to 1 space.


      No-gaps doesn't help, it removed all the spaces between my words and making them unreadable.


      it seems that my words are already having 1 space in between, except the width of the one space is big, So the problem is how do I reduce the width of the space?


      For example, the gap between my words are 2mm, how do i reduce it to 1mm?




      I have tried the style. The character per inch only used to calculate the length if i use character for calculation.


      I found out a work around, which is to set the tab to 1mm, then instead of using space after typing each word, i use tab... but this is very tedious, anybody knows the correct way to reduce the space?




      • Re: How to reduce the spacing between words
        Satya Phani Kumar Pilli
        Currently Being Moderated

        For your paragraph format in style check the indent & spacing tab & check the spacing options.


        & i think no need to use tabs if once you do at spacing.




        • Re: How to reduce the spacing between words
          Albert Lee
          Currently Being Moderated

          Hi Guys,


          I appreicate your help to try and find a solution to this problem.


          As I have mentioned earlier, CPI is not useful, it does not change anything even if i set it to 50 CPI. I believed the problem is my page format is using DINA4, it is using MM as unit, not characters. I cannot change to other format as my client printer is using this.


          The help file on CPI said it is used for calculating absolute distant. I have paste the explaination below.


          [Quote] Number of characters per inch (CPI) in the form. If the unit "characters" is used for horizontal length entries in the definition of the form or style, the absolute length is calculated from this value.


          Example: If the first line of a paragraph has an indent of "5 characters" and the CPI value of the form is 10, the indent of the first line is 1/2 inch in absolute units.[/Quote]


          Therefore I would appreciate to those who suggest changing CPI in the future will be able to give me a working example?





          The spacing in the paragraph format is for the space between the lines, not between words. The space before and after is the distance before and after a paragraph and the page, like an indent.




  • Re: How to reduce the spacing between words
    surya v
    Currently Being Moderated



    u mean reduce the space between words, plea trye like this also,


    for that perticular text u maintaine the new style with reduce the  tab space, charecters per inch in that perticular style.





  • Re: How to reduce the spacing between words
    silpa sanagala
    Currently Being Moderated

    Go to the smart style u have chosen( goto smart forms>global settings>output options

    here u can find style.


    go to Transaction smart forms select the radio button style give the name of ur style

    Go to Header data-->standard settings

    here u can find characters per inch

    try modifying this


    keep 12 or more char per inch